aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2013-01-23 10:43:16 +0800
committerswills <swills@FreeBSD.org>2013-01-23 10:43:16 +0800
commit86132f8e25a54011c824ac70fdb1f91f8963521d (patch)
tree736abcaed5ee12a281cae3483d9904954a00b370 /www
parentf162c96826673fba82ea4611b6d6e32a260a4f64 (diff)
downloadfreebsd-ports-gnome-86132f8e25a54011c824ac70fdb1f91f8963521d.tar.gz
freebsd-ports-gnome-86132f8e25a54011c824ac70fdb1f91f8963521d.tar.zst
freebsd-ports-gnome-86132f8e25a54011c824ac70fdb1f91f8963521d.zip
Add rubygem-async_sinatra 1.0.0, a Sinatra plugin to provide async
responses. PR: ports/172117 Submitted by: Kimo <kimor79@yahoo.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-async_sinatra/Makefile19
-rw-r--r--www/rubygem-async_sinatra/distinfo2
-rw-r--r--www/rubygem-async_sinatra/pkg-descr7
4 files changed, 29 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 7b5d4b13553d..306cbc1a835d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1694,6 +1694,7 @@
SUBDIR += rubygem-addressable
SUBDIR += rubygem-amazon-ecs
SUBDIR += rubygem-anemone
+ SUBDIR += rubygem-async_sinatra
SUBDIR += rubygem-bluecloth
SUBDIR += rubygem-cgi_multipart_eof_fix
SUBDIR += rubygem-chef-server-api
diff --git a/www/rubygem-async_sinatra/Makefile b/www/rubygem-async_sinatra/Makefile
new file mode 100644
index 000000000000..491d3ea8766d
--- /dev/null
+++ b/www/rubygem-async_sinatra/Makefile
@@ -0,0 +1,19 @@
+# Created by: Kimo <kimor79@yahoo.com>
+# $FreeBSD$
+
+PORTNAME= async_sinatra
+PORTVERSION= 1.0.0
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= A Sinatra plugin to provide async responses
+
+RUN_DEPENDS= rubygem-rack>=1.4.1:${PORTSDIR}/www/rubygem-rack \
+ rubygem-sinatra>=1.3.2:${PORTSDIR}/www/rubygem-sinatra
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-async_sinatra/distinfo b/www/rubygem-async_sinatra/distinfo
new file mode 100644
index 000000000000..863ad919821c
--- /dev/null
+++ b/www/rubygem-async_sinatra/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/async_sinatra-1.0.0.gem) = 2ae0d764f2edff215a4b8cf289422da0eaf82ee99ab070892273a2a81d4ed10b
+SIZE (rubygem/async_sinatra-1.0.0.gem) = 10752
diff --git a/www/rubygem-async_sinatra/pkg-descr b/www/rubygem-async_sinatra/pkg-descr
new file mode 100644
index 000000000000..097ae5f58459
--- /dev/null
+++ b/www/rubygem-async_sinatra/pkg-descr
@@ -0,0 +1,7 @@
+A Sinatra plugin to provide convenience whilst performing asynchronous
+responses inside of the Sinatra framework running under async webservers. To
+properly utilise this package, some knowledge of EventMachine and/or
+asynchronous patterns is recommended. Currently, supporting servers include
+Thin, Rainbows, Zbatery.
+
+WWW: http://github.com/raggi/async_sinatra