aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2004-08-11 09:27:37 +0800
committerlofi <lofi@FreeBSD.org>2004-08-11 09:27:37 +0800
commit864e9b668c7ed19626e92e91ce653b0426e8a652 (patch)
tree790eb38840233721a33b0ae2dcaaebb416020301 /www
parent73eb1b5f64621d1b69dbde88fc44e81f1bd5f32d (diff)
downloadfreebsd-ports-gnome-864e9b668c7ed19626e92e91ce653b0426e8a652.tar.gz
freebsd-ports-gnome-864e9b668c7ed19626e92e91ce653b0426e8a652.tar.zst
freebsd-ports-gnome-864e9b668c7ed19626e92e91ce653b0426e8a652.zip
Factor out all but one of the build switches of the KDE main module ports
into separate ports. The OPTIONS will remain as of yet and trigger dependencies now, for easy transition. Update KOffice to version 1.3.2. Add patches to fix a number of issues, including: - fix kxkb on Xorg - fix kdemultimedia WITH_MPEGLIB (now mpeglib_artsplug) compilation on gcc 3.4.2 with optimizations greater than -O Add security related patches and entries to portaudit.txt.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/konqueror-nsplugins/Makefile40
-rw-r--r--www/konqueror-nsplugins/distinfo2
-rw-r--r--www/konqueror-nsplugins/files/patch-nsplugins-pluginscan.cpp10
-rw-r--r--www/konqueror-nsplugins/pkg-descr2
-rw-r--r--www/konqueror-nsplugins/pkg-plist7
6 files changed, 62 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 9cd8a6bdf2be..aa6b1fa3cc28 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -175,6 +175,7 @@
SUBDIR += junkbuster
SUBDIR += kannel
SUBDIR += knowledgekit
+ SUBDIR += konqueror-nsplugins
SUBDIR += larbin
SUBDIR += libghttp
SUBDIR += libgtkhtml
diff --git a/www/konqueror-nsplugins/Makefile b/www/konqueror-nsplugins/Makefile
new file mode 100644
index 000000000000..198b10f19df1
--- /dev/null
+++ b/www/konqueror-nsplugins/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: konqueror-nsplugins
+# Date created: June 19 2004
+# Whom: Michael Nottebrock <lofi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= konqueror-nsplugins
+PORTVERSION= ${KDE_VERSION}
+CATEGORIES= www kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
+PKGNAMEPREFIX= kdebase-
+DISTNAME= kdebase-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Netscape plugin support for Konqueror
+
+CONFLICTS= kdebase-3.1.* kdebase-3.2.[0-3]
+
+USE_KDELIBS_VER=3
+PREFIX= ${KDE_PREFIX}
+
+USE_MOTIF= yes
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/kdebase-${PORTVERSION}
+
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
+
+pre-configure:
+ ${ECHO_CMD} "nsplugins" > ${WRKSRC}/inst-apps
+ ${REINPLACE_CMD} -e \
+ 's/startkde//g' ${WRKSRC}/Makefile.in
+
+.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include <bsd.port.mk>
diff --git a/www/konqueror-nsplugins/distinfo b/www/konqueror-nsplugins/distinfo
new file mode 100644
index 000000000000..25dba8c07361
--- /dev/null
+++ b/www/konqueror-nsplugins/distinfo
@@ -0,0 +1,2 @@
+MD5 (KDE/kdebase-3.2.3.tar.bz2) = fd05a338d155610856b06988d8dff117
+SIZE (KDE/kdebase-3.2.3.tar.bz2) = 17330422
diff --git a/www/konqueror-nsplugins/files/patch-nsplugins-pluginscan.cpp b/www/konqueror-nsplugins/files/patch-nsplugins-pluginscan.cpp
new file mode 100644
index 000000000000..55eed7247922
--- /dev/null
+++ b/www/konqueror-nsplugins/files/patch-nsplugins-pluginscan.cpp
@@ -0,0 +1,10 @@
+--- nsplugins/pluginscan.cpp.orig Sat Mar 13 21:07:58 2004
++++ nsplugins/pluginscan.cpp Sat Mar 13 21:08:50 2004
+@@ -457,6 +457,7 @@
+ paths.append("/usr/lib64/netscape/plugins");
+ paths.append("/usr/lib64/mozilla/plugins");
+ paths.append("$MOZILLA_HOME/plugins");
++ paths.append("/usr/local/lib/linux-flashplugin6");
+ config->writeEntry( "scanPaths", paths );
+ }
+
diff --git a/www/konqueror-nsplugins/pkg-descr b/www/konqueror-nsplugins/pkg-descr
new file mode 100644
index 000000000000..c503c42b1c40
--- /dev/null
+++ b/www/konqueror-nsplugins/pkg-descr
@@ -0,0 +1,2 @@
+This package enhances Konqueror with compatibility for browser plugins
+made for Netscape webbrowsers like Macromedia Flash.
diff --git a/www/konqueror-nsplugins/pkg-plist b/www/konqueror-nsplugins/pkg-plist
new file mode 100644
index 000000000000..df4e14f294a2
--- /dev/null
+++ b/www/konqueror-nsplugins/pkg-plist
@@ -0,0 +1,7 @@
+bin/nspluginscan
+bin/nspluginviewer
+lib/kde3/kcm_nsplugins.la
+lib/kde3/kcm_nsplugins.so
+lib/kde3/libnsplugin.la
+lib/kde3/libnsplugin.so
+share/applications/kde/khtml_plugins.desktop