aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2017-12-12 05:48:32 +0800
committerantoine <antoine@FreeBSD.org>2017-12-12 05:48:32 +0800
commit86c0546df7691e89929dbaaefbee0b502c6bbb12 (patch)
tree437ea2ab71b53041f6f4c748512cf722da16ecc4 /www
parent534b574e70136bd97502b070638f5a767ca8c50b (diff)
downloadfreebsd-ports-gnome-86c0546df7691e89929dbaaefbee0b502c6bbb12.tar.gz
freebsd-ports-gnome-86c0546df7691e89929dbaaefbee0b502c6bbb12.tar.zst
freebsd-ports-gnome-86c0546df7691e89929dbaaefbee0b502c6bbb12.zip
- Those ports fail to build with python3
- Add some explicit FLAVOR to dependencies where needed
Diffstat (limited to 'www')
-rw-r--r--www/bluefish/Makefile2
-rw-r--r--www/clearsilver/Makefile2
-rw-r--r--www/monast/Makefile2
-rw-r--r--www/py-fcgi/Makefile2
-rw-r--r--www/py-pyquery/Makefile2
-rw-r--r--www/twms/Makefile8
-rw-r--r--www/webcheck/Makefile2
7 files changed, 10 insertions, 10 deletions
diff --git a/www/bluefish/Makefile b/www/bluefish/Makefile
index 26600dcae45f..e3710466ef51 100644
--- a/www/bluefish/Makefile
+++ b/www/bluefish/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpcre.so:devel/pcre \
libenchant.so:textproc/enchant
-USES= desktop-file-utils gettext gmake libtool localbase pkgconfig python \
+USES= desktop-file-utils gettext gmake libtool localbase pkgconfig python:2.7 \
shared-mime-info shebangfix tar:bzip2
SHEBANG_FILES= data/css_decompressor
python_OLD_CMD= /usr/bin/python2.7
diff --git a/www/clearsilver/Makefile b/www/clearsilver/Makefile
index f54ca91f3e8c..37f0872ce8d3 100644
--- a/www/clearsilver/Makefile
+++ b/www/clearsilver/Makefile
@@ -17,7 +17,7 @@ CONFIGURE_ARGS= --disable-apache --disable-perl --disable-ruby \
.if defined(WITH_PYTHON)
CONFIGURE_ARGS+= --with-python=${PYTHON_CMD}
-USES+= python
+USES+= python:2.7
PLIST_SUB+= PYTHON=""
PKGNAMESUFFIX= -python
.else
diff --git a/www/monast/Makefile b/www/monast/Makefile
index c73364c8e5c1..6e5b818c2da5 100644
--- a/www/monast/Makefile
+++ b/www/monast/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF/monast/MonAst%20for%20Asterisk%201.4_1.6/1.4
MAINTAINER= ports@FreeBSD.org
COMMENT= Monitoring and an operator panel interface for AsteriskTM
-USES= python
+USES= python:2.7
USE_RC_SUBR= monast
NO_BUILD= yes
diff --git a/www/py-fcgi/Makefile b/www/py-fcgi/Makefile
index ad1fcccbc26b..db3f308a390b 100644
--- a/www/py-fcgi/Makefile
+++ b/www/py-fcgi/Makefile
@@ -14,7 +14,7 @@ EXTRACT_ONLY= #
MAINTAINER= ports@FreeBSD.org
COMMENT= Python FastCGI interface library
-USES= python
+USES= python:2.7
NO_WRKSUBDIR= yes
post-extract:
diff --git a/www/py-pyquery/Makefile b/www/py-pyquery/Makefile
index f9eded270850..6faf56535acd 100644
--- a/www/py-pyquery/Makefile
+++ b/www/py-pyquery/Makefile
@@ -27,7 +27,7 @@ USES= python:2.7 zip
USE_PYTHON= autoplist distutils
NO_ARCH= yes
-DOCS_BUILD_DEPENDS= sphinx-build:textproc/py-sphinx
+DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0:textproc/py-sphinx@${FLAVOR}
DOCS_VARS= PYDISTUTILS_BUILD_TARGET+="build_sphinx -a -E"
post-install-DOCS-on:
diff --git a/www/twms/Makefile b/www/twms/Makefile
index 9851b576bb95..bd34f718fc7c 100644
--- a/www/twms/Makefile
+++ b/www/twms/Makefile
@@ -12,14 +12,14 @@ COMMENT= Tiny WMS server
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pyproj/__init__.py:graphics/py-pyproj \
- ${PYTHON_SITELIBDIR}/web/__init__.py:www/webpy \
- ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyproj>0:graphics/py-pyproj@${PY_FLAVOR} \
+ ${PYTHON_SITELIBDIR}/web/__init__.py:www/webpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
USE_GITHUB= yes
GH_ACCOUNT= Komzpa
-USES= python shebangfix tar:bzip2
+USES= python:2.7 shebangfix tar:bzip2
SHEBANG_FILES= twms.py
NO_BUILD= yes
NO_ARCH= yes
diff --git a/www/webcheck/Makefile b/www/webcheck/Makefile
index 32a795ab35dd..3fcc71a1ec40 100644
--- a/www/webcheck/Makefile
+++ b/www/webcheck/Makefile
@@ -11,7 +11,7 @@ EXTRACT_SUFX= .tar.gz
MAINTAINER= reed@reedmedia.net
COMMENT= View structure of a web site, get a list of problems like broken links
-USES= python
+USES= python:2.7
NO_BUILD= yes
# what about fancytooltips?