aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2010-01-06 06:06:43 +0800
committerosa <osa@FreeBSD.org>2010-01-06 06:06:43 +0800
commit8dac272dc3c1946696c49d5b617b35bc27d0d8a9 (patch)
treeaa9181cd7c41faab7c46b7ffda9d7399b3304911 /www
parent03aefe6f79e7a6ccc58b2a0f15326bf34453c5ae (diff)
downloadfreebsd-ports-gnome-8dac272dc3c1946696c49d5b617b35bc27d0d8a9.tar.gz
freebsd-ports-gnome-8dac272dc3c1946696c49d5b617b35bc27d0d8a9.tar.zst
freebsd-ports-gnome-8dac272dc3c1946696c49d5b617b35bc27d0d8a9.zip
Accordingly commit changes for third-party modules in www/nginx
and www/nginx-devel: o) update uploadprogress from 0.7 to 0.8; o) update upstream_fair from 20081012 to 20090923; o) update supervisord from 1.2 to 1.3; o) add udplog (syslog) module version 1.0.0; o) s/modle/module/ for both Makefiles. Remove needless patches. Do not bump PORTREVISIONs.
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile22
-rw-r--r--www/nginx-devel/distinfo21
-rw-r--r--www/nginx-devel/files/extra-patch-ngx_http_uploadprogress_module.c12
-rw-r--r--www/nginx/Makefile22
-rw-r--r--www/nginx/distinfo21
-rw-r--r--www/nginx/files/extra-patch-ngx_http_uploadprogress_module.c12
6 files changed, 50 insertions, 60 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index f4f04df3cbf6..c4a217fda6ac 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -63,7 +63,8 @@ OPTIONS= DEBUG "Enable nginx debugging" off \
HTTP_ZIP_MODULE "3rd party http_zip module" off \
PASSENGER_MODULE "3rd party passenger module" off \
SLOWFS_CACHE_MODULE "3rd party slowfs_cache module" off \
- SUPERVISORD_MODULE "3rd party supervisord modle" off
+ SUPERVISORD_MODULE "3rd party supervisord module" off \
+ UDPLOG_MODULE "3rd party udplog (syslog) module" off
WANT_GNOME= yes
MAKE_JOBS_SAFE= yes
@@ -283,7 +284,7 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx_upload_module-${NGINX_UPLOAD_MODULE
.endif
.if defined(WITH_HTTP_UPLOAD_PROGRESS)
-NGINX_UPLOADPROGRESS_MODULE_VERSION= 0.7
+NGINX_UPLOADPROGRESS_MODULE_VERSION= 0.8
MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:uploadprogress/}
MASTER_SITE_SUBDIR+= osa/:uploadprogress
DISTFILES+= nginx_uploadprogress_module-${NGINX_UPLOADPROGRESS_MODULE_VERSION}.tar.gz:uploadprogress
@@ -291,7 +292,7 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx_uploadprogress_module-${NGINX_UPLOA
.endif
.if defined(WITH_HTTP_UPSTREAM_FAIR) || defined(WITH_SUPERVISORD_MODULE)
-NGINX_UPSTREAM_FAIR_VERSION= 20081012
+NGINX_UPSTREAM_FAIR_VERSION= 20090923
MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:upstreamfair/}
MASTER_SITE_SUBDIR+= osa/:upstreamfair
DISTFILES+= nginx_upstream_fair-${NGINX_UPSTREAM_FAIR_VERSION}.tar.gz:upstreamfair
@@ -342,12 +343,19 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_slowfs_cache-${NGINX_SLOWFS_CACHE_MOD
.endif
.if defined(WITH_SUPERVISORD_MODULE)
-NGINX_SUPERVISORD_MODULE_VERSION= 1.2
+NGINX_SUPERVISORD_MODULE_VERSION= 1.3
MASTER_SITES+= http://labs.frickle.com/files/:supervisord
DISTFILES+= ngx_supervisord-${NGINX_SUPERVISORD_MODULE_VERSION}.tar.gz:supervisord
CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_supervisord-${NGINX_SUPERVISORD_MODULE_VERSION}
.endif
+.if defined(WITH_UDPLOG_MODULE)
+NGINX_UDPLOG_MODULE_VERSION= 1.0.0
+MASTER_SITES+= http://www.grid.net.ru/nginx/download/:udplog
+DISTFILES+= nginx_udplog_module-${NGINX_UDPLOG_MODULE_VERSION}.tar.gz:udplog
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx_udplog_module-${NGINX_UDPLOG_MODULE_VERSION}
+.endif
+
.if defined(WITH_WWW)
PLIST_SUB+= WWWDATA=""
.else
@@ -413,10 +421,6 @@ post-patch:
@${PATCH} ${PATCH_ARGS} < \
${PATCHDIR}/extra-patch-ngx_http_upload_module.c
.endif
-.if defined(WITH_HTTP_UPLOAD_PROGRESS)
- @${PATCH} ${PATCH_ARGS} < \
- ${PATCHDIR}/extra-patch-ngx_http_uploadprogress_module.c
-.endif
.if defined(WITH_PASSENGER_MODULE)
@${REINPLACE_CMD} 's!g++!${CXX}!' \
${WRKDIR}/passenger-${PASSENGER_VERSION}/Rakefile
@@ -425,7 +429,7 @@ post-patch:
${WRKDIR}/passenger-${PASSENGER_VERSION}/lib/phusion_passenger/platform_info.rb
.endif
.if defined(WITH_SUPERVISORD_MODULE)
- ( cd ${WRKDIR}/nginx_upstream_fair-20081012 && \
+ ( cd ${WRKDIR}/nginx_upstream_fair-${NGINX_UPSTREAM_FAIR_VERSION} && \
${PATCH} -p0 < \
${WRKDIR}/ngx_supervisord-${NGINX_SUPERVISORD_MODULE_VERSION}/patches/ngx_http_upstream_fair_module.patch )
( cd ${WRKSRC} && \
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index 82ee243ece18..292ff55307a5 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -37,12 +37,12 @@ SIZE (ngx_http_response-0.3.tar.gz) = 2244
MD5 (nginx_upload_module-2.0.11.tar.gz) = dd1d0f11201073938c8b4225d3aac9f9
SHA256 (nginx_upload_module-2.0.11.tar.gz) = 287c56a42b4cfe4ffc6466b550675fc0f705cf696833ed74af2be8a1cf021b39
SIZE (nginx_upload_module-2.0.11.tar.gz) = 20056
-MD5 (nginx_uploadprogress_module-0.7.tar.gz) = 427b7849d06465b3497ae60bf6731c37
-SHA256 (nginx_uploadprogress_module-0.7.tar.gz) = a3623629c43823e5dcf8b822157e9b02792ce68350c7235d6d752cc4f9ee59df
-SIZE (nginx_uploadprogress_module-0.7.tar.gz) = 15602
-MD5 (nginx_upstream_fair-20081012.tar.gz) = 1f7b4f3e47c32f89afac59fa60381dc4
-SHA256 (nginx_upstream_fair-20081012.tar.gz) = 4c2bd957168008e5b2397fad49824ca70f3685cf884e8d1be45d56c8e3bbe88c
-SIZE (nginx_upstream_fair-20081012.tar.gz) = 10021
+MD5 (nginx_uploadprogress_module-0.8.tar.gz) = dec48681e54a01195cc8dd2e0c71a5a0
+SHA256 (nginx_uploadprogress_module-0.8.tar.gz) = 7828410e79603de86a135084d60e74393df18894194b30af92ff144e6afeae13
+SIZE (nginx_uploadprogress_module-0.8.tar.gz) = 16364
+MD5 (nginx_upstream_fair-20090923.tar.gz) = a8443d779ee91db2290efc83832ac88d
+SHA256 (nginx_upstream_fair-20090923.tar.gz) = ec9ed7f856263e17faadee3dc7209932364ded4e546b829841c2454aa432450b
+SIZE (nginx_upstream_fair-20090923.tar.gz) = 10024
MD5 (ngx_http_upstream_keepalive-0.2.tar.gz) = 1d9663a22c25633b5ad1c8a0f6fea467
SHA256 (ngx_http_upstream_keepalive-0.2.tar.gz) = fdea0f46ce24c8889827993902659d41efa62b93b1a8000975a023209e138c2d
SIZE (ngx_http_upstream_keepalive-0.2.tar.gz) = 7092
@@ -55,6 +55,9 @@ SIZE (passenger-2.2.8.tar.gz) = 1993046
MD5 (ngx_slowfs_cache-1.2.tar.gz) = e79af4a6eecd7c385d76a92f814d0720
SHA256 (ngx_slowfs_cache-1.2.tar.gz) = 5e04bcdcde52d7958f397acdc4af2c1961e5384499e627400c1c2f166930fa1c
SIZE (ngx_slowfs_cache-1.2.tar.gz) = 9610
-MD5 (ngx_supervisord-1.2.tar.gz) = eb21b2d927a027c94da35af984db6371
-SHA256 (ngx_supervisord-1.2.tar.gz) = c4fcf58639b98a7dcdc923d4eff75f90a07c15b05fc44c6d9aa5d41c6810a126
-SIZE (ngx_supervisord-1.2.tar.gz) = 15209
+MD5 (ngx_supervisord-1.3.tar.gz) = d632977d94f0d8cfffcf3fe7bd83e2ce
+SHA256 (ngx_supervisord-1.3.tar.gz) = d168e4bd5c4d5cbcaa23c924a0259a63ce0cf99ca204d9eba1a8931cd0ba46af
+SIZE (ngx_supervisord-1.3.tar.gz) = 18750
+MD5 (nginx_udplog_module-1.0.0.tar.gz) = dc211933806fd325fa0a204df3369ba8
+SHA256 (nginx_udplog_module-1.0.0.tar.gz) = e0c0bfa524c3a675ad6c08b916d08e57ef45f9818cb8a0d848c2c83785c6e659
+SIZE (nginx_udplog_module-1.0.0.tar.gz) = 6284
diff --git a/www/nginx-devel/files/extra-patch-ngx_http_uploadprogress_module.c b/www/nginx-devel/files/extra-patch-ngx_http_uploadprogress_module.c
deleted file mode 100644
index 13949c8f6e6e..000000000000
--- a/www/nginx-devel/files/extra-patch-ngx_http_uploadprogress_module.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- ../nginx_uploadprogress_module-0.7/ngx_http_uploadprogress_module.c.orig 2009-11-21 21:48:48.000000000 +0300
-+++ ../nginx_uploadprogress_module-0.7/ngx_http_uploadprogress_module.c 2009-12-19 13:09:52.000000000 +0300
-@@ -1475,6 +1475,9 @@
-
- ngx_memzero(&sc, sizeof(ngx_http_script_compile_t));
-
-+ t->lengths = NULL;
-+ t->values = NULL;
-+
- sc.cf = cf;
- sc.source = source;
- sc.lengths = &t->lengths;
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index c9da30e12a0a..2ac1ef30257b 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -60,7 +60,8 @@ OPTIONS= DEBUG "Build with debug" off \
HTTP_ZIP_MODULE "3rd party http_zip module" off \
PASSENGER_MODULE "3rd party passenger module" off \
SLOWFS_CACHE_MODULE "3rd party slowfs_cache module" off \
- SUPERVISORD_MODULE "3rd party supervisord modle" off
+ SUPERVISORD_MODULE "3rd party supervisord module" off \
+ UDPLOG_MODULE "3rd party updlog (syslog) module" off
WANT_GNOME= yes
MAKE_JOBS_SAFE= yes
@@ -271,7 +272,7 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx_upload_module-${NGINX_UPLOAD_MODULE
.endif
.if defined(WITH_HTTP_UPLOAD_PROGRESS)
-NGINX_UPLOADPROGRESS_MODULE_VERSION= 0.7
+NGINX_UPLOADPROGRESS_MODULE_VERSION= 0.8
MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:uploadprogress/}
MASTER_SITE_SUBDIR+= osa/:uploadprogress
DISTFILES+= nginx_uploadprogress_module-${NGINX_UPLOADPROGRESS_MODULE_VERSION}.tar.gz:uploadprogress
@@ -279,7 +280,7 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx_uploadprogress_module-${NGINX_UPLOA
.endif
.if defined(WITH_HTTP_UPSTREAM_FAIR) || defined(WITH_SUPERVISORD_MODULE)
-NGINX_UPSTREAM_FAIR_VERSION= 20081012
+NGINX_UPSTREAM_FAIR_VERSION= 20090923
MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:upstreamfair/}
MASTER_SITE_SUBDIR+= osa/:upstreamfair
DISTFILES+= nginx_upstream_fair-${NGINX_UPSTREAM_FAIR_VERSION}.tar.gz:upstreamfair
@@ -330,12 +331,19 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_slowfs_cache-${NGINX_SLOWFS_CACHE_MOD
.endif
.if defined(WITH_SUPERVISORD_MODULE)
-NGINX_SUPERVISORD_MODULE_VERSION= 1.2
+NGINX_SUPERVISORD_MODULE_VERSION= 1.3
MASTER_SITES+= http://labs.frickle.com/files/:supervisord
DISTFILES+= ngx_supervisord-${NGINX_SUPERVISORD_MODULE_VERSION}.tar.gz:supervisord
CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_supervisord-${NGINX_SUPERVISORD_MODULE_VERSION}
.endif
+.if defined(WITH_UDPLOG_MODULE)
+NGINX_UDPLOG_MODULE_VERSION= 1.0.0
+MASTER_SITES+= http://www.grid.net.ru/nginx/download/:udplog
+DISTFILES+= nginx_udplog_module-${NGINX_UDPLOG_MODULE_VERSION}.tar.gz:udplog
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx_udplog_module-${NGINX_UDPLOG_MODULE_VERSION}
+.endif
+
.if defined(WITH_WWW)
PLIST_SUB+= WWWDATA=""
.else
@@ -397,10 +405,6 @@ post-patch:
@${PATCH} ${PATCH_ARGS} < \
${PATCHDIR}/extra-patch-ngx_http_notice_module.c
.endif
-.if defined(WITH_HTTP_UPLOAD_PROGRESS)
- @${PATCH} ${PATCH_ARGS} < \
- ${PATCHDIR}/extra-patch-ngx_http_uploadprogress_module.c
-.endif
.if defined(WITH_PASSENGER_MODULE)
@${REINPLACE_CMD} 's!g++!${CXX}!' \
${WRKDIR}/passenger-${PASSENGER_VERSION}/Rakefile
@@ -409,7 +413,7 @@ post-patch:
${WRKDIR}/passenger-${PASSENGER_VERSION}/lib/phusion_passenger/platform_info.rb
.endif
.if defined(WITH_SUPERVISORD_MODULE)
- ( cd ${WRKDIR}/nginx_upstream_fair-20081012 && \
+ ( cd ${WRKDIR}/nginx_upstream_fair-${NGINX_UPSTREAM_FAIR_VERSION} && \
${PATCH} -p0 < \
${WRKDIR}/ngx_supervisord-${NGINX_SUPERVISORD_MODULE_VERSION}/patches/ngx_http_upstream_fair_module.patch )
( cd ${WRKSRC} && \
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index b398cd95fe3d..c62e3b173df4 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -37,12 +37,12 @@ SIZE (ngx_http_response-0.3.tar.gz) = 2244
MD5 (nginx_upload_module-2.0.11.tar.gz) = dd1d0f11201073938c8b4225d3aac9f9
SHA256 (nginx_upload_module-2.0.11.tar.gz) = 287c56a42b4cfe4ffc6466b550675fc0f705cf696833ed74af2be8a1cf021b39
SIZE (nginx_upload_module-2.0.11.tar.gz) = 20056
-MD5 (nginx_uploadprogress_module-0.7.tar.gz) = 427b7849d06465b3497ae60bf6731c37
-SHA256 (nginx_uploadprogress_module-0.7.tar.gz) = a3623629c43823e5dcf8b822157e9b02792ce68350c7235d6d752cc4f9ee59df
-SIZE (nginx_uploadprogress_module-0.7.tar.gz) = 15602
-MD5 (nginx_upstream_fair-20081012.tar.gz) = 1f7b4f3e47c32f89afac59fa60381dc4
-SHA256 (nginx_upstream_fair-20081012.tar.gz) = 4c2bd957168008e5b2397fad49824ca70f3685cf884e8d1be45d56c8e3bbe88c
-SIZE (nginx_upstream_fair-20081012.tar.gz) = 10021
+MD5 (nginx_uploadprogress_module-0.8.tar.gz) = dec48681e54a01195cc8dd2e0c71a5a0
+SHA256 (nginx_uploadprogress_module-0.8.tar.gz) = 7828410e79603de86a135084d60e74393df18894194b30af92ff144e6afeae13
+SIZE (nginx_uploadprogress_module-0.8.tar.gz) = 16364
+MD5 (nginx_upstream_fair-20090923.tar.gz) = a8443d779ee91db2290efc83832ac88d
+SHA256 (nginx_upstream_fair-20090923.tar.gz) = ec9ed7f856263e17faadee3dc7209932364ded4e546b829841c2454aa432450b
+SIZE (nginx_upstream_fair-20090923.tar.gz) = 10024
MD5 (ngx_http_upstream_keepalive-0.2.tar.gz) = 1d9663a22c25633b5ad1c8a0f6fea467
SHA256 (ngx_http_upstream_keepalive-0.2.tar.gz) = fdea0f46ce24c8889827993902659d41efa62b93b1a8000975a023209e138c2d
SIZE (ngx_http_upstream_keepalive-0.2.tar.gz) = 7092
@@ -55,6 +55,9 @@ SIZE (passenger-2.2.8.tar.gz) = 1993046
MD5 (ngx_slowfs_cache-1.2.tar.gz) = e79af4a6eecd7c385d76a92f814d0720
SHA256 (ngx_slowfs_cache-1.2.tar.gz) = 5e04bcdcde52d7958f397acdc4af2c1961e5384499e627400c1c2f166930fa1c
SIZE (ngx_slowfs_cache-1.2.tar.gz) = 9610
-MD5 (ngx_supervisord-1.2.tar.gz) = eb21b2d927a027c94da35af984db6371
-SHA256 (ngx_supervisord-1.2.tar.gz) = c4fcf58639b98a7dcdc923d4eff75f90a07c15b05fc44c6d9aa5d41c6810a126
-SIZE (ngx_supervisord-1.2.tar.gz) = 15209
+MD5 (ngx_supervisord-1.3.tar.gz) = d632977d94f0d8cfffcf3fe7bd83e2ce
+SHA256 (ngx_supervisord-1.3.tar.gz) = d168e4bd5c4d5cbcaa23c924a0259a63ce0cf99ca204d9eba1a8931cd0ba46af
+SIZE (ngx_supervisord-1.3.tar.gz) = 18750
+MD5 (nginx_udplog_module-1.0.0.tar.gz) = dc211933806fd325fa0a204df3369ba8
+SHA256 (nginx_udplog_module-1.0.0.tar.gz) = e0c0bfa524c3a675ad6c08b916d08e57ef45f9818cb8a0d848c2c83785c6e659
+SIZE (nginx_udplog_module-1.0.0.tar.gz) = 6284
diff --git a/www/nginx/files/extra-patch-ngx_http_uploadprogress_module.c b/www/nginx/files/extra-patch-ngx_http_uploadprogress_module.c
deleted file mode 100644
index 13949c8f6e6e..000000000000
--- a/www/nginx/files/extra-patch-ngx_http_uploadprogress_module.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- ../nginx_uploadprogress_module-0.7/ngx_http_uploadprogress_module.c.orig 2009-11-21 21:48:48.000000000 +0300
-+++ ../nginx_uploadprogress_module-0.7/ngx_http_uploadprogress_module.c 2009-12-19 13:09:52.000000000 +0300
-@@ -1475,6 +1475,9 @@
-
- ngx_memzero(&sc, sizeof(ngx_http_script_compile_t));
-
-+ t->lengths = NULL;
-+ t->values = NULL;
-+
- sc.cf = cf;
- sc.source = source;
- sc.lengths = &t->lengths;