aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormfechner <mfechner@FreeBSD.org>2018-04-09 20:14:14 +0800
committermfechner <mfechner@FreeBSD.org>2018-04-09 20:14:14 +0800
commit92e26f937f7ecd7e80ffcc07e82b399e2d5d073e (patch)
treeb6d019e25dd290c1f742ceeaffc218b1cff7bca2 /www
parent4a85cad81fbcca52f9a2396543929edb7975bbfd (diff)
downloadfreebsd-ports-gnome-92e26f937f7ecd7e80ffcc07e82b399e2d5d073e.tar.gz
freebsd-ports-gnome-92e26f937f7ecd7e80ffcc07e82b399e2d5d073e.tar.zst
freebsd-ports-gnome-92e26f937f7ecd7e80ffcc07e82b399e2d5d073e.zip
Added required directory %%WWWDIR%%/tmp/cache/tracker with correct permissions to pkg-plist.
Made the file %%WWWDIR%%/piwik.js writeable for user www, as systemChecks of matomo complains if that file is not writeable. PR: 227364 Reviewed by: tz (mentor) Approved by: tz (maintainer, mentor) Differential Revision: https://reviews.freebsd.org/D15013
Diffstat (limited to 'www')
-rw-r--r--www/matomo/Makefile2
-rw-r--r--www/matomo/pkg-plist4
2 files changed, 5 insertions, 1 deletions
diff --git a/www/matomo/Makefile b/www/matomo/Makefile
index de74801c3851..284b2175adcb 100644
--- a/www/matomo/Makefile
+++ b/www/matomo/Makefile
@@ -2,6 +2,7 @@
PORTNAME= matomo
DISTVERSION= 3.4.0
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://builds.matomo.org/
PKGNAMEPREFIX= ${PHP_PKGNAMEPREFIX}
@@ -43,6 +44,7 @@ pre-install:
fi
do-install:
+ ${MKDIR} ${STAGEDIR}${WWWDIR}/tmp/cache/tracker
@(cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
.include <bsd.port.mk>
diff --git a/www/matomo/pkg-plist b/www/matomo/pkg-plist
index c0b4492ef71b..7e2752bc26c8 100644
--- a/www/matomo/pkg-plist
+++ b/www/matomo/pkg-plist
@@ -1401,7 +1401,7 @@
%%WWWDIR%%/misc/others/widget_example_lastvisits.html
%%WWWDIR%%/misc/proxy-hide-piwik-url/README.md
%%WWWDIR%%/misc/user/index.html
-%%WWWDIR%%/piwik.js
+@(%%WWWOWN%%,%%WWWGRP%%,) %%WWWDIR%%/piwik.js
%%WWWDIR%%/piwik.php
%%WWWDIR%%/plugins/API/API.php
%%WWWDIR%%/plugins/API/Controller.php
@@ -7818,5 +7818,7 @@
@dir %%WWWDIR%%/plugins/ExampleTheme/screenshots
@dir %%WWWDIR%%/vendor/symfony/console/Symfony/Component/Console/Resources
@dir %%WWWDIR%%/vendor/szymach/c-pchart/app/cache
+@dir(%%WWWOWN%%,%%WWWGRP%%,755) %%WWWDIR%%/tmp/cache/tracker
+@dir(%%WWWOWN%%,%%WWWGRP%%,755) %%WWWDIR%%/tmp/cache
@dir(%%WWWOWN%%,%%WWWGRP%%,755) %%WWWDIR%%/tmp
@dir(%%WWWOWN%%,%%WWWGRP%%,) %%WWWDIR%%/config