aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-02-02 22:42:53 +0800
committernork <nork@FreeBSD.org>2003-02-02 22:42:53 +0800
commit98453ef756317a009c94c7375f334a0ccea1af98 (patch)
treec4e5e3be160ff353f09d98aef17d496b03cd3d42 /www
parenta04a92afa2882a0928799a430d07d4a027ff95e3 (diff)
downloadfreebsd-ports-gnome-98453ef756317a009c94c7375f334a0ccea1af98.tar.gz
freebsd-ports-gnome-98453ef756317a009c94c7375f334a0ccea1af98.tar.zst
freebsd-ports-gnome-98453ef756317a009c94c7375f334a0ccea1af98.zip
Conditionalize libgnugetopt dependencies.
PR: ports/47752 Submitted by: Ports Fury
Diffstat (limited to 'www')
-rw-r--r--www/cadaver/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/www/cadaver/Makefile b/www/cadaver/Makefile
index b518fb1417dc..91fc5eaf0a49 100644
--- a/www/cadaver/Makefile
+++ b/www/cadaver/Makefile
@@ -13,20 +13,26 @@ MASTER_SITES= http://www.webdav.org/cadaver/
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
- expat.4:${PORTSDIR}/textproc/expat2 \
+LIB_DEPENDS= expat.4:${PORTSDIR}/textproc/expat2 \
neon.23:${PORTSDIR}/www/neon
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-netrc \
--with-expat
ALL_TARGET= cadaver
MAN1= cadaver.1
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.if !exists(/usr/include/getopt.h)
+LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LDFLAGS+= -lgnugetopt
+.endif
+
.if !defined(WITHOUT_OPENSSL)
USE_OPENSSL= yes
CONFIGURE_ARGS+= --with-ssl --with-force-ssl