aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-12-26 14:55:19 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-12-26 14:55:19 +0800
commit99b573761aa57f6f0f8113b32b707af0d1241413 (patch)
treeb5db3105c1ef4a94f27d63c5fa9dd696b66f14cc /www
parent7aea48175ad7154314f4b23bf159f03dfde0461b (diff)
downloadfreebsd-ports-gnome-99b573761aa57f6f0f8113b32b707af0d1241413.tar.gz
freebsd-ports-gnome-99b573761aa57f6f0f8113b32b707af0d1241413.tar.zst
freebsd-ports-gnome-99b573761aa57f6f0f8113b32b707af0d1241413.zip
- Update to 2.3.4
PR: ports/141389 Submitted by: Carsten Wiedmann <carsten_sttgt@gmx.de> Approved by: maintainer timeout (14 days)
Diffstat (limited to 'www')
-rw-r--r--www/mod_fcgid/Makefile27
-rw-r--r--www/mod_fcgid/distinfo6
-rw-r--r--www/mod_fcgid/files/patch-modules-fcgid-fcgid_conf.c (renamed from www/mod_fcgid/files/patch-fcgid_conf.c)6
-rw-r--r--www/mod_fcgid/files/pkg-message.in4
-rw-r--r--www/mod_fcgid/pkg-descr18
-rw-r--r--www/mod_fcgid/pkg-plist3
6 files changed, 40 insertions, 24 deletions
diff --git a/www/mod_fcgid/Makefile b/www/mod_fcgid/Makefile
index 1da1f6382bad..da8e374abcba 100644
--- a/www/mod_fcgid/Makefile
+++ b/www/mod_fcgid/Makefile
@@ -6,19 +6,27 @@
#
PORTNAME= mod_fcgid
-PORTVERSION= 2.2
+PORTVERSION= 2.3.4
CATEGORIES= www
-MASTER_SITES= SF/mod-fcgid/OldFiles
-DISTNAME= ${PORTNAME}.${PORTVERSION}
+MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= hemi@puresimplicity.net
COMMENT= An alternative FastCGI module for Apache2
-MAKE_JOBS_SAFE= yes
+MAKE_JOBS_SAFE= yes
USE_APACHE= 2.0+
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT= configure.apxs
+
+INSTALL_WRKSRC= ${WRKSRC}/modules/fcgid
+
SUB_FILES= pkg-message
+SUB_LIST+= APACHEMODDIR=${APACHEMODDIR}
+PLIST_SUB+= APACHEMODDIR=${APACHEMODDIR}
.include <bsd.port.pre.mk>
@@ -26,17 +34,20 @@ SUB_FILES= pkg-message
MAKE_ARGS+= top_dir="${LOCALBASE}/share/apache${APACHE_VERSION}"
MAKE_ARGS+= INCLUDES="-I${LOCALBASE}/include/apache${APACHE_VERSION} -I${LOCALBASE}/include/apr-1"
INSTALL_TARGET= install-modules-yes
-PLIST_SUB+= APACHE_VERSION=${APACHE_VERSION}
-SUB_LIST+= APACHE_VERSION=${APACHE_VERSION}
+DOCSDIR= ${PREFIX}/share/doc/apache22/mod
.else
MAKE_ARGS+= top_dir="${LOCALBASE}/share/apache${APACHE_VERSION:S/20/2/}"
MAKE_ARGS+= INCLUDES="-I${LOCALBASE}/include/apache${APACHE_VERSION:S/20/2/}"
INSTALL_TARGET= install-modules
-PLIST_SUB+= APACHE_VERSION=${APACHE_VERSION:S/20/2/}
-SUB_LIST+= APACHE_VERSION=${APACHE_VERSION:S/20/2/}
+DOCSDIR= ${PREFIX}/share/doc/apache2/mod
.endif
post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/docs/manual/mod/mod_fcgid.html ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/docs/manual/mod/mod_fcgid.html.en ${DOCSDIR}
+.endif
${MKDIR} -m 700 /var/run/fcgidsock
${CHOWN} www:www /var/run/fcgidsock
@${CAT} ${PKGMESSAGE}
diff --git a/www/mod_fcgid/distinfo b/www/mod_fcgid/distinfo
index e2873503697e..3cb840ea8572 100644
--- a/www/mod_fcgid/distinfo
+++ b/www/mod_fcgid/distinfo
@@ -1,3 +1,3 @@
-MD5 (mod_fcgid.2.2.tar.gz) = ce7d7b16e69643dbd549d43d85025983
-SHA256 (mod_fcgid.2.2.tar.gz) = 7a0985a120dceb4c6974e8bf216752b0b763ae949f5dfbbf93cc350510e4c80e
-SIZE (mod_fcgid.2.2.tar.gz) = 56954
+MD5 (mod_fcgid-2.3.4.tar.gz) = 3778c0710ae4d750d87dddee70990681
+SHA256 (mod_fcgid-2.3.4.tar.gz) = 139cb06f766fac2bb2ad583272b5e786316f4b935e072256b6f45cecd8b6df1b
+SIZE (mod_fcgid-2.3.4.tar.gz) = 94417
diff --git a/www/mod_fcgid/files/patch-fcgid_conf.c b/www/mod_fcgid/files/patch-modules-fcgid-fcgid_conf.c
index 74a07b44e12b..f1adc418cf88 100644
--- a/www/mod_fcgid/files/patch-fcgid_conf.c
+++ b/www/mod_fcgid/files/patch-modules-fcgid-fcgid_conf.c
@@ -1,6 +1,6 @@
---- fcgid_conf.c.orig 2007-07-31 04:09:20.000000000 -0500
-+++ fcgid_conf.c 2007-10-08 08:17:12.000000000 -0500
-@@ -17,8 +17,8 @@
+--- modules/fcgid/fcgid_conf.c.orig 2009-10-07 05:16:08.000000000 +0200
++++ modules/fcgid/fcgid_conf.c 2009-12-11 16:18:09.000000000 +0100
+@@ -35,8 +35,8 @@
#define DEFAULT_ERROR_SCAN_INTERVAL 3
#define DEFAULT_ZOMBIE_SCAN_INTERVAL 3
#define DEFAULT_PROC_LIFETIME (60*60)
diff --git a/www/mod_fcgid/files/pkg-message.in b/www/mod_fcgid/files/pkg-message.in
index 44a21ca8d934..25838e2a4cb6 100644
--- a/www/mod_fcgid/files/pkg-message.in
+++ b/www/mod_fcgid/files/pkg-message.in
@@ -7,4 +7,8 @@ lines to your server configuration file:
<IfModule mod_fcgid.c>
AddHandler fcgid-script .fcgi
</IfModule>
+
+If you are upgrading from mod_fcgid 2.2, you have to rename
+the directives you have used in the config files:
+http://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html#upgrade
************************************************************
diff --git a/www/mod_fcgid/pkg-descr b/www/mod_fcgid/pkg-descr
index 84c664b6d108..20d4377d1683 100644
--- a/www/mod_fcgid/pkg-descr
+++ b/www/mod_fcgid/pkg-descr
@@ -1,11 +1,9 @@
-mod_fcgid -- an alternative FastCGI module for Apache2
+mod_fcgid is a high performance alternative to mod_cgi or mod_cgid,
+which starts a sufficient number instances of the CGI program to
+handle concurrent requests, and these programs remain running to
+handle further incoming requests. It is favored by the PHP developers,
+for example, as a preferred alternative to running mod_php in-process,
+delivering very similar performance.
-mod_fcgid has a new process management strategy, which concentrates on
-reducing the number of fastcgi server, and kick out the corrupt
-fastcgi server as soon as possible.
-
-mod_fcgid is binary-compatible with mod_fastcgi so your existing fastcgi
-programs do not need to be recompiled. mod_fcgid supports suEXEC.
-
-License: GPL
-WWW: http://fastcgi.coremail.cn/
+License: Apache License
+WWW: http://httpd.apache.org/mod_fcgid/
diff --git a/www/mod_fcgid/pkg-plist b/www/mod_fcgid/pkg-plist
index e5008c69d220..8cee86c0e0df 100644
--- a/www/mod_fcgid/pkg-plist
+++ b/www/mod_fcgid/pkg-plist
@@ -1,4 +1,7 @@
%%APACHEMODDIR%%/mod_fcgid.so
+%%PORTDOCS%%%%DOCSDIR%%/mod_fcgid.html
+%%PORTDOCS%%%%DOCSDIR%%/mod_fcgid.html.en
+%%PORTDOCS%%@unexec /bin/rmdir %D/%%DOCSDIR%% 2>/dev/null || true
@exec /bin/mkdir -p -m 700 /var/run/fcgidsock
@exec /usr/sbin/chown www:www /var/run/fcgidsock
@unexec /bin/rmdir /var/run/fcgidsock 2>/dev/null || true