aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-12-19 20:10:33 +0800
committerwill <will@FreeBSD.org>2000-12-19 20:10:33 +0800
commit9b225879c83fcd0c781cdd5b4639e309a803df4e (patch)
tree206320605bea6c6de5d2a8f72f4be5bbfcf42751 /www
parentf8b858706203eba3564dd61a3a14a31d76eb8ee4 (diff)
downloadfreebsd-ports-gnome-9b225879c83fcd0c781cdd5b4639e309a803df4e.tar.gz
freebsd-ports-gnome-9b225879c83fcd0c781cdd5b4639e309a803df4e.tar.zst
freebsd-ports-gnome-9b225879c83fcd0c781cdd5b4639e309a803df4e.zip
Add webresolve 0.0.1, a script that resolves IP addresses to host names
in web logfiles. PR: 23333 Submitted by: Joseph Scott <joseph@randomnetworks.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/webresolve/Makefile21
-rw-r--r--www/webresolve/distinfo1
-rw-r--r--www/webresolve/pkg-comment1
-rw-r--r--www/webresolve/pkg-descr17
-rw-r--r--www/webresolve/pkg-plist2
6 files changed, 43 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index b4fe913b4208..76db796ed0d4 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -201,6 +201,7 @@
SUBDIR += webglimpse
SUBDIR += weblint
SUBDIR += webredirect
+ SUBDIR += webresolve
SUBDIR += webstone
SUBDIR += webstone-ssl
SUBDIR += wml
diff --git a/www/webresolve/Makefile b/www/webresolve/Makefile
new file mode 100644
index 000000000000..054434149dcb
--- /dev/null
+++ b/www/webresolve/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: webresolve
+# Date created: Wed 6 Dec 2000
+# Whom: Joseph Scott <joseph@randomnetworks.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= webresolve
+PORTVERSION= 0.0.1
+CATEGORIES= www
+MASTER_SITES= ftp://siag.nu/pub/webresolve/
+
+MAINTAINER= joseph@randomnetworks.com
+
+ALL_TARGET= webresolve
+MAKE_ARGS= PREFIX=${PREFIX}
+
+post-install:
+ @strip ${PREFIX}/bin/webresolve
+
+.include <bsd.port.mk>
diff --git a/www/webresolve/distinfo b/www/webresolve/distinfo
new file mode 100644
index 000000000000..2ebf247be2c6
--- /dev/null
+++ b/www/webresolve/distinfo
@@ -0,0 +1 @@
+MD5 (webresolve-0.0.1.tar.gz) = b0ecb991ebbf6b2c4cebe6e6ebfbce03
diff --git a/www/webresolve/pkg-comment b/www/webresolve/pkg-comment
new file mode 100644
index 000000000000..619a9507ab23
--- /dev/null
+++ b/www/webresolve/pkg-comment
@@ -0,0 +1 @@
+Webresolve resolves IP addresses to host names in web log files.
diff --git a/www/webresolve/pkg-descr b/www/webresolve/pkg-descr
new file mode 100644
index 000000000000..7360044ccafa
--- /dev/null
+++ b/www/webresolve/pkg-descr
@@ -0,0 +1,17 @@
+This program is pretty slow. Thanks to the caching, repeated visits from the
+same address will only result in one lookup. Therefore large files will be
+processed proportionally faster than small ones.
+
+The load from this program is very light, because it spends most of its time
+waiting for the resolver. This also means that large files can take quite some
+time to process. The solution is to split the log file and run several
+resolution processes in parallel. This is done by the script splitwr:
+
+ splitwr logfile > logfile.resolved
+ webalizer logfile.resolved
+ rm logfile.resolved
+
+By default, splitwr runs 20 parallel resolution processes. The number can be
+changed by editing the script.
+
+WWW: http://siag.nu/webresolve/
diff --git a/www/webresolve/pkg-plist b/www/webresolve/pkg-plist
new file mode 100644
index 000000000000..700c3889251d
--- /dev/null
+++ b/www/webresolve/pkg-plist
@@ -0,0 +1,2 @@
+bin/splitwr
+bin/webresolve