aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorjkoshy <jkoshy@FreeBSD.org>2001-01-30 18:48:28 +0800
committerjkoshy <jkoshy@FreeBSD.org>2001-01-30 18:48:28 +0800
commit9c4e022027fba1edded71dce473f24c3a2bb4e2a (patch)
tree0aadaa7d34520790ce34e2f73040204bac0ab6f4 /www
parent3ee4ad453e82cfb33c6bb5e185e81825657e8318 (diff)
downloadfreebsd-ports-gnome-9c4e022027fba1edded71dce473f24c3a2bb4e2a.tar.gz
freebsd-ports-gnome-9c4e022027fba1edded71dce473f24c3a2bb4e2a.tar.zst
freebsd-ports-gnome-9c4e022027fba1edded71dce473f24c3a2bb4e2a.zip
Add `nspostgres', a driver allowing AOLserver to communicate with
PostgreSQL database servers.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/nspostgres/Makefile27
-rw-r--r--www/nspostgres/distinfo1
-rw-r--r--www/nspostgres/files/patch-aa11
-rw-r--r--www/nspostgres/pkg-comment1
-rw-r--r--www/nspostgres/pkg-descr4
-rw-r--r--www/nspostgres/pkg-plist1
7 files changed, 46 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 709f5f003adb..0ad849da37d9 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -130,6 +130,7 @@
SUBDIR += netscape47-navigator
SUBDIR += nscache
SUBDIR += npc
+ SUBDIR += nspostgres
SUBDIR += oops
SUBDIR += p5-Apache
SUBDIR += p5-Apache-ASP
diff --git a/www/nspostgres/Makefile b/www/nspostgres/Makefile
new file mode 100644
index 000000000000..fb33424099df
--- /dev/null
+++ b/www/nspostgres/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: nspostgres
+# Date created: 30 January 2001
+# Whom: jkoshy
+#
+# $FreeBSD$
+#
+
+PORTNAME= nspostgres
+PORTVERSION= 3.0
+CATEGORIES= www databases
+MASTER_SITES= ftp://ftp.aolserver.com/modules/nspostgres/
+DISTNAME= nspostgres3_0
+
+MAINTAINER= jkoshy@freebsd.org
+
+RUN_DEPENDS= ${LOCALBASE}/aolserver/bin/nsd:${PORTSDIR}/www/aolserver \
+ ${LOCALBASE}/pgsql/bin/postmaster:${PORTSDIR}/databases/postgresql7
+
+WRKSRC= ${WRKDIR}/nspostgres
+
+USE_GMAKE= yes
+MAKE_ENV+= POSTGRES=${PREFIX}/pgsql BUILDPREFIX=${PREFIX}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/nspostgres.so ${PREFIX}/aolserver/bin
+
+.include <bsd.port.mk>
diff --git a/www/nspostgres/distinfo b/www/nspostgres/distinfo
new file mode 100644
index 000000000000..0ebb238cefb1
--- /dev/null
+++ b/www/nspostgres/distinfo
@@ -0,0 +1 @@
+MD5 (nspostgres3_0.tar.gz) = 55c9725810b6fa1fe62640b9af0e8b3e
diff --git a/www/nspostgres/files/patch-aa b/www/nspostgres/files/patch-aa
new file mode 100644
index 000000000000..91f0d39607e3
--- /dev/null
+++ b/www/nspostgres/files/patch-aa
@@ -0,0 +1,11 @@
+--- Makefile.orig Sun Aug 20 21:42:48 2000
++++ Makefile Tue Jan 30 16:14:26 2001
+@@ -7,7 +7,7 @@
+ # Postgres internal database driver.
+ #
+
+-NSHOME = ../aolserver
++NSHOME = ${BUILDPREFIX}/aolserver
+
+ #
+ # Override default rules if library not available
diff --git a/www/nspostgres/pkg-comment b/www/nspostgres/pkg-comment
new file mode 100644
index 000000000000..c4e4e9fbf6a5
--- /dev/null
+++ b/www/nspostgres/pkg-comment
@@ -0,0 +1 @@
+A driver to access PostgreSQL databases from Aolserver
diff --git a/www/nspostgres/pkg-descr b/www/nspostgres/pkg-descr
new file mode 100644
index 000000000000..a4c3001388df
--- /dev/null
+++ b/www/nspostgres/pkg-descr
@@ -0,0 +1,4 @@
+An driver module allowing access to PostgreSQL databases from
+within AOLserver.
+
+WWW: http://www.aolserver.com/download/index.adp?dir=%2fmodules%2fnspostgres
diff --git a/www/nspostgres/pkg-plist b/www/nspostgres/pkg-plist
new file mode 100644
index 000000000000..d8340ba95ac5
--- /dev/null
+++ b/www/nspostgres/pkg-plist
@@ -0,0 +1 @@
+aolserver/bin/nspostgres.so