aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2014-05-26 10:14:29 +0800
committernivit <nivit@FreeBSD.org>2014-05-26 10:14:29 +0800
commita7443110d6c3c533e1a38e7a417ea51c5b1499df (patch)
tree050a42efc6e3d6e544a48d87682151b9130f28ce /www
parent14649b576e0b2d508be011acbff3f62a7e5d2a3c (diff)
downloadfreebsd-ports-gnome-a7443110d6c3c533e1a38e7a417ea51c5b1499df.tar.gz
freebsd-ports-gnome-a7443110d6c3c533e1a38e7a417ea51c5b1499df.tar.zst
freebsd-ports-gnome-a7443110d6c3c533e1a38e7a417ea51c5b1499df.zip
- Add support for stage dir [1]
- Use a single space after WWW in pkg-descr PR: ports/190208 Submitted by: Joseph Benden <joe@thrallingpenguin.com>
Diffstat (limited to 'www')
-rw-r--r--www/jspacker/Makefile13
-rw-r--r--www/jspacker/pkg-descr2
2 files changed, 7 insertions, 8 deletions
diff --git a/www/jspacker/Makefile b/www/jspacker/Makefile
index feee8a4f8cd7..39a5b5c33c84 100644
--- a/www/jspacker/Makefile
+++ b/www/jspacker/Makefile
@@ -23,17 +23,16 @@ SUB_FILES= ${PORTNAME}
SUB_LIST= JSPACKER=${JSPACKER} \
PERL5=${PERL5}
-NO_STAGE= yes
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
- ${MKDIR} ${DATADIR} && \
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${MKDIR} ${STAGEDIR}${DATADIR} && \
cd ${WRKSRC} && \
- ${INSTALL_DATA} *.pm ${DATADIR} && \
- ${INSTALL_SCRIPT} ${JSPACKER} ${DATADIR}
+ ${INSTALL_DATA} *.pm ${STAGEDIR}${DATADIR} && \
+ ${INSTALL_SCRIPT} ${JSPACKER} ${STAGEDIR}${DATADIR}
.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR} && \
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR} && \
cd ${WRKSRC} && \
- ${INSTALL_DATA} *.htm ${EXAMPLESDIR}
+ ${INSTALL_DATA} *.htm ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>
diff --git a/www/jspacker/pkg-descr b/www/jspacker/pkg-descr
index 7d8dc0bb7923..6e0010b76a0d 100644
--- a/www/jspacker/pkg-descr
+++ b/www/jspacker/pkg-descr
@@ -1,3 +1,3 @@
A Javascript compressor/obfuscator written in Perl
-WWW: http://dean.edwards.name/packer/
+WWW: http://dean.edwards.name/packer/