aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-05-24 14:24:01 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-05-24 14:24:01 +0800
commita9041502fd09375ce9208b4feed10fbe8935267e (patch)
treee1e3c789913cca8515061af06ddbef79b06ed593 /www
parent4156f9c49e1b9be985e3519a131898d755907858 (diff)
downloadfreebsd-ports-gnome-a9041502fd09375ce9208b4feed10fbe8935267e.tar.gz
freebsd-ports-gnome-a9041502fd09375ce9208b4feed10fbe8935267e.tar.zst
freebsd-ports-gnome-a9041502fd09375ce9208b4feed10fbe8935267e.zip
- Update to 0.4.0
- Use USES=libtool Changes: https://github.com/tatsuhiro-t/nghttp2/releases
Diffstat (limited to 'www')
-rw-r--r--www/nghttp2/Makefile14
-rw-r--r--www/nghttp2/distinfo4
-rw-r--r--www/nghttp2/pkg-plist6
3 files changed, 15 insertions, 9 deletions
diff --git a/www/nghttp2/Makefile b/www/nghttp2/Makefile
index 985521fa005b..8ee9f948027c 100644
--- a/www/nghttp2/Makefile
+++ b/www/nghttp2/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= nghttp2
-PORTVERSION= 0.3.2
-PORTREVISION= 1
+PORTVERSION= 0.4.0
CATEGORIES= www net
MASTER_SITES= https://github.com/tatsuhiro-t/${PORTNAME}/releases/download/v${PORTVERSION}/ \
LOCAL/sunpoet
@@ -21,7 +20,9 @@ OPTIONS_SUB= yes
CONFIGURE_ARGS= --disable-python-bindings \
--enable-app \
- --enable-examples
+ --enable-examples \
+ --with-jemalloc \
+ --with-spdylay
CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl" \
ZLIB_CFLAGS="-I${INCLUDEDIR}" \
@@ -31,7 +32,7 @@ USE_CXXSTD= c++11
USE_GNOME= libxml2
USE_LDCONFIG= yes
USE_OPENSSL= yes
-USES= compiler:c++11-lang pathfix pkgconfig tar:xz
+USES= compiler:c++11-lang libtool pathfix pkgconfig tar:xz
PORTDOCS= *
@@ -44,7 +45,10 @@ HPACK_LIB_DEPENDS= libjansson.so:${PORTSDIR}/devel/jansson
IGNORE= nghttp2 requires OpenSSL 1.0.1+
.endif
+post-patch:
+ @${REINPLACE_CMD} -e '/JEMALLOC_LIBS/ s|-ljemalloc||' ${WRKSRC}/configure
+
post-build:
- @${STRIP_CMD} ${WRKSRC}/lib/.libs/libnghttp2.so.2
+ @${STRIP_CMD} ${WRKSRC}/lib/.libs/libnghttp2.so.3
.include <bsd.port.post.mk>
diff --git a/www/nghttp2/distinfo b/www/nghttp2/distinfo
index a4ae7bb5a367..45c9c57057d1 100644
--- a/www/nghttp2/distinfo
+++ b/www/nghttp2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nghttp2-0.3.2.tar.xz) = 74a2865139558d2c8abaceb9961c7812575d472e5ec2eb7655fd553588587718
-SIZE (nghttp2-0.3.2.tar.xz) = 699148
+SHA256 (nghttp2-0.4.0.tar.xz) = e83dcd19f07c349fe0f10f62278852be480c61501ba40235dc01bab14f192991
+SIZE (nghttp2-0.4.0.tar.xz) = 760012
diff --git a/www/nghttp2/pkg-plist b/www/nghttp2/pkg-plist
index 8ef1a4638ba1..d8b8d8fd0964 100644
--- a/www/nghttp2/pkg-plist
+++ b/www/nghttp2/pkg-plist
@@ -1,4 +1,5 @@
%%HPACK%%bin/deflatehd
+bin/h2load
%%HPACK%%bin/inflatehd
bin/nghttp
bin/nghttpd
@@ -6,10 +7,11 @@ bin/nghttpx
include/nghttp2/nghttp2.h
include/nghttp2/nghttp2ver.h
lib/libnghttp2.a
-lib/libnghttp2.la
lib/libnghttp2.so
-lib/libnghttp2.so.2
+lib/libnghttp2.so.3
+lib/libnghttp2.so.3.0.0
libdata/pkgconfig/libnghttp2.pc
+man/man1/h2load.1.gz
man/man1/nghttp.1.gz
man/man1/nghttpd.1.gz
man/man1/nghttpx.1.gz