aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2016-04-21 19:33:16 +0800
committergahr <gahr@FreeBSD.org>2016-04-21 19:33:16 +0800
commitaac577b29e7c8c670b8a66c39f62bad322857d03 (patch)
treec6cb1634ff4ea3d4c9f601585a6fc959826e2ff8 /www
parent6430722ff2a915080b85d5e4136b10757a23a481 (diff)
downloadfreebsd-ports-gnome-aac577b29e7c8c670b8a66c39f62bad322857d03.tar.gz
freebsd-ports-gnome-aac577b29e7c8c670b8a66c39f62bad322857d03.tar.zst
freebsd-ports-gnome-aac577b29e7c8c670b8a66c39f62bad322857d03.zip
Support Tk in USES=tk:tea. Convert more ports + minor fixes and modernization.
Diffstat (limited to 'www')
-rw-r--r--www/mod_rivet/Makefile9
-rw-r--r--www/mod_rivet/distinfo4
-rw-r--r--www/mod_rivet/pkg-plist3
-rw-r--r--www/tclhttpd/Makefile6
-rw-r--r--www/tdom/Makefile18
-rw-r--r--www/tdom/files/patch-Makefile.in8
-rw-r--r--www/tdom/files/patch-configure19
-rw-r--r--www/tdom/files/patch-expat-xmlparse.h16
-rw-r--r--www/tdom/files/patch-expat_xmlparse.c20
-rw-r--r--www/tdom/files/patch-generic-dom.h8
-rw-r--r--www/tdom/files/patch-generic-tcldom.c8
-rw-r--r--www/tdom/files/patch-generic-tclexpat.c8
-rw-r--r--www/websh/Makefile5
13 files changed, 68 insertions, 64 deletions
diff --git a/www/mod_rivet/Makefile b/www/mod_rivet/Makefile
index 73d1e1905d3b..0b82ad8230fe 100644
--- a/www/mod_rivet/Makefile
+++ b/www/mod_rivet/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mod_rivet
-PORTVERSION= 2.2.3
+PORTVERSION= 2.3.1
CATEGORIES= www tcl
MASTER_SITES= APACHE/tcl/rivet
DISTNAME= rivet-${PORTVERSION}
@@ -15,18 +15,15 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libitcl.so:lang/itcl
-GNU_CONFIGURE= yes
USE_APACHE= 22+
USE_LDCONFIG= ${PREFIX}/lib/rivet
-USES+= gmake libtool tcl:85+
+USES+= gmake libtool tcl:85+,tea
INSTALL_TARGET= install-strip
SUB_FILES= pkg-message
-CONFIGURE_ARGS+=--with-apache-version=2 \
- --prefix=${PREFIX} --with-apxs=${APXS} \
- --with-tcl=${TCL_LIBDIR} --with-tclsh=${TCLSH} \
+CONFIGURE_ARGS= --with-apxs=${APXS} \
--with-rivet-target-dir=${PREFIX}/lib/rivet
post-patch:
diff --git a/www/mod_rivet/distinfo b/www/mod_rivet/distinfo
index 6292716fcd40..0d92159f72ea 100644
--- a/www/mod_rivet/distinfo
+++ b/www/mod_rivet/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rivet-2.2.3.tar.gz) = d5f6cae2a09999e59f3f7eef73d55f50ab29ee4277c92c5e6e50e4b165fc7d16
-SIZE (rivet-2.2.3.tar.gz) = 1171217
+SHA256 (rivet-2.3.1.tar.gz) = d6b4dd70204fb8707cca1e0067e75bad689e7182d989d45f4aa17a870c2cbc40
+SIZE (rivet-2.3.1.tar.gz) = 1203555
diff --git a/www/mod_rivet/pkg-plist b/www/mod_rivet/pkg-plist
index a28fa8c06dcd..a3dc89237893 100644
--- a/www/mod_rivet/pkg-plist
+++ b/www/mod_rivet/pkg-plist
@@ -2,6 +2,7 @@ lib/rivet/init.tcl
lib/rivet/librivetlib.so
lib/rivet/librivetparser.so
lib/rivet/packages/README
+lib/rivet/packages/asciiglyphs/asciiglyphs.tcl
lib/rivet/packages/calendar/calendar.tcl
lib/rivet/packages/commserver/commserver.tcl
lib/rivet/packages/commserver/server.tcl
@@ -37,6 +38,7 @@ lib/rivet/packages/tclrivet/tclrivet.tcl
lib/rivet/packages/tclrivet/tclrivetparser.tcl
lib/rivet/pkgIndex.tcl
lib/rivet/rivet-tcl/README
+lib/rivet/rivet-tcl/catch.tcl
lib/rivet/rivet-tcl/cookie.tcl
lib/rivet/rivet-tcl/debug.tcl
lib/rivet/rivet-tcl/html.tcl
@@ -55,6 +57,7 @@ lib/rivet/rivet-tcl/read_file.tcl
lib/rivet/rivet-tcl/redirect.tcl
lib/rivet/rivet-tcl/rivet_command_document.tcl
lib/rivet/rivet-tcl/tclIndex
+lib/rivet/rivet-tcl/try.tcl
lib/rivet/rivet-tcl/wrap.tcl
lib/rivet/rivet-tcl/xml.tcl
%%APACHEMODDIR%%/mod_rivet.so
diff --git a/www/tclhttpd/Makefile b/www/tclhttpd/Makefile
index cb4eecdd30bd..f170e2354968 100644
--- a/www/tclhttpd/Makefile
+++ b/www/tclhttpd/Makefile
@@ -14,12 +14,8 @@ COMMENT= Http-server implemented in TCL
RUN_DEPENDS= dtplite:devel/tcllib
USE_RC_SUBR= tclhttpd
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-tcl="${TCL_LIBDIR}" \
- --with-tclinclude="${TCL_INCLUDEDIR}" \
- --exec-prefix=${PREFIX}
-USES= tcl
+USES= tcl:tea
.include <bsd.port.pre.mk>
diff --git a/www/tdom/Makefile b/www/tdom/Makefile
index b2736dbf6856..2147573ce2af 100644
--- a/www/tdom/Makefile
+++ b/www/tdom/Makefile
@@ -9,20 +9,17 @@ MASTER_SITES= GHC http://mirrors.rit.edu/zi/
MAINTAINER= mi@aldan.algebra.com
COMMENT= High performance XML data processing with Tcl (ARGS for OpenACS)
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/unix
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
TDOMBASE= ${PREFIX}/lib/tdom${PORTVERSION}
OPTIONS_DEFINE= DOCS
-USES= gmake tar:tgz tcl
+USES= gmake tar:tgz tcl:tea
USE_GITHUB= yes
GH_PROJECT= tdom
-HAS_CONFIGURE= yes
-CONFIGURE_SCRIPT= ../configure
-
pre-configure:
- ${RM} -f ${WRKSRC}/../generic/domalloc.?
+ ${RM} -f ${WRKSRC}/generic/domalloc.?
PLIST_SUB+= PORTVERSION=${PORTVERSION}
@@ -34,10 +31,7 @@ HTMLDOCS= category-index.html dom.html domDoc.html domNode.html \
post-build test:
${SETENV} LANG=C ${MAKE} -C ${WRKSRC} test
-CONFIGURE_ARGS+=--enable-threads --disable-tdomalloc \
- --with-tcl=${TCL_LIBDIR} \
- --with-tclinclude=${TCL_INCLUDEDIR} \
- --prefix=${PREFIX} --exec-prefix=${PREFIX}
+CONFIGURE_ARGS+=--enable-threads --disable-tdomalloc
post-install:
${CHMOD} 755 ${STAGEDIR}${TDOMBASE}
@@ -46,10 +40,10 @@ post-install:
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}/html
.for FILE in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/../${FILE} ${STAGEDIR}${DOCSDIR}/${FILE}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${STAGEDIR}${DOCSDIR}/${FILE}
.endfor
.for FILE in ${HTMLDOCS}
- ${INSTALL_DATA} ${WRKSRC}/../doc/${FILE} ${STAGEDIR}${DOCSDIR}/html/${FILE}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${FILE} ${STAGEDIR}${DOCSDIR}/html/${FILE}
.endfor
.include <bsd.port.mk>
diff --git a/www/tdom/files/patch-Makefile.in b/www/tdom/files/patch-Makefile.in
index dbf4a340dc3a..b1f67eb5147e 100644
--- a/www/tdom/files/patch-Makefile.in
+++ b/www/tdom/files/patch-Makefile.in
@@ -1,9 +1,11 @@
---- ../Makefile.in 2007-03-02 18:43:53.000000000 -0500
-+++ ../Makefile.in 2008-02-14 15:21:19.000000000 -0500
-@@ -110,5 +110,5 @@
+--- Makefile.in.orig 2007-03-02 23:43:53 UTC
++++ Makefile.in
+@@ -109,7 +109,7 @@ CFLAGS_WARNING = @CFLAGS_WARNING@
+ CLEANFILES = @CLEANFILES@
EXEEXT = @EXEEXT@
LDFLAGS_DEFAULT = @LDFLAGS_DEFAULT@
-MAKE_LIB = @MAKE_LIB@
+MAKE_LIB = @MAKE_LIB@ ${LDFLAGS_DEFAULT}
MAKE_SHARED_LIB = @MAKE_SHARED_LIB@
MAKE_STATIC_LIB = @MAKE_STATIC_LIB@
+ MAKE_STUB_LIB = @MAKE_STUB_LIB@
diff --git a/www/tdom/files/patch-configure b/www/tdom/files/patch-configure
index b4e5a95924c3..aa7654804378 100644
--- a/www/tdom/files/patch-configure
+++ b/www/tdom/files/patch-configure
@@ -1,30 +1,37 @@
---- ../configure 2007-08-05 14:47:49.000000000 -0400
-+++ ../configure 2008-02-14 14:16:33.000000000 -0500
-@@ -6169,5 +6169,5 @@
+--- configure.orig 2007-08-15 21:40:11 UTC
++++ configure
+@@ -6168,14 +6168,14 @@ extern "C"
+ #endif
/* We use char because int might match the return type of a gcc2
builtin and then its argument prototype would still apply. */
-char $ac_func ();
+void * $ac_func ();
/* The GNU C library defines this for functions which it implements
to always fail with ENOSYS. Some functions are actually named
-@@ -6176,5 +6176,5 @@
+ something starting with __ and the normal name is an alias. */
+ #if defined (__stub_$ac_func) || defined (__stub___$ac_func)
choke me
#else
-char (*f) () = $ac_func;
+void * (*f) () = $ac_func;
#endif
#ifdef __cplusplus
-@@ -7263,5 +7262,5 @@
+ }
+@@ -7261,7 +7261,7 @@ fi
+ CFLAGS_OPTIMIZE=-O
if test "$GCC" = "yes" ; then
CFLAGS_OPTIMIZE=-O2
- CFLAGS_WARNING="-Wall -Wno-implicit-int"
+ CFLAGS_WARNING="-Wall -Wno-implicit-int -Wno-uninitialized"
else
CFLAGS_WARNING=""
-@@ -8404,5 +8401,5 @@
+ fi
+@@ -8402,7 +8402,7 @@ echo "${ECHO_T}$tcl_cv_ld_elf" >&6
+ # The -pthread needs to go in the CFLAGS, not LIBS
LIBS=`echo $LIBS | sed s/-pthread//`
CFLAGS="$CFLAGS -pthread"
- LDFLAGS="$LDFLAGS -pthread"
+ LDFLAGS="$LDFLAGS"
fi
case $system in
+ FreeBSD-3.*)
diff --git a/www/tdom/files/patch-expat-xmlparse.h b/www/tdom/files/patch-expat-xmlparse.h
deleted file mode 100644
index 12368b8a3a5e..000000000000
--- a/www/tdom/files/patch-expat-xmlparse.h
+++ /dev/null
@@ -1,16 +0,0 @@
---- ../expat/xmlparse.c 2007-07-30 20:16:28.000000000 -0400
-+++ ../expat/xmlparse.c 2008-02-14 14:20:27.000000000 -0500
-@@ -1476,5 +1476,5 @@
- const char *end;
- int nLeftOver;
-- enum XML_Error result;
-+ enum XML_Error result = XML_STATUS_ERROR;
- parseEndByteIndex += len;
- positionPtr = s;
-@@ -1500,4 +1500,6 @@
- return result;
- }
-+ case XML_FINISHED:
-+ /* nothing */;
- }
- }
diff --git a/www/tdom/files/patch-expat_xmlparse.c b/www/tdom/files/patch-expat_xmlparse.c
new file mode 100644
index 000000000000..ab1a44cf8f37
--- /dev/null
+++ b/www/tdom/files/patch-expat_xmlparse.c
@@ -0,0 +1,20 @@
+--- expat/xmlparse.c.orig 2007-07-31 00:16:28 UTC
++++ expat/xmlparse.c
+@@ -1475,7 +1475,7 @@ XML_Parse(XML_Parser parser, const char
+ else if (bufferPtr == bufferEnd) {
+ const char *end;
+ int nLeftOver;
+- enum XML_Error result;
++ enum XML_Error result = XML_STATUS_ERROR;
+ parseEndByteIndex += len;
+ positionPtr = s;
+ ps_finalBuffer = (XML_Bool)isFinal;
+@@ -1499,6 +1499,8 @@ XML_Parse(XML_Parser parser, const char
+ ps_parsing = XML_FINISHED;
+ return result;
+ }
++ case XML_FINISHED:
++ /* nothing */;
+ }
+ }
+
diff --git a/www/tdom/files/patch-generic-dom.h b/www/tdom/files/patch-generic-dom.h
index bca37d3f418e..947ecc50972f 100644
--- a/www/tdom/files/patch-generic-dom.h
+++ b/www/tdom/files/patch-generic-dom.h
@@ -1,8 +1,10 @@
---- ../generic/dom.h 2007-08-08 11:52:38.000000000 -0400
-+++ ../generic/dom.h 2008-02-14 14:27:46.000000000 -0500
-@@ -41,5 +41,4 @@
+--- generic/dom.h.orig 2007-08-18 12:51:46 UTC
++++ generic/dom.h
+@@ -40,7 +40,6 @@
+ #include <ctype.h>
#include <expat.h>
#include <utf8conv.h>
-#include <domalloc.h>
/*
+ * tDOM provides it's own memory allocator which is optimized for
diff --git a/www/tdom/files/patch-generic-tcldom.c b/www/tdom/files/patch-generic-tcldom.c
index 5b9b640b94c8..cc03d6bbb9dd 100644
--- a/www/tdom/files/patch-generic-tcldom.c
+++ b/www/tdom/files/patch-generic-tcldom.c
@@ -1,6 +1,6 @@
---- ../generic/tcldom.c.orig 2007-12-26 00:19:02.000000000 +0100
-+++ ../generic/tcldom.c 2013-05-22 09:01:30.000000000 +0200
-@@ -5915,6 +5915,9 @@
+--- generic/tcldom.c.orig 2007-12-25 23:19:02 UTC
++++ generic/tcldom.c
+@@ -5915,6 +5915,9 @@ int tcldom_DomObjCmd (
| tcldom_EvalLocked
|
\---------------------------------------------------------------------------*/
@@ -10,7 +10,7 @@
static
int tcldom_EvalLocked (
-@@ -5934,7 +5937,7 @@
+@@ -5934,7 +5937,7 @@ int tcldom_EvalLocked (
if (ret == TCL_ERROR) {
char msg[64 + TCL_INTEGER_SPACE];
sprintf(msg, "\n (\"%s %s\" body line %d)", Tcl_GetString(objv[0]),
diff --git a/www/tdom/files/patch-generic-tclexpat.c b/www/tdom/files/patch-generic-tclexpat.c
index c50370e289e2..5f4b50a2d130 100644
--- a/www/tdom/files/patch-generic-tclexpat.c
+++ b/www/tdom/files/patch-generic-tclexpat.c
@@ -1,9 +1,11 @@
---- ../generic/tclexpat.c 2007-08-07 13:54:16.000000000 -0400
-+++ ../generic/tclexpat.c 2008-02-14 14:35:48.000000000 -0500
-@@ -43,4 +43,6 @@
+--- generic/tclexpat.c.orig 2008-03-04 20:34:28 UTC
++++ generic/tclexpat.c
+@@ -42,6 +42,8 @@
+
#ifdef _MSC_VER
#include <io.h>
+#else
+#include <unistd.h> /* read() and close() live there */
#endif
+ #ifdef _POSIX_SOURCE
diff --git a/www/websh/Makefile b/www/websh/Makefile
index 36f4b2b7fc72..01c1b7ee4a15 100644
--- a/www/websh/Makefile
+++ b/www/websh/Makefile
@@ -15,11 +15,8 @@ MAKE_JOBS_UNSAFE= yes
TCL_DVER= ${TCL_VER:S/.//}
-USES= gmake tcl:84,85,86
-USE_AUTOTOOLS= autoconf
+USES= autoreconf gmake tcl:tea
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src/unix
-CONFIGURE_ARGS+=--with-tclinclude=${TCL_INCLUDEDIR} \
- --with-tcl=${TCL_LIBDIR}
USE_LDCONFIG= yes
SUB_FILES= httpd.conf pkgIndex.tcl pkg-message
SUB_LIST+= TCL_DVER=${TCL_DVER} WS_VER=${PORTVERSION}