aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorjadawin <jadawin@FreeBSD.org>2012-12-19 22:36:05 +0800
committerjadawin <jadawin@FreeBSD.org>2012-12-19 22:36:05 +0800
commitad56650407d90d7fe869f0c764293d52cdc636cd (patch)
tree7b8df0d6520c9cb77ca9010a358a6169cbd6f9cd /www
parent9a4e521b888d6fbe5ca8099bcd170f0a090968e9 (diff)
downloadfreebsd-ports-gnome-ad56650407d90d7fe869f0c764293d52cdc636cd.tar.gz
freebsd-ports-gnome-ad56650407d90d7fe869f0c764293d52cdc636cd.tar.zst
freebsd-ports-gnome-ad56650407d90d7fe869f0c764293d52cdc636cd.zip
Nginx::Simple is a Perl module which allows for a "Apache mod_perl-like"
interface. WWW: http://search.cpan.org/dist/Nginx-Simple/ PR: ports/171164 Submitted by: simond@irrelevant.org
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Nginx-Simple/Makefile20
-rw-r--r--www/p5-Nginx-Simple/distinfo2
-rw-r--r--www/p5-Nginx-Simple/pkg-descr4
-rw-r--r--www/p5-Nginx-Simple/pkg-plist13
5 files changed, 40 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 81b44dfcdc56..06bee090fe6f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1077,6 +1077,7 @@
SUBDIR += p5-Net-eBay
SUBDIR += p5-Newsletter
SUBDIR += p5-Nginx-ReadBody
+ SUBDIR += p5-Nginx-Simple
SUBDIR += p5-PHP-Session
SUBDIR += p5-POE-Component-Client-HTTP
SUBDIR += p5-POE-Component-Client-UserAgent
diff --git a/www/p5-Nginx-Simple/Makefile b/www/p5-Nginx-Simple/Makefile
new file mode 100644
index 000000000000..d20a72c753cf
--- /dev/null
+++ b/www/p5-Nginx-Simple/Makefile
@@ -0,0 +1,20 @@
+# Created by: Simon Dick <simond@irrelevant.org>
+# $FreeBSD$
+
+PORTNAME= Nginx-Simple
+PORTVERSION= 0.07
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= simond@irrelevant.org
+COMMENT= Perl 5 module for easy to use interface for Nginx Perl Module
+
+PERL_CONFIGURE= YES
+
+MAN3= Nginx::Simple::Dispatch.3 Nginx::Simple::Cookie.3 \
+ Nginx::Simple::Ajax.3 Nginx::Simple.3 \
+ Nginx::Simple::Dispatcher::Attributes.3 \
+ Nginx::Simple::Dispatcher.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Nginx-Simple/distinfo b/www/p5-Nginx-Simple/distinfo
new file mode 100644
index 000000000000..5a1f43cc43a7
--- /dev/null
+++ b/www/p5-Nginx-Simple/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Nginx-Simple-0.07.tar.gz) = d4699f160edb8ac4c4c23a3485e6648e9f339f904e5c400dfe33843628cafae3
+SIZE (Nginx-Simple-0.07.tar.gz) = 31522
diff --git a/www/p5-Nginx-Simple/pkg-descr b/www/p5-Nginx-Simple/pkg-descr
new file mode 100644
index 000000000000..f7e7b509988d
--- /dev/null
+++ b/www/p5-Nginx-Simple/pkg-descr
@@ -0,0 +1,4 @@
+Nginx::Simple is a Perl module which allows for a "Apache mod_perl-like"
+interface.
+
+WWW: http://search.cpan.org/dist/Nginx-Simple/
diff --git a/www/p5-Nginx-Simple/pkg-plist b/www/p5-Nginx-Simple/pkg-plist
new file mode 100644
index 000000000000..feaea981bc29
--- /dev/null
+++ b/www/p5-Nginx-Simple/pkg-plist
@@ -0,0 +1,13 @@
+bin/ngs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Nginx/Simple/.packlist
+%%SITE_PERL%%/Nginx/Simple.pm
+%%SITE_PERL%%/Nginx/Simple/Dispatch.pm
+%%SITE_PERL%%/Nginx/Simple/Ajax.pm
+%%SITE_PERL%%/Nginx/Simple/Cookie.pm
+%%SITE_PERL%%/Nginx/Simple/Dispatcher.pm
+%%SITE_PERL%%/Nginx/Simple/Dispatcher/Attributes.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Nginx/Simple
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Nginx
+@dirrmtry %%SITE_PERL%%/Nginx/Simple/Dispatcher
+@dirrmtry %%SITE_PERL%%/Nginx/Simple
+@dirrmtry %%SITE_PERL%%/Nginx