aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbhughes <bhughes@FreeBSD.org>2018-04-06 15:07:17 +0800
committerbhughes <bhughes@FreeBSD.org>2018-04-06 15:07:17 +0800
commitad8d335d9bf9a7c76a6f2a8a12a3fb6ccc29995a (patch)
tree489dee16b51b0c79da08ebc94007e558cd38e0ba /www
parentba79fa1385d844cd3a9307be232c2960492916de (diff)
downloadfreebsd-ports-gnome-ad8d335d9bf9a7c76a6f2a8a12a3fb6ccc29995a.tar.gz
freebsd-ports-gnome-ad8d335d9bf9a7c76a6f2a8a12a3fb6ccc29995a.tar.zst
freebsd-ports-gnome-ad8d335d9bf9a7c76a6f2a8a12a3fb6ccc29995a.zip
www/node4: fix portlint errors and relevant warnings
- move DEPRECATED/EXPIRATION_DATE out of MAINTAINER section - move ONLY_FOR_ARCHS - remove USES_LDCONFIG (Node.js doesn't install a .so) MFH: 2018Q2
Diffstat (limited to 'www')
-rw-r--r--www/node4/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/www/node4/Makefile b/www/node4/Makefile
index 1da1b6c9af80..97cba5206fa9 100644
--- a/www/node4/Makefile
+++ b/www/node4/Makefile
@@ -10,12 +10,14 @@ PKGNAMESUFFIX= 4
MAINTAINER= bhughes@FreeBSD.org
COMMENT= V8 JavaScript for client and server (4.x LTS)
-DEPRECATED= Node.js v4.x reaches end-of-life on 2018-04-30, see https://github.com/nodejs/Release
-EXPIRATION_DATE= 2018-04-30
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Node.js v4.x reaches end-of-life on 2018-04-30, see https://github.com/nodejs/Release
+EXPIRATION_DATE= 2018-04-30
+ONLY_FOR_ARCHS= amd64 i386
+
OPTIONS_DEFINE= BUNDLED_SSL DOCS NLS
OPTIONS_DEFAULT=
OPTIONS_SUB= yes
@@ -32,11 +34,9 @@ NLS_LIB_DEPENDS= libicui18n.so:devel/icu
USES= compiler:c++11-lib gmake python:2.7 pkgconfig localbase
HAS_CONFIGURE= yes
-USE_LDCONFIG= yes
CONFLICTS_INSTALL= node[568]-[0-9]* node-[0-9]*
-ONLY_FOR_ARCHS= amd64 i386
CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST} \
--without-npm \
--shared-libuv \