aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2011-06-16 00:01:06 +0800
committermm <mm@FreeBSD.org>2011-06-16 00:01:06 +0800
commitb21767bd08237f06b1bb9fa70ac9dda47a27ddad (patch)
treeac8c46d3c0b737b120919ef5aaad9ac5b93db95d /www
parentf549f1487a4244c484f3d027be1960d6ae8db03c (diff)
downloadfreebsd-ports-gnome-b21767bd08237f06b1bb9fa70ac9dda47a27ddad.tar.gz
freebsd-ports-gnome-b21767bd08237f06b1bb9fa70ac9dda47a27ddad.tar.zst
freebsd-ports-gnome-b21767bd08237f06b1bb9fa70ac9dda47a27ddad.zip
The htt provides a large variety of HTTP-related functionality, useful for
implementing all kinds of HTTP-based tests: - Advanced HTTP protocol handling, including ne-grained timeout handling, request and response validation - Simulating clients and servers, including startup and shutdown of server daemons. This allows to create mock-ups of back-end systems in more complex test situations, for example when the tested application needs to interact with a 3rd-party back-end system which is not available in the testing environment. - Execution of external commandline tools, using their output as request or response data, or for validation purposes. - Copying stream data (e.g. from a response) and re-using it in variables. WWW: http://htt.sourceforge.net/cgi-bin/cwiki/bin/public
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/httest/Makefile31
-rw-r--r--www/httest/distinfo2
-rw-r--r--www/httest/pkg-descr15
-rw-r--r--www/httest/pkg-plist6
5 files changed, 55 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 4e1dceb35c50..c9c4f81457ec 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -330,6 +330,7 @@
SUBDIR += htmlcompressor
SUBDIR += htmlobject
SUBDIR += htmlpp
+ SUBDIR += httest
SUBDIR += http-analyze
SUBDIR += http_get
SUBDIR += http_load
diff --git a/www/httest/Makefile b/www/httest/Makefile
new file mode 100644
index 000000000000..0ed091bb3639
--- /dev/null
+++ b/www/httest/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: httest
+# Date created: Jun 15, 2011
+# Whom: Martin Matuska <mm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= httest
+PORTVERSION= 2.0.7
+CATEGORIES= www
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= htt/htt/${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= mm@FreeBSD.org
+COMMENT= HTTP Test Tool
+
+LIB_DEPENDS+= apr-1:${PORTSDIR}/devel/apr1 \
+ pcre.0:${PORTSDIR}/devel/pcre
+
+LICENSE= ASL
+
+GNU_CONFIGURE= yes
+USE_OPENSSL= yes
+
+CONFIGURE_ARGS+=--with-apr="${LOCALBASE}/bin" \
+ --with-apr-util="${LOCALBASE}/bin" \
+ --with-pcre="${LOCALBASE}/bin"
+
+MAN1= httest.1 htproxy.1 htntlm.1 htremote.1 hturlext.1 htx2b.1
+
+.include <bsd.port.mk>
diff --git a/www/httest/distinfo b/www/httest/distinfo
new file mode 100644
index 000000000000..e3c84dac36f5
--- /dev/null
+++ b/www/httest/distinfo
@@ -0,0 +1,2 @@
+SHA256 (httest-2.0.7.tar.gz) = 0c750b0b2419487e91f009cee7628fcdcf71f17772abb421078e9dfda97a1168
+SIZE (httest-2.0.7.tar.gz) = 439406
diff --git a/www/httest/pkg-descr b/www/httest/pkg-descr
new file mode 100644
index 000000000000..f1710148e0af
--- /dev/null
+++ b/www/httest/pkg-descr
@@ -0,0 +1,15 @@
+The htt provides a large variety of HTTP-related functionality, useful for
+implementing all kinds of HTTP-based tests:
+
+- Advanced HTTP protocol handling, including ne-grained timeout handling,
+ request and response validation
+- Simulating clients and servers, including startup and shutdown of server
+ daemons. This allows to create mock-ups of back-end systems in more complex
+ test situations, for example when the tested application needs to interact
+ with a 3rd-party back-end system which is not available in the testing
+ environment.
+- Execution of external commandline tools, using their output as request
+ or response data, or for validation purposes.
+- Copying stream data (e.g. from a response) and re-using it in variables.
+
+WWW: http://htt.sourceforge.net/cgi-bin/cwiki/bin/public
diff --git a/www/httest/pkg-plist b/www/httest/pkg-plist
new file mode 100644
index 000000000000..073cb5522dad
--- /dev/null
+++ b/www/httest/pkg-plist
@@ -0,0 +1,6 @@
+bin/htntlm
+bin/htproxy
+bin/htremote
+bin/httest
+bin/hturlext
+bin/htx2b