aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-04-06 15:20:03 +0800
committeryuri <yuri@FreeBSD.org>2018-04-06 15:20:03 +0800
commitbf771b4acaf608372913ee037f6e0835ef48bc50 (patch)
tree31218a3facf6417ace7e167a70599413ff8941fc /www
parentad8d335d9bf9a7c76a6f2a8a12a3fb6ccc29995a (diff)
downloadfreebsd-ports-gnome-bf771b4acaf608372913ee037f6e0835ef48bc50.tar.gz
freebsd-ports-gnome-bf771b4acaf608372913ee037f6e0835ef48bc50.tar.zst
freebsd-ports-gnome-bf771b4acaf608372913ee037f6e0835ef48bc50.zip
New port: www/py-livereload: WSGI for web developers to watch changes in realtime
PR: 227290 Submitted by: Kai <freebsd_ports@k-worx.org>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-livereload/Makefile22
-rw-r--r--www/py-livereload/distinfo3
-rw-r--r--www/py-livereload/pkg-descr6
4 files changed, 32 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 63b9d50babe8..a6fab538744e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1714,6 +1714,7 @@
SUBDIR += py-kallithea
SUBDIR += py-lesscpy
SUBDIR += py-libsass
+ SUBDIR += py-livereload
SUBDIR += py-mechanize
SUBDIR += py-meld
SUBDIR += py-meld3
diff --git a/www/py-livereload/Makefile b/www/py-livereload/Makefile
new file mode 100644
index 000000000000..0e35a1ac0761
--- /dev/null
+++ b/www/py-livereload/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= livereload
+DISTVERSION= 2.5.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= WSGI for web developers to watch changes in realtime
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tornado>0:www/py-tornado@${FLAVOR}
+
+USES= python
+USE_PYTHON= distutils concurrent autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-livereload/distinfo b/www/py-livereload/distinfo
new file mode 100644
index 000000000000..bb7995b9a1e5
--- /dev/null
+++ b/www/py-livereload/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522885827
+SHA256 (livereload-2.5.1.tar.gz) = 422de10d7ea9467a1ba27cbaffa84c74b809d96fb1598d9de4b9b676adf35e2c
+SIZE (livereload-2.5.1.tar.gz) = 20356
diff --git a/www/py-livereload/pkg-descr b/www/py-livereload/pkg-descr
new file mode 100644
index 000000000000..dcf596d33393
--- /dev/null
+++ b/www/py-livereload/pkg-descr
@@ -0,0 +1,6 @@
+LiveReload is designed for web developers who know Python. It offers a server
+that provides a WSGI application to watch changes on web files in realtime.
+
+It offers APIs for the Django, Flask and Bottle frameworks.
+
+WWW: https://github.com/lepture/python-livereload