aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-02-11 03:59:31 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-02-11 03:59:31 +0800
commitc95dadfc6e030d3f7f5056c68906ee39a038c0f2 (patch)
tree5d4f43af7fb1a928c17801cef518bbdcaf120222 /www
parenta2fb91b856847c6cbd0902cbc159e65519aad984 (diff)
downloadfreebsd-ports-gnome-c95dadfc6e030d3f7f5056c68906ee39a038c0f2.tar.gz
freebsd-ports-gnome-c95dadfc6e030d3f7f5056c68906ee39a038c0f2.tar.zst
freebsd-ports-gnome-c95dadfc6e030d3f7f5056c68906ee39a038c0f2.zip
Simplify Makefile: use PY_FUTURES
With hat: python
Diffstat (limited to 'www')
-rw-r--r--www/py-requests-futures/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/www/py-requests-futures/Makefile b/www/py-requests-futures/Makefile
index 6eda7ba6fc7e..d000309f1c3b 100644
--- a/www/py-requests-futures/Makefile
+++ b/www/py-requests-futures/Makefile
@@ -15,14 +15,9 @@ LICENSE= APACHE20
USES= python
USE_PYTHON= autoplist distutils
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${FLAVOR}
+RUN_DEPENDS= ${PY_FUTURES} \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${FLAVOR}
NO_ARCH= yes
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_VER} == "2.7"
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}futures>0:devel/py-futures@${FLAVOR}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>