aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2004-11-09 00:50:57 +0800
committernobutaka <nobutaka@FreeBSD.org>2004-11-09 00:50:57 +0800
commitd71c8a2adbe6c17d97aafc7483937ba212e14c40 (patch)
tree8f67d18770aef58b112628ee96134f4df5df3fd2 /www
parentf0e03e791b274b71ff7b06af27b5a62d0dc2fc4a (diff)
downloadfreebsd-ports-gnome-d71c8a2adbe6c17d97aafc7483937ba212e14c40.tar.gz
freebsd-ports-gnome-d71c8a2adbe6c17d97aafc7483937ba212e14c40.tar.zst
freebsd-ports-gnome-d71c8a2adbe6c17d97aafc7483937ba212e14c40.zip
Fix build error on -current with boehm-gc with REDIRECT and THREADING options.
Diffstat (limited to 'www')
-rw-r--r--www/w3m/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/www/w3m/Makefile b/www/w3m/Makefile
index adfb61c24670..409fda58ad52 100644
--- a/www/w3m/Makefile
+++ b/www/w3m/Makefile
@@ -86,8 +86,12 @@ CONFIGURE_ARGS+= --enable-keymap=lynx
CONFIGURE_ENV= DEFS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="${LIBS} ${PTHREAD_LIBS} -lc_r"
.else
+# Use -lpthread instead of ${PTHREAD_LIBS} to link libpthread
+# and libc before libgc.
+# This is necessary to avoid build error with boehm-gc with REDIRECT and
+# THREADING options.
CONFIGURE_ENV= DEFS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LIBS="${LIBS} ${PTHREAD_LIBS} -lc"
+ LIBS="${LIBS} -lpthread -lc"
.endif
pre-everything::