aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-05-22 14:32:25 +0800
committermiwi <miwi@FreeBSD.org>2014-05-22 14:32:25 +0800
commitd934d17fc1c905c6a36d5c874e3ebf85bc6c3aad (patch)
treef9ab690c6e34e815d18303c6e491a6263ee38804 /www
parentcc3183ddbfa1e791767d70f95ec7935c821e6e11 (diff)
downloadfreebsd-ports-gnome-d934d17fc1c905c6a36d5c874e3ebf85bc6c3aad.tar.gz
freebsd-ports-gnome-d934d17fc1c905c6a36d5c874e3ebf85bc6c3aad.tar.zst
freebsd-ports-gnome-d934d17fc1c905c6a36d5c874e3ebf85bc6c3aad.zip
django-ldapdb is an LDAP database backend for Django.
It allows you to manipulate LDAP entries using Django's models. Declaring models using the LDAP backend is very staightforward, you simply inherit from ldapdb.models.Model and declare the fields in the same way as for regular models. You can even edit the LDAP entries using Django's admin interface. WWW: http://opensource.bolloretelecom.eu/projects/django-ldapdb/ PR: ports/186162 Submitted by: Alexander Kriventsov <avk@vl.ru>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-ldapdb/Makefile22
-rw-r--r--www/py-django-ldapdb/distinfo2
-rw-r--r--www/py-django-ldapdb/pkg-descr8
4 files changed, 33 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e2d4dda63402..f6013d60880d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1507,6 +1507,7 @@
SUBDIR += py-django-haystack
SUBDIR += py-django-json-rpc
SUBDIR += py-django-keyedcache
+ SUBDIR += py-django-ldapdb
SUBDIR += py-django-livesettings
SUBDIR += py-django-mezzanine
SUBDIR += py-django-mezzanine-filebrowser
diff --git a/www/py-django-ldapdb/Makefile b/www/py-django-ldapdb/Makefile
new file mode 100644
index 000000000000..cecfe163d402
--- /dev/null
+++ b/www/py-django-ldapdb/Makefile
@@ -0,0 +1,22 @@
+# Created by: Alexander Kriventsov <avk@vl.ru>
+# $FreeBSD$
+
+PORTNAME= django-ldapdb
+PORTVERSION= 0.1.0
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= avk@vl.ru
+COMMENT= Support for django models over LDAP
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django15>=1.5.0:${PORTSDIR}/www/py-django15 \
+ ${PYTHON_PKGNAMEPREFIX}ldap2>=2.0:${PORTSDIR}/net/py-ldap2
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-django-ldapdb/distinfo b/www/py-django-ldapdb/distinfo
new file mode 100644
index 000000000000..14db5c8e787f
--- /dev/null
+++ b/www/py-django-ldapdb/distinfo
@@ -0,0 +1,2 @@
+SHA256 (django-ldapdb-0.1.0.tar.gz) = fa6a008a004ccfa9b00306f7ddc14b9e370a55b34711287470c8985617a207e0
+SIZE (django-ldapdb-0.1.0.tar.gz) = 7282
diff --git a/www/py-django-ldapdb/pkg-descr b/www/py-django-ldapdb/pkg-descr
new file mode 100644
index 000000000000..4f6a183b3b7f
--- /dev/null
+++ b/www/py-django-ldapdb/pkg-descr
@@ -0,0 +1,8 @@
+django-ldapdb is an LDAP database backend for Django.
+It allows you to manipulate LDAP entries using Django's models.
+Declaring models using the LDAP backend is very staightforward,
+ you simply inherit from ldapdb.models.Model and declare the fields
+ in the same way as for regular models.
+You can even edit the LDAP entries using Django's admin interface.
+
+WWW: http://opensource.bolloretelecom.eu/projects/django-ldapdb/