aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2002-01-06 07:43:13 +0800
committerdinoex <dinoex@FreeBSD.org>2002-01-06 07:43:13 +0800
commitdb413244c100322f6d3f1e786bfc25cd5faf1a45 (patch)
tree2882387616c92b6edb047d960dfb306df707aa23 /www
parent4bdb304d7f696835f39fa3321ddcf6c2d692cbe9 (diff)
downloadfreebsd-ports-gnome-db413244c100322f6d3f1e786bfc25cd5faf1a45.tar.gz
freebsd-ports-gnome-db413244c100322f6d3f1e786bfc25cd5faf1a45.tar.zst
freebsd-ports-gnome-db413244c100322f6d3f1e786bfc25cd5faf1a45.zip
- make portlint happier
- use DOCSDIR or EXAMPLESDIR - get rid of some INTERACTIVE scrips in news/ifmail
Diffstat (limited to 'www')
-rw-r--r--www/webalizer/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/www/webalizer/Makefile b/www/webalizer/Makefile
index 9981a1f98f0b..8d056efe3c59 100644
--- a/www/webalizer/Makefile
+++ b/www/webalizer/Makefile
@@ -20,6 +20,8 @@ LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd
USE_BZIP2= yes
GNU_CONFIGURE= yes
+DOCSDIR?= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+EXAMPLESDIR?= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
.if defined(BATCH)
# no cosmetique spaces allowed
@@ -73,15 +75,13 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/webalizer.1 ${PREFIX}/man/man1/${i}
.endfor
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/${PKGNAMEPREFIX}webalizer
+ ${MKDIR} ${DOCSDIR}
.for i in ${DOC1}
- @${INSTALL_DATA} ${WRKSRC}/${i} \
- ${PREFIX}/share/doc/${PKGNAMEPREFIX}webalizer/${i}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/${i}
.endfor
- ${MKDIR} ${PREFIX}/share/examples/${PKGNAMEPREFIX}webalizer
+ ${MKDIR} ${EXAMPLESDIR}
.for i in msfree.png sample.conf webalizer.png
- @${INSTALL_DATA} ${WRKSRC}/${i} \
- ${PREFIX}/share/examples/${PKGNAMEPREFIX}webalizer/${i}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${EXAMPLESDIR}/${i}
.endfor
.endif