aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrodrigo <rodrigo@FreeBSD.org>2017-05-03 06:56:14 +0800
committerrodrigo <rodrigo@FreeBSD.org>2017-05-03 06:56:14 +0800
commitde0da7fe3c8d6aa5950e309cfa70d4fd9017d2ba (patch)
treeadce90af0add1ff3fb72d7c401fd717c768cc521 /www
parentff4f37d0245f9d99c9afca18f1be2efc1dccfe62 (diff)
downloadfreebsd-ports-gnome-de0da7fe3c8d6aa5950e309cfa70d4fd9017d2ba.tar.gz
freebsd-ports-gnome-de0da7fe3c8d6aa5950e309cfa70d4fd9017d2ba.tar.zst
freebsd-ports-gnome-de0da7fe3c8d6aa5950e309cfa70d4fd9017d2ba.zip
Fix lessc after breakage by node 6 update.
https://github.com/less/less.js/issues/2881
Diffstat (limited to 'www')
-rw-r--r--www/lessc/Makefile1
-rw-r--r--www/lessc/files/patch-bin_lessc20
2 files changed, 21 insertions, 0 deletions
diff --git a/www/lessc/Makefile b/www/lessc/Makefile
index 0a50113dd4af..acec1b9ea71f 100644
--- a/www/lessc/Makefile
+++ b/www/lessc/Makefile
@@ -4,6 +4,7 @@
PORTNAME= lessc
PORTVERSION= 2.5.1
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= www devel
MAINTAINER= rodrigo@FreeBSD.org
diff --git a/www/lessc/files/patch-bin_lessc b/www/lessc/files/patch-bin_lessc
new file mode 100644
index 000000000000..c2bc58706bdd
--- /dev/null
+++ b/www/lessc/files/patch-bin_lessc
@@ -0,0 +1,20 @@
+--- bin/lessc.orig 2017-05-02 22:40:55 UTC
++++ bin/lessc
+@@ -316,8 +316,8 @@ function printUsage() {
+ }
+
+ if (sourceMapOptions.sourceMapRootpath === undefined) {
+- var pathToMap = path.dirname(sourceMapFileInline ? output : sourceMapOptions.sourceMapFullFilename),
+- pathToInput = path.dirname(sourceMapOptions.sourceMapInputFilename);
++ var pathToMap = path.dirname(sourceMapFileInline ? output : sourceMapOptions.sourceMapFullFilename || '.'),
++ pathToInput = path.dirname(sourceMapOptions.sourceMapInputFilename || '.');
+ sourceMapOptions.sourceMapRootpath = path.relative(pathToMap, pathToInput);
+ }
+
+@@ -484,4 +484,4 @@ function printUsage() {
+ parseLessFile(false, buffer);
+ });
+ }
+-})();
+\ No newline at end of file
++})();