aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2014-12-25 21:16:27 +0800
committerwen <wen@FreeBSD.org>2014-12-25 21:16:27 +0800
commite1cd1adbba901df32874efd84c01f808a8d53e41 (patch)
tree407a7ebfaba181f869f6c15293466e78eb174656 /www
parent2e38ce2a63e6069c6079e36fd7e3434601289622 (diff)
downloadfreebsd-ports-gnome-e1cd1adbba901df32874efd84c01f808a8d53e41.tar.gz
freebsd-ports-gnome-e1cd1adbba901df32874efd84c01f808a8d53e41.tar.zst
freebsd-ports-gnome-e1cd1adbba901df32874efd84c01f808a8d53e41.zip
The ajax keyword which is exported by this plugin allow you to
define a route handler optimized for Ajax queries. WWW: https://metacpan.org/pod/Dancer2::Plugin::Ajax PR: 196253 Submitted by: Henk van Oers<hvo.pm@xs4all.nl>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Dancer2-Plugin-Ajax/Makefile21
-rw-r--r--www/p5-Dancer2-Plugin-Ajax/distinfo2
-rw-r--r--www/p5-Dancer2-Plugin-Ajax/pkg-descr4
-rw-r--r--www/p5-Dancer2-Plugin-Ajax/pkg-plist2
5 files changed, 30 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 555ca892d05a..989e214c7708 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -820,6 +820,7 @@
SUBDIR += p5-Dancer-Session-Cookie
SUBDIR += p5-Dancer-Template-Xslate
SUBDIR += p5-Dancer2
+ SUBDIR += p5-Dancer2-Plugin-Ajax
SUBDIR += p5-Data-TreeDumper-Renderer-DHTML
SUBDIR += p5-Data-Validate-URI
SUBDIR += p5-Emplacken
diff --git a/www/p5-Dancer2-Plugin-Ajax/Makefile b/www/p5-Dancer2-Plugin-Ajax/Makefile
new file mode 100644
index 000000000000..cdc2d9a2b1b3
--- /dev/null
+++ b/www/p5-Dancer2-Plugin-Ajax/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= Dancer2-Plugin-Ajax
+PORTVERSION= 0.200000
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Ajax handling for Dancer2 applications
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+RUN_DEPENDS= p5-Dancer2>=0.156001:${PORTSDIR}/www/p5-Dancer2
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/www/p5-Dancer2-Plugin-Ajax/distinfo b/www/p5-Dancer2-Plugin-Ajax/distinfo
new file mode 100644
index 000000000000..011367e1d889
--- /dev/null
+++ b/www/p5-Dancer2-Plugin-Ajax/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Dancer2-Plugin-Ajax-0.200000.tar.gz) = 8ab8486ad1b0ba81282da4a8b1c6cc62f10c4956d515f4e4e1cec52b88655470
+SIZE (Dancer2-Plugin-Ajax-0.200000.tar.gz) = 13713
diff --git a/www/p5-Dancer2-Plugin-Ajax/pkg-descr b/www/p5-Dancer2-Plugin-Ajax/pkg-descr
new file mode 100644
index 000000000000..4ff469e95517
--- /dev/null
+++ b/www/p5-Dancer2-Plugin-Ajax/pkg-descr
@@ -0,0 +1,4 @@
+The ajax keyword which is exported by this plugin allow you to
+define a route handler optimized for Ajax queries.
+
+WWW: https://metacpan.org/pod/Dancer2::Plugin::Ajax
diff --git a/www/p5-Dancer2-Plugin-Ajax/pkg-plist b/www/p5-Dancer2-Plugin-Ajax/pkg-plist
new file mode 100644
index 000000000000..c0f5c24be18b
--- /dev/null
+++ b/www/p5-Dancer2-Plugin-Ajax/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Dancer2/Plugin/Ajax.pm
+%%PERL5_MAN3%%/Dancer2::Plugin::Ajax.3.gz