aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2017-11-10 07:06:50 +0800
committerswills <swills@FreeBSD.org>2017-11-10 07:06:50 +0800
commite4642fc7e0f00b3e9c569a9e89f489b663be3199 (patch)
tree0bc3f1d44c9cb697c247cd8ab41151e50962afbd /www
parent29bcb780198eecbbe315fdd6ab9db7deee91bddb (diff)
downloadfreebsd-ports-gnome-e4642fc7e0f00b3e9c569a9e89f489b663be3199.tar.gz
freebsd-ports-gnome-e4642fc7e0f00b3e9c569a9e89f489b663be3199.tar.zst
freebsd-ports-gnome-e4642fc7e0f00b3e9c569a9e89f489b663be3199.zip
www/obhttpd: Fix libressl build dependency
PR: 219081 Submitted by: Nikola Kolev <koue@chaosophia.net> (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/obhttpd/Makefile26
-rw-r--r--www/obhttpd/files/patch-lib_libtls_tls__conninfo.c14
2 files changed, 36 insertions, 4 deletions
diff --git a/www/obhttpd/Makefile b/www/obhttpd/Makefile
index 5b3b89837651..1670ea0697ea 100644
--- a/www/obhttpd/Makefile
+++ b/www/obhttpd/Makefile
@@ -2,7 +2,7 @@
PORTNAME= obhttpd
PORTVERSION= 6.0.20161006
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MAINTAINER= koue@chaosophia.net
@@ -44,8 +44,26 @@ post-install:
.include <bsd.port.pre.mk>
-.if empty(SSL_DEFAULT:Mlibressl*)
-IGNORE= needs LibreSSL to build. Set DEFAULT_VERSIONS+=ssl=libressl and rebuild everything
-.endif
+.if ! ${SSL_DEFAULT:Mlibressl*}
+BUILD_DEPENDS+= ${NONEXISTENT}:security/libressl:stage
+
+do-configure:
+ ${REINPLACE_CMD} -e 's|/usr/local|${WRKDIR}/libressl|g' \
+ ${WRKSRC}/usr.sbin/httpd/Makefile
+ ${REINPLACE_CMD} -e 's|LOCALBASE|LIBRESSLBASE|g' \
+ ${WRKSRC}/usr.sbin/httpd/Makefile
+ ${REINPLACE_CMD} -e 's|/usr/local|${WRKDIR}/libressl|g' \
+ ${WRKSRC}/usr.bin/htpasswd/Makefile
+ ${REINPLACE_CMD} -e 's|LOCALBASE|LIBRESSLBASE|g' \
+ ${WRKSRC}/usr.bin/htpasswd/Makefile
+
+. ifnmake describe
+STAGEDIR_libressl!= ${MAKE} -V STAGEDIR -C ${PORTSDIR}/security/libressl
+. endif
+
+pre-configure:
+ @(cd ${STAGEDIR_libressl}${LOCALBASE} && ${COPYTREE_SHARE} \
+ . ${WRKDIR}/libressl "! -name *.so*")
+.endif # SSL_DEFAULT
.include <bsd.port.post.mk>
diff --git a/www/obhttpd/files/patch-lib_libtls_tls__conninfo.c b/www/obhttpd/files/patch-lib_libtls_tls__conninfo.c
new file mode 100644
index 000000000000..360342df4def
--- /dev/null
+++ b/www/obhttpd/files/patch-lib_libtls_tls__conninfo.c
@@ -0,0 +1,14 @@
+--- lib/libtls/tls_conninfo.c.orig 2017-05-04 18:48:54 UTC
++++ lib/libtls/tls_conninfo.c
+@@ -140,9 +140,9 @@ tls_get_peer_cert_times(struct tls *ctx,
+ goto err;
+ if ((after = X509_get_notAfter(ctx->ssl_peer_cert)) == NULL)
+ goto err;
+- if (asn1_time_parse(before->data, before->length, &before_tm, 0) == -1)
++ if (ASN1_time_parse(before->data, before->length, &before_tm, 0) == -1)
+ goto err;
+- if (asn1_time_parse(after->data, after->length, &after_tm, 0) == -1)
++ if (ASN1_time_parse(after->data, after->length, &after_tm, 0) == -1)
+ goto err;
+ if ((*notbefore = timegm(&before_tm)) == -1)
+ goto err;