aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-07-08 03:25:14 +0800
committermiwi <miwi@FreeBSD.org>2009-07-08 03:25:14 +0800
commite46650cdbbc59730ac5c0cd67d7b815beeb81c4e (patch)
tree7d165294052f9538d02dddf87457615449aee646 /www
parent3dc3670484da0ac77cb72d8fcf43935936c81236 (diff)
downloadfreebsd-ports-gnome-e46650cdbbc59730ac5c0cd67d7b815beeb81c4e.tar.gz
freebsd-ports-gnome-e46650cdbbc59730ac5c0cd67d7b815beeb81c4e.tar.zst
freebsd-ports-gnome-e46650cdbbc59730ac5c0cd67d7b815beeb81c4e.zip
WebFlash is a library to display "flash" messages in python web
applications. These messages are usually used to provide feedback to the user (eg: you changes have been saved, your credit card number has been stolen, ...). One important characteristic they must provide is the ability to survive a redirect (ie: display the message in a page after being redirected from a form submission). WWW: http://python-rum.org/wiki/WebFlash PR: ports/136404 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-WebFlash/Makefile26
-rw-r--r--www/py-WebFlash/distinfo3
-rw-r--r--www/py-WebFlash/pkg-descr8
-rw-r--r--www/py-WebFlash/pkg-plist13
5 files changed, 51 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 9f035d959c88..2dfeb167e9e0 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1256,6 +1256,7 @@
SUBDIR += py-HTMLgen
SUBDIR += py-Lightbox
SUBDIR += py-WebError
+ SUBDIR += py-WebFlash
SUBDIR += py-WebTest
SUBDIR += py-albatross
SUBDIR += py-amf
diff --git a/www/py-WebFlash/Makefile b/www/py-WebFlash/Makefile
new file mode 100644
index 000000000000..134cf6ee43eb
--- /dev/null
+++ b/www/py-WebFlash/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: WebFlash
+# Date created: 6th July, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WebFlash
+PORTVERSION= 0.1a9
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Library to display flash messages in python web applications
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 260
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}simplejson>=0:${PORTSDIR}/devel/py-simplejson
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/py-WebFlash/distinfo b/www/py-WebFlash/distinfo
new file mode 100644
index 000000000000..4cd204525dab
--- /dev/null
+++ b/www/py-WebFlash/distinfo
@@ -0,0 +1,3 @@
+MD5 (WebFlash-0.1a9.tar.gz) = faf2a563097baa7b24cf724565d5b1d0
+SHA256 (WebFlash-0.1a9.tar.gz) = 061aa6971da68ce9cfc1909f1dc7335d49546e4e7efccf54679b8c2c49062a7c
+SIZE (WebFlash-0.1a9.tar.gz) = 7374
diff --git a/www/py-WebFlash/pkg-descr b/www/py-WebFlash/pkg-descr
new file mode 100644
index 000000000000..0779ce25a2f9
--- /dev/null
+++ b/www/py-WebFlash/pkg-descr
@@ -0,0 +1,8 @@
+WebFlash is a library to display "flash" messages in python web
+applications. These messages are usually used to provide feedback
+to the user (eg: you changes have been saved, your credit card
+number has been stolen, ...). One important characteristic they
+must provide is the ability to survive a redirect (ie: display the
+message in a page after being redirected from a form submission).
+
+WWW: http://python-rum.org/wiki/WebFlash
diff --git a/www/py-WebFlash/pkg-plist b/www/py-WebFlash/pkg-plist
new file mode 100644
index 000000000000..df421eb1b0d7
--- /dev/null
+++ b/www/py-WebFlash/pkg-plist
@@ -0,0 +1,13 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/webflash/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/webflash/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/webflash/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/webflash/webflash.js
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/webflash/webflash.min.js
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/webflash
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%