aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-07-17 14:19:12 +0800
committerbapt <bapt@FreeBSD.org>2015-07-17 14:19:12 +0800
commite5d1a2ff74f816bb32d376e11ee5d3ba012375af (patch)
tree7c556d4712b5f67bec39b07a9546512da54caf33 /www
parent08ae788c316a8db0a1eecb2f6b77057ec3e244d7 (diff)
downloadfreebsd-ports-gnome-e5d1a2ff74f816bb32d376e11ee5d3ba012375af.tar.gz
freebsd-ports-gnome-e5d1a2ff74f816bb32d376e11ee5d3ba012375af.tar.zst
freebsd-ports-gnome-e5d1a2ff74f816bb32d376e11ee5d3ba012375af.zip
Update to 0.6.2
Diffstat (limited to 'www')
-rw-r--r--www/kcgi/Makefile2
-rw-r--r--www/kcgi/distinfo4
-rw-r--r--www/kcgi/files/patch-child.c12
-rw-r--r--www/kcgi/files/patch-kcgiregress.c12
-rw-r--r--www/kcgi/files/patch-output.c20
-rw-r--r--www/kcgi/pkg-plist7
6 files changed, 53 insertions, 4 deletions
diff --git a/www/kcgi/Makefile b/www/kcgi/Makefile
index 6e2b4ffdaeff..ab079d0433db 100644
--- a/www/kcgi/Makefile
+++ b/www/kcgi/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= kcgi
-PORTVERSION= 0.6.1
+PORTVERSION= 0.6.2
CATEGORIES= www devel
MASTER_SITES= http://kristaps.bsd.lv/kcgi/snapshots/
diff --git a/www/kcgi/distinfo b/www/kcgi/distinfo
index 26ebdefad202..9c5f192d87c8 100644
--- a/www/kcgi/distinfo
+++ b/www/kcgi/distinfo
@@ -1,2 +1,2 @@
-SHA256 (kcgi-0.6.1.tgz) = 5e0779067ff661103884d470afbbe4f85a81ccbcd29778795e6f7d28ba4bb91e
-SIZE (kcgi-0.6.1.tgz) = 84326
+SHA256 (kcgi-0.6.2.tgz) = a1e5104c521f6528afd544c20e2c35e176916085659a878ae99eb59dc119534d
+SIZE (kcgi-0.6.2.tgz) = 97487
diff --git a/www/kcgi/files/patch-child.c b/www/kcgi/files/patch-child.c
new file mode 100644
index 000000000000..445c8b8051d5
--- /dev/null
+++ b/www/kcgi/files/patch-child.c
@@ -0,0 +1,12 @@
+--- child.c.orig 2015-07-16 22:52:47 UTC
++++ child.c
+@@ -17,9 +17,7 @@
+ #ifdef HAVE_CONFIG_H
+ #include "config.h"
+ #endif
+-#ifdef __linux__
+ #include <arpa/inet.h>
+-#endif
+
+ #include <assert.h>
+ #include <ctype.h>
diff --git a/www/kcgi/files/patch-kcgiregress.c b/www/kcgi/files/patch-kcgiregress.c
new file mode 100644
index 000000000000..e5db70d58016
--- /dev/null
+++ b/www/kcgi/files/patch-kcgiregress.c
@@ -0,0 +1,12 @@
+--- kcgiregress.c.orig 2015-07-17 06:16:43 UTC
++++ kcgiregress.c
+@@ -197,9 +197,6 @@ dochild_cgi(kcgi_regress_server child, v
+ setenv(headbuf, val, 1);
+ }
+
+- if (NULL == head)
+- goto out;
+-
+ if (-1 != in)
+ close(in);
+ if (-1 != s)
diff --git a/www/kcgi/files/patch-output.c b/www/kcgi/files/patch-output.c
new file mode 100644
index 000000000000..4807f2993625
--- /dev/null
+++ b/www/kcgi/files/patch-output.c
@@ -0,0 +1,20 @@
+--- output.c.orig 2015-07-16 22:52:47 UTC
++++ output.c
+@@ -17,9 +17,7 @@
+ #ifdef HAVE_CONFIG_H
+ #include "config.h"
+ #endif
+-#ifdef __linux__
+ #include <arpa/inet.h>
+-#endif
+
+ #include <assert.h>
+ #include <stdarg.h>
+@@ -27,6 +25,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <unistd.h>
+ #ifdef HAVE_ZLIB
+ #include <zlib.h>
+ #endif
diff --git a/www/kcgi/pkg-plist b/www/kcgi/pkg-plist
index 8ea0ac5d6b60..40bd6a3c27aa 100644
--- a/www/kcgi/pkg-plist
+++ b/www/kcgi/pkg-plist
@@ -6,12 +6,15 @@ lib/libkcgi.a
lib/libkcgihtml.a
lib/libkcgijson.a
lib/libkcgixml.a
-man/man3/kcgi.3.gz
+man/man3/kcgi.3.gr
man/man3/kcgi_regress.3.gz
man/man3/kcgihtml.3.gz
man/man3/kcgijson.3.gz
man/man3/kcgixml.3.gz
man/man3/khttp_body.3.gz
+man/man3/khttp_fcgi_free.3.gz
+man/man3/khttp_fcgi_init.3.gz
+man/man3/khttp_fcgi_parse.3.gz
man/man3/khttp_free.3.gz
man/man3/khttp_head.3.gz
man/man3/khttp_parse.3.gz
@@ -20,5 +23,7 @@ man/man3/khttp_write.3.gz
man/man3/kmalloc.3.gz
man/man3/kutil_urlencode.3.gz
man/man3/kvalid_string.3.gz
+man/man8/kfcgi.8.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sample.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sample-fcgi.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/template.xml