aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-09-13 00:56:48 +0800
committerantoine <antoine@FreeBSD.org>2014-09-13 00:56:48 +0800
commite88b2807b9002fe0820a23b8625df7ec68732268 (patch)
treedbf70ee2dd63fe4b9d9aceea5de3e25ce8d34d3a /www
parent6dfd116535cfd93f258ac1e38f1a0d63f7de9093 (diff)
downloadfreebsd-ports-gnome-e88b2807b9002fe0820a23b8625df7ec68732268.tar.gz
freebsd-ports-gnome-e88b2807b9002fe0820a23b8625df7ec68732268.tar.zst
freebsd-ports-gnome-e88b2807b9002fe0820a23b8625df7ec68732268.zip
- Allow staging as a regular user
- Bump portrevision as files were not packaged with intended owner
Diffstat (limited to 'www')
-rw-r--r--www/lilurl/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/www/lilurl/Makefile b/www/lilurl/Makefile
index 1d7fda397416..5cad3079fd75 100644
--- a/www/lilurl/Makefile
+++ b/www/lilurl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= lilurl
PORTVERSION= 0.1.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}.tar.gz
@@ -19,25 +20,24 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
PLIST= ${WRKDIR}/pkg-plist
-.include <bsd.port.pre.mk>
-
post-extract:
@${MV} ${WRKSRC}/includes/conf.php ${WRKSRC}/includes/conf.php.sample
pre-install:
+ @${ECHO_CMD} -e "@owner ${WWWOWN}\n@group ${WWWGRP}" > ${PLIST}
@cd ${WRKSRC} && ${FIND} -s . -type f | \
- ${SED} -e 's|^./||;s|^|${LILURL_DIR}/|' > ${PLIST} \
+ ${SED} -e 's|^./||;s|^|${LILURL_DIR}/|' >> ${PLIST} \
&& ${FIND} -d * -type d | \
${SED} -e 's|^|@dirrm ${LILURL_DIR}/|' >> ${PLIST} \
&& ${ECHO_CMD} @dirrm ${LILURL_DIR} >> ${PLIST}
+ @${ECHO_CMD} -e "@owner root\n@group wheel" >> ${PLIST}
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${LILURL_DIR}
@${CP} -R ${WRKSRC}/ ${STAGEDIR}${PREFIX}/${LILURL_DIR}
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${STAGEDIR}${PREFIX}/${LILURL_DIR}
post-install:
@${SED} -e 's,%%PREFIX%%,${PREFIX},; s,%%LILURL_DIR%%,${LILURL_DIR},g' \
${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>