aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2011-12-31 16:26:14 +0800
committerkuriyama <kuriyama@FreeBSD.org>2011-12-31 16:26:14 +0800
commited23c6826fbcd352c83bda8ccac1d366ff52b7e3 (patch)
tree99a0394684e935e3bff016cb736a8a364a060bdc /www
parent66557209cbab57fdb574f13f2abdf184cd700f61 (diff)
downloadfreebsd-ports-gnome-ed23c6826fbcd352c83bda8ccac1d366ff52b7e3.tar.gz
freebsd-ports-gnome-ed23c6826fbcd352c83bda8ccac1d366ff52b7e3.tar.zst
freebsd-ports-gnome-ed23c6826fbcd352c83bda8ccac1d366ff52b7e3.zip
This is a wrapper to Furl for asynchronous HTTP requests with Coro.
WWW: http://search.cpan.org/dist/FurlX-Coro/
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-FurlX-Coro/Makefile30
-rw-r--r--www/p5-FurlX-Coro/distinfo2
-rw-r--r--www/p5-FurlX-Coro/pkg-descr3
-rw-r--r--www/p5-FurlX-Coro/pkg-plist8
5 files changed, 44 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 8070f0c67543..8c9b64c4466c 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -899,6 +899,7 @@
SUBDIR += p5-Flickr-Upload
SUBDIR += p5-Fliggy
SUBDIR += p5-Furl
+ SUBDIR += p5-FurlX-Coro
SUBDIR += p5-Gantry
SUBDIR += p5-Geo-Caching
SUBDIR += p5-Google-Code-Upload
diff --git a/www/p5-FurlX-Coro/Makefile b/www/p5-FurlX-Coro/Makefile
new file mode 100644
index 000000000000..c16ab2e707c1
--- /dev/null
+++ b/www/p5-FurlX-Coro/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: FurlX::Coro
+# Date created: 31 Dec 2011
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= FurlX-Coro
+PORTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/G/GF/GFUJI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for multiple HTTP requests with Coro
+
+RUN_DEPENDS= \
+ p5-Coro>0:${PORTSDIR}/devel/p5-Coro \
+ p5-Furl>0:${PORTSDIR}/www/p5-Furl
+BUILD_DEPENDS= \
+ ${RUN_DEPENDS} \
+ p5-Test-Requires>0:${PORTSDIR}/devel/p5-Test-Requires
+
+PERL_CONFIGURE= yes
+
+MAN3= FurlX::Coro.3 \
+ FurlX::Coro::HTTP.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-FurlX-Coro/distinfo b/www/p5-FurlX-Coro/distinfo
new file mode 100644
index 000000000000..225f10553475
--- /dev/null
+++ b/www/p5-FurlX-Coro/distinfo
@@ -0,0 +1,2 @@
+SHA256 (FurlX-Coro-0.01.tar.gz) = 34d69a35d2d03d453c43f46e35d518513a3fc2bf5154aa35d446225a52b445b7
+SIZE (FurlX-Coro-0.01.tar.gz) = 20058
diff --git a/www/p5-FurlX-Coro/pkg-descr b/www/p5-FurlX-Coro/pkg-descr
new file mode 100644
index 000000000000..324efa10e01f
--- /dev/null
+++ b/www/p5-FurlX-Coro/pkg-descr
@@ -0,0 +1,3 @@
+This is a wrapper to Furl for asynchronous HTTP requests with Coro.
+
+WWW: http://search.cpan.org/dist/FurlX-Coro/
diff --git a/www/p5-FurlX-Coro/pkg-plist b/www/p5-FurlX-Coro/pkg-plist
new file mode 100644
index 000000000000..ed75e63f8a1b
--- /dev/null
+++ b/www/p5-FurlX-Coro/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/FurlX/Coro/.packlist
+%%SITE_PERL%%/FurlX/.dim.pl
+%%SITE_PERL%%/FurlX/Coro.pm
+%%SITE_PERL%%/FurlX/Coro/HTTP.pm
+@dirrm %%SITE_PERL%%/FurlX/Coro
+@dirrmtry %%SITE_PERL%%/FurlX
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/FurlX/Coro
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/FurlX