aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-09-22 18:48:57 +0800
committermat <mat@FreeBSD.org>2017-09-22 18:48:57 +0800
commitf7ea694d40fb25ebb08976089f0d25ef8068e94e (patch)
treec94257e28b8e5f01fe14d767f8a4ade36ad9d111 /www
parent6f0cd74a7e03c52a2dddfb99666ec0c3814fd7bb (diff)
downloadfreebsd-ports-gnome-f7ea694d40fb25ebb08976089f0d25ef8068e94e.tar.gz
freebsd-ports-gnome-f7ea694d40fb25ebb08976089f0d25ef8068e94e.tar.zst
freebsd-ports-gnome-f7ea694d40fb25ebb08976089f0d25ef8068e94e.zip
Cleanup after removal of libexecinfo from ports.
PR: 220271 Submitted by: mat (review), Yasuhiro KIMURA (PR) Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D11488
Diffstat (limited to 'www')
-rw-r--r--www/links-hacked/Makefile3
-rw-r--r--www/mod_spdy/Makefile2
-rw-r--r--www/mod_spdy/files/patch-base.gypi4
3 files changed, 5 insertions, 4 deletions
diff --git a/www/links-hacked/Makefile b/www/links-hacked/Makefile
index 5155a1dfffc2..b9c74ce65ff2 100644
--- a/www/links-hacked/Makefile
+++ b/www/links-hacked/Makefile
@@ -18,8 +18,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ssl --without-pmshell --without-atheos --without-fb
CFLAGS+= -Wno-error=return-type
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
+LDFLAGS+= -lexecinfo
CONFLICTS= links-[0-9]*
diff --git a/www/mod_spdy/Makefile b/www/mod_spdy/Makefile
index 3d6b1976b92c..1a2a5afc1714 100644
--- a/www/mod_spdy/Makefile
+++ b/www/mod_spdy/Makefile
@@ -38,7 +38,7 @@ GYP_DEFINES+= \
system_include_path_httpd=${LOCALBASE}/include/apache22 \
system_include_path_apr=${LOCALBASE}/include/apr-1 \
system_include_path_aprutil=${LOCALBASE}/include/apr-1 \
- system_include_path_execinfo=${LOCALBASE}/include \
+ system_include_path_execinfo=/usr/include \
include_dirs=${LOCALBASE}/include
SUB_FILES+= mod_spdy.conf
diff --git a/www/mod_spdy/files/patch-base.gypi b/www/mod_spdy/files/patch-base.gypi
index 2fd1a7baa2b1..6ae78a6ca390 100644
--- a/www/mod_spdy/files/patch-base.gypi
+++ b/www/mod_spdy/files/patch-base.gypi
@@ -1,10 +1,12 @@
+FIXME: this feels a bit silly now.
+
--- base/base.gypi.org 2012-03-31 16:28:56.347804000 +0900
+++ base/base.gypi 2012-03-31 17:03:22.470770534 +0900
@@ -7,6 +7,7 @@
'variables': {
'base_target': 0,
'chromium_root': '<(DEPTH)/third_party/chromium/src',
-+ 'system_include_path_execinfo%': '%%LOCALBASE%%/include',
++ 'system_include_path_execinfo%': '/usr/include',
},
'target_conditions': [
# This part is shared between the targets defined below. Only files and