aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-09-27 12:12:05 +0800
committerjbeich <jbeich@FreeBSD.org>2017-09-27 12:12:05 +0800
commitf9cf22dd7a14f96f3e66670c7df1503bcc5ac1ea (patch)
tree635092dffdea12e2325691d4c46a31b2dbbd707b /www
parent3bcc4e17abe0b08ee0a3d63882f9d67686d0db70 (diff)
downloadfreebsd-ports-gnome-f9cf22dd7a14f96f3e66670c7df1503bcc5ac1ea.tar.gz
freebsd-ports-gnome-f9cf22dd7a14f96f3e66670c7df1503bcc5ac1ea.tar.zst
freebsd-ports-gnome-f9cf22dd7a14f96f3e66670c7df1503bcc5ac1ea.zip
gecko: add JACK option (enabled by default)
PR: 221464
Diffstat (limited to 'www')
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox-esr/files/patch-bug138695714
-rw-r--r--www/firefox-esr/pkg-message7
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/firefox/Makefile.options6
-rw-r--r--www/firefox/files/patch-bug138695714
-rw-r--r--www/firefox/pkg-message7
-rw-r--r--www/libxul/Makefile1
-rw-r--r--www/seamonkey/Makefile2
-rw-r--r--www/seamonkey/files/patch-bug138695714
10 files changed, 64 insertions, 5 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 35a7f7ad8304..5aff53232918 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -4,7 +4,7 @@
PORTNAME= firefox
DISTVERSION= 52.3.0
DISTVERSIONSUFFIX=esr.source
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox-esr/files/patch-bug1386957 b/www/firefox-esr/files/patch-bug1386957
new file mode 100644
index 000000000000..8c035624e16f
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug1386957
@@ -0,0 +1,14 @@
+https://github.com/kinetiknz/cubeb/commit/16f9ccc064f2
+
+--- media/libcubeb/src/cubeb_jack.cpp.orig 2017-07-07 05:37:16 UTC
++++ media/libcubeb/src/cubeb_jack.cpp
+@@ -8,7 +8,9 @@
+ */
+ #define _DEFAULT_SOURCE
+ #define _BSD_SOURCE
++#ifndef __FreeBSD__
+ #define _POSIX_SOURCE
++#endif
+ #include <algorithm>
+ #include <dlfcn.h>
+ #include <limits>
diff --git a/www/firefox-esr/pkg-message b/www/firefox-esr/pkg-message
index 828dcc62c6a4..cb201deae462 100644
--- a/www/firefox-esr/pkg-message
+++ b/www/firefox-esr/pkg-message
@@ -10,6 +10,13 @@ Some features available on other platforms are not implemented:
======================================================================
+To select non-default audio backend open about:config page and create
+media.cubeb.backend preference. Supported values are: alsa, jack,
+pulse, oss, sndio. Currently, selected backend can be inspected on
+about:support page.
+
+======================================================================
+
smb:// issues (Gvfs/GIO option):
Network group, machine, and share browsing does not work correctly.
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index a40300938640..a52cfd1d6927 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -4,7 +4,7 @@
PORTNAME= firefox
DISTVERSION= 55.0.3
DISTVERSIONSUFFIX=.source
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
diff --git a/www/firefox/Makefile.options b/www/firefox/Makefile.options
index ddaef7a3355d..33830c95745c 100644
--- a/www/firefox/Makefile.options
+++ b/www/firefox/Makefile.options
@@ -5,12 +5,14 @@ OPTIONS_DEFINE+= BUNDLED_CAIRO CANBERRA DBUS DEBUG DTRACE FFMPEG GCONF \
OPTIMIZED_CFLAGS PGO PROFILE TEST
OPTIONS_DEFAULT+= DBUS DTRACE FFMPEG OPTIMIZED_CFLAGS \
- ALSA PULSEAUDIO \
+ ${OPTIONS_MULTI_AUDIO:NSNDIO} \
${MACHINE_CPU:Msoftfp:C/.+/INTEGER_SAMPLES/}
OPTIONS_MULTI+= AUDIO
-OPTIONS_MULTI_AUDIO= ALSA PULSEAUDIO SNDIO
+OPTIONS_MULTI_AUDIO= ALSA JACK PULSEAUDIO SNDIO
+# WebRTC legacy audio library only supports ALSA and PulseAudio
+JACK_IMPLIES= ALSA
# No lazy-bindings and inconsistent fallback order (libcubeb vs. audio_device)
SNDIO_PREVENTS= ${OPTIONS_MULTI_AUDIO:NSNDIO}
diff --git a/www/firefox/files/patch-bug1386957 b/www/firefox/files/patch-bug1386957
new file mode 100644
index 000000000000..34b38c5c1298
--- /dev/null
+++ b/www/firefox/files/patch-bug1386957
@@ -0,0 +1,14 @@
+https://github.com/kinetiknz/cubeb/commit/16f9ccc064f2
+
+--- media/libcubeb/src/cubeb_jack.cpp.orig 2017-07-07 05:37:16 UTC
++++ media/libcubeb/src/cubeb_jack.cpp
+@@ -8,7 +8,9 @@
+ */
+ #define _DEFAULT_SOURCE
+ #define _BSD_SOURCE
++#ifndef __FreeBSD__
+ #define _POSIX_SOURCE
++#endif
+ #include <dlfcn.h>
+ #include <stdio.h>
+ #include <string.h>
diff --git a/www/firefox/pkg-message b/www/firefox/pkg-message
index dd05b38f33ad..7ff1f03ed8c8 100644
--- a/www/firefox/pkg-message
+++ b/www/firefox/pkg-message
@@ -11,6 +11,13 @@ Some features available on other platforms are not implemented:
======================================================================
+To select non-default audio backend open about:config page and create
+media.cubeb.backend preference. Supported values are: alsa, jack,
+pulse, pulse-rust, oss, sndio. Currently, selected backend can be
+inspected on about:support page.
+
+======================================================================
+
smb:// issues (Gvfs/GIO option):
Network group, machine, and share browsing does not work correctly.
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index c7733a4c9368..482631c56131 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -58,6 +58,7 @@ OPTIONS_SINGLE+= TOOLKIT
OPTIONS_SINGLE_TOOLKIT= GTK2 GTK3
.include "${.CURDIR}/../../www/firefox/Makefile.options"
+OPTIONS_MULTI_AUDIO:= ${OPTIONS_MULTI_AUDIO:NJACK}
.if ${USE_MOZILLA:M-nss}
MOZ_PKGCONFIG_FILES+= mozilla-nss
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 2bbd4ac7548c..1c521ae442a4 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -4,7 +4,7 @@
PORTNAME= seamonkey
DISTVERSION= 2.48
MOZILLA_VER= 51 # above + 3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES?= www mail news editors irc ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/www/seamonkey/files/patch-bug1386957 b/www/seamonkey/files/patch-bug1386957
new file mode 100644
index 000000000000..d7421200aa78
--- /dev/null
+++ b/www/seamonkey/files/patch-bug1386957
@@ -0,0 +1,14 @@
+https://github.com/kinetiknz/cubeb/commit/16f9ccc064f2
+
+--- mozilla/media/libcubeb/src/cubeb_jack.cpp.orig 2017-07-07 05:37:16 UTC
++++ mozilla/media/libcubeb/src/cubeb_jack.cpp
+@@ -8,7 +8,9 @@
+ */
+ #define _DEFAULT_SOURCE
+ #define _BSD_SOURCE
++#ifndef __FreeBSD__
+ #define _POSIX_SOURCE
++#endif
+ #include <algorithm>
+ #include <dlfcn.h>
+ #include <limits>