aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2009-10-13 18:12:43 +0800
committerkuriyama <kuriyama@FreeBSD.org>2009-10-13 18:12:43 +0800
commitfc485d708ce09530440388f6c78ab02d98344b2a (patch)
treec07c5a68aaca170b567740a654149a18a0bd432d /www
parent84050dad7ec566e175add78d198d166e66288ad8 (diff)
downloadfreebsd-ports-gnome-fc485d708ce09530440388f6c78ab02d98344b2a.tar.gz
freebsd-ports-gnome-fc485d708ce09530440388f6c78ab02d98344b2a.tar.zst
freebsd-ports-gnome-fc485d708ce09530440388f6c78ab02d98344b2a.zip
Enable your CGI.pm aware applications to adapt PSGI protocol.
WWW: http://search.cpan.org/dist/CGI-PSGI/
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-CGI-PSGI/Makefile21
-rw-r--r--www/p5-CGI-PSGI/distinfo3
-rw-r--r--www/p5-CGI-PSGI/pkg-descr3
-rw-r--r--www/p5-CGI-PSGI/pkg-plist5
5 files changed, 33 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 2b64696f9f18..d772a539a4d6 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -704,6 +704,7 @@
SUBDIR += p5-CGI-Framework
SUBDIR += p5-CGI-Kwiki
SUBDIR += p5-CGI-Minimal
+ SUBDIR += p5-CGI-PSGI
SUBDIR += p5-CGI-Pager
SUBDIR += p5-CGI-Prototype
SUBDIR += p5-CGI-Response
diff --git a/www/p5-CGI-PSGI/Makefile b/www/p5-CGI-PSGI/Makefile
new file mode 100644
index 000000000000..40a2e85f50eb
--- /dev/null
+++ b/www/p5-CGI-PSGI/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: CGI::PSGI
+# Date created: 13 Oct 2009
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-PSGI
+PORTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to enable CGI.pm applications to adapt PSGI
+
+PERL_CONFIGURE= yes
+
+MAN3= CGI::PSGI.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-CGI-PSGI/distinfo b/www/p5-CGI-PSGI/distinfo
new file mode 100644
index 000000000000..bdb359ec4cc9
--- /dev/null
+++ b/www/p5-CGI-PSGI/distinfo
@@ -0,0 +1,3 @@
+MD5 (CGI-PSGI-0.01.tar.gz) = 2b253dd2462901d98cf2328cb623476f
+SHA256 (CGI-PSGI-0.01.tar.gz) = 62ad46730874816994f8da74cf97ed906fc8ddcb64496b6bdd33d45ff0ef280f
+SIZE (CGI-PSGI-0.01.tar.gz) = 45016
diff --git a/www/p5-CGI-PSGI/pkg-descr b/www/p5-CGI-PSGI/pkg-descr
new file mode 100644
index 000000000000..3afcac8fb7f8
--- /dev/null
+++ b/www/p5-CGI-PSGI/pkg-descr
@@ -0,0 +1,3 @@
+Enable your CGI.pm aware applications to adapt PSGI protocol.
+
+WWW: http://search.cpan.org/dist/CGI-PSGI/
diff --git a/www/p5-CGI-PSGI/pkg-plist b/www/p5-CGI-PSGI/pkg-plist
new file mode 100644
index 000000000000..c474824fedde
--- /dev/null
+++ b/www/p5-CGI-PSGI/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/PSGI/.packlist
+%%SITE_PERL%%/CGI/PSGI.pm
+@dirrmtry %%SITE_PERL%%/CGI
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/PSGI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI