aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2017-09-15 23:19:28 +0800
committerkoobs <koobs@FreeBSD.org>2017-09-15 23:19:28 +0800
commitfce9336c39975c0644a5a8696268c0b92a64fa7e (patch)
tree7cb52c9ee4564fe831b4bb5be12af73217b01105 /www
parent8f3d88d3969ea2474580cb73cf8e21c71b8386e4 (diff)
downloadfreebsd-ports-gnome-fce9336c39975c0644a5a8696268c0b92a64fa7e.tar.gz
freebsd-ports-gnome-fce9336c39975c0644a5a8696268c0b92a64fa7e.tar.zst
freebsd-ports-gnome-fce9336c39975c0644a5a8696268c0b92a64fa7e.zip
www/py-gandi.cli: Update to 0.22
Changelog: https://github.com/Gandi/gandi.cli/blob/0.22/CHANGES.rst Requested by: bapt
Diffstat (limited to 'www')
-rw-r--r--www/py-gandi.cli/Makefile2
-rw-r--r--www/py-gandi.cli/distinfo6
-rw-r--r--www/py-gandi.cli/files/patch-setup.py14
3 files changed, 11 insertions, 11 deletions
diff --git a/www/py-gandi.cli/Makefile b/www/py-gandi.cli/Makefile
index b033d61d594a..73454a4aa5b6 100644
--- a/www/py-gandi.cli/Makefile
+++ b/www/py-gandi.cli/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gandi.cli
-PORTVERSION= 0.21
+PORTVERSION= 0.22
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/www/py-gandi.cli/distinfo b/www/py-gandi.cli/distinfo
index 8544aa80967d..21e5da465138 100644
--- a/www/py-gandi.cli/distinfo
+++ b/www/py-gandi.cli/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1505202146
-SHA256 (gandi.cli-0.21.tar.gz) = 931da484b50a3cb99f58013588b749be01663488689c5057035434a37befd8c5
-SIZE (gandi.cli-0.21.tar.gz) = 149213
+TIMESTAMP = 1505488175
+SHA256 (gandi.cli-0.22.tar.gz) = 5666b544e313132cf9cfe82fb3a163ce140df0e1b91d5452d54dd50a49b0b8e6
+SIZE (gandi.cli-0.22.tar.gz) = 149823
diff --git a/www/py-gandi.cli/files/patch-setup.py b/www/py-gandi.cli/files/patch-setup.py
index d7d047c6e05c..9afd26949bdf 100644
--- a/www/py-gandi.cli/files/patch-setup.py
+++ b/www/py-gandi.cli/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2016-02-08 14:17:09 UTC
+--- setup.py.orig 2017-09-13 12:32:20 UTC
+++ setup.py
-@@ -6,11 +6,11 @@ import os
+@@ -6,19 +6,19 @@ import os
import sys
from setuptools import setup, find_packages
@@ -9,22 +9,22 @@
here = os.path.abspath(os.path.dirname(__file__))
-README = open(os.path.join(here, 'README.md')).read()
-CHANGES = open(os.path.join(here, 'CHANGES.rst')).read()
--
+README = open(os.path.join(here, 'README.md'), encoding='utf-8').read()
+CHANGES = open(os.path.join(here, 'CHANGES.rst'), encoding='utf-8').read()
+-
with open(os.path.join(here, 'gandi', 'cli', '__init__.py')) as v_file:
version = re.compile(r".*__version__ = '(.*?)'",
-@@ -18,7 +18,7 @@ with open(os.path.join(here, 'gandi', 'c
+ re.S).match(v_file.read()).group(1)
requires = ['setuptools', 'pyyaml', 'click>=3.1', 'requests', 'IPy']
--tests_require = ['nose', 'coverage', 'tox', 'httpretty==0.8.6']
-+tests_require = ['httpretty>=0.8.6']
+-tests_require = ['nose', 'coverage', 'tox']
++tests_require = []
if sys.version_info < (2, 7):
tests_require += ['unittest2', 'importlib']
-@@ -54,7 +54,7 @@ setup(name='gandi.cli',
+@@ -55,7 +55,7 @@ setup(name='gandi.cli',
zip_safe=False,
install_requires=requires,
tests_require=tests_require,