aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-02-18 01:07:37 +0800
committerpgj <pgj@FreeBSD.org>2012-02-18 01:07:37 +0800
commit007bf4964c434dfe2911939c59ff840b46f4d07c (patch)
tree147b3f714070b97e6a78db89cc6d199b12d994f2 /www
parentbec297f18cf26b64cf986d61bd6527abfe0b4b2d (diff)
downloadfreebsd-ports-gnome-007bf4964c434dfe2911939c59ff840b46f4d07c.tar.gz
freebsd-ports-gnome-007bf4964c434dfe2911939c59ff840b46f4d07c.tar.zst
freebsd-ports-gnome-007bf4964c434dfe2911939c59ff840b46f4d07c.zip
Just pick which parts of your data structures you want indexed using an
easy to use template-haskell function. Spare yourself the need to write, run, and maintain code that marshalls your data to/from an external relational database just for efficient queries. The happstack-ixset relies on generics and TH to spare you the boilerplate normally required for such tasks. WWW: http://happstack.com/ Obtained from: FreeBSD Haskell
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/hs-happstack-ixset/Makefile23
-rw-r--r--www/hs-happstack-ixset/distinfo2
-rw-r--r--www/hs-happstack-ixset/pkg-descr8
4 files changed, 34 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 802d93f7df09..4fef968b339a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -282,6 +282,7 @@
SUBDIR += hs-cgi
SUBDIR += hs-hS3
SUBDIR += hs-happstack-data
+ SUBDIR += hs-happstack-ixset
SUBDIR += hs-happstack-util
SUBDIR += hs-heist
SUBDIR += hs-fastcgi
diff --git a/www/hs-happstack-ixset/Makefile b/www/hs-happstack-ixset/Makefile
new file mode 100644
index 000000000000..4d6606d6c666
--- /dev/null
+++ b/www/hs-happstack-ixset/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: hs-happstack-ixset
+# Date created: December 2, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= happstack-ixset
+PORTVERSION= 6.0.1
+CATEGORIES= www haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Efficient relational queries on Haskell sets
+
+LICENSE= BSD
+FILE_LICENSE= COPYING
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= happstack-data>=6.0 happstack-util>=6.0 mtl>=1.1 \
+ syb syb-with-class>=0.6.1
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/www/hs-happstack-ixset/distinfo b/www/hs-happstack-ixset/distinfo
new file mode 100644
index 000000000000..02c21ae78cb4
--- /dev/null
+++ b/www/hs-happstack-ixset/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/happstack-ixset-6.0.1.tar.gz) = d122eeff5fa0e0321a8a76d2b1ff39f9d99cc70df5dc13be9db970e723b0d0c2
+SIZE (cabal/happstack-ixset-6.0.1.tar.gz) = 13169
diff --git a/www/hs-happstack-ixset/pkg-descr b/www/hs-happstack-ixset/pkg-descr
new file mode 100644
index 000000000000..731dcdccc780
--- /dev/null
+++ b/www/hs-happstack-ixset/pkg-descr
@@ -0,0 +1,8 @@
+Just pick which parts of your data structures you want indexed using an
+easy to use template-haskell function. Spare yourself the need to
+write, run, and maintain code that marshalls your data to/from an
+external relational database just for efficient queries. The
+happstack-ixset relies on generics and TH to spare you the boilerplate
+normally required for such tasks.
+
+WWW: http://happstack.com/