aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-10-21 16:43:17 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-10-21 16:43:17 +0800
commit04f31183ebff0e58bdc444dfcc189726024cf010 (patch)
tree4f926c6e6068d078fe8b9175d2305539c6413b02 /www
parent185ea946b27148415460b8f78ec2b1ca705e40e9 (diff)
downloadfreebsd-ports-gnome-04f31183ebff0e58bdc444dfcc189726024cf010.tar.gz
freebsd-ports-gnome-04f31183ebff0e58bdc444dfcc189726024cf010.tar.zst
freebsd-ports-gnome-04f31183ebff0e58bdc444dfcc189726024cf010.zip
- Convert to new options helper
- Support STAGEDIR - Use PLIST - Fix typo
Diffstat (limited to 'www')
-rw-r--r--www/aria2/Makefile69
1 files changed, 12 insertions, 57 deletions
diff --git a/www/aria2/Makefile b/www/aria2/Makefile
index 9b661a176cad..5f96bc0c8601 100644
--- a/www/aria2/Makefile
+++ b/www/aria2/Makefile
@@ -13,6 +13,7 @@ LICENSE= GPLv2
OPTIONS_DEFINE= CA_BUNDLE DOCS NLS SQLITE
OPTIONS_DEFAULT=SQLITE
+OPTIONS_SUB= yes
CA_BUNDLE_DESC= Use CA bundle from Mozilla Project
CONFIGURE_ARGS= --disable-epoll --enable-bittorrent --enable-metalink \
@@ -21,7 +22,7 @@ CONFIGURE_ARGS= --disable-epoll --enable-bittorrent --enable-metalink \
--without-libcares --without-libexpat --without-libgcrypt \
--without-libgmp --without-libnettle
CONFIGURE_ENV= OPENSSL_CFLAGS=-I${OPENSSLINC} OPENSSL_LIBS="-L${OPENSSLLIB} -lssl" \
- AZLIB_CFLAGS=-I${INCLUDEDIR} ZLIB_LIBS="-L${LIBDIR} -lz" \
+ ZLIB_CFLAGS=-I${INCLUDEDIR} ZLIB_LIBS="-L${LIBDIR} -lz" \
ac_cv_path_RST2HTML=no
GNU_CONFIGURE= yes
USE_GNOME= libxml2
@@ -29,61 +30,15 @@ USE_OPENSSL= yes
USE_XZ= yes
USES= pathfix pkgconfig
-MAN1= aria2c.1
-MANLANG= "" pt ru
-PLIST_FILES= bin/aria2c
-PLIST_DIRSTRY= man/ru/man1 \
- man/ru \
- man/pt/man1 \
- man/pt
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MCA_BUNDLE}
-RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
-CONFIGURE_ARGS+=--with-ca-bundle=${LOCALBASE}/share/certs/ca-root-nss.crt
-.else
-CONFIGURE_ARGS+=--without-ca-bundle
-.endif
-
-.if ${PORT_OPTIONS:MDOCS}
-PLIST_FILES+= %%DOCSDIR%%/README \
- %%DOCSDIR%%/README.html \
- %%DOCSDIR%%/README.rst \
- %%DOCSDIR%%/bash_completion/README.txt \
- %%DOCSDIR%%/bash_completion/aria2c \
- %%DOCSDIR%%/xmlrpc/README.txt \
- %%DOCSDIR%%/xmlrpc/aria2mon \
- %%DOCSDIR%%/xmlrpc/aria2rpc
-PLIST_DIRS= %%DOCSDIR%%/xmlrpc \
- %%DOCSDIR%%/bash_completion \
- %%DOCSDIR%%
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-CONFIGURE_ARGS+=--with-libintl-prefix=${LOCALBASE}
-USES+= gettext
-LANGS= en@boldquot en@quot fil kk oc zh_HK
-LANGS_MTREE= ar bg bn ca da de el es fa fi fr he hr hu id it ja ko ms nb nl \
- nn pl pt pt_BR ro ru sk sr sv th tr uk vi zh_CN zh_TW
-.for lang in ${LANGS} ${LANGS_MTREE}
-PLIST_FILES+= share/locale/${lang}/LC_MESSAGES/${PORTNAME}.mo
-.endfor
-.for lang in ${LANGS}
-PLIST_DIRSTRY+= share/locale/${lang}/LC_MESSAGES \
- share/locale/${lang}
-.endfor
-.else
-CONFIGURE_ARGS+=--disable-nls
-.endif
-
-.if ${PORT_OPTIONS:MSQLITE}
-CONFIGURE_ARGS+=--with-sqlite3
-USE_SQLITE= yes
-.else
-CONFIGURE_ARGS+=--without-sqlite3
-.endif
+CA_BUNDLE_CONFIGURE_OFF=--without-ca-bundle
+CA_BUNDLE_CONFIGURE_ON= --with-ca-bundle=${LOCALBASE}/share/certs/ca-root-nss.crt
+CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+NLS_CONFIGURE_OFF= --disable-nls
+NLS_CONFIGURE_ON= --with-libintl-prefix=${LOCALBASE}
+NLS_USES= gettext
+SQLITE_CONFIGURE_OFF= --without-sqlite3
+SQLITE_CONFIGURE_ON= --with-sqlite3
+SQLITE_USE= SQLITE=yes
.include <bsd.port.pre.mk>
@@ -98,7 +53,7 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${INSTALL_DATA} ${WRKSRC}/README.html ${DOCSDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/README.html ${STAGEDIR}${DOCSDIR}/
.endif
.include <bsd.port.post.mk>