aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2011-03-27 03:22:41 +0800
committernox <nox@FreeBSD.org>2011-03-27 03:22:41 +0800
commit10b47f9d058c282b3e2810bf73e136c50418b17b (patch)
treecb81f638b105ac5c6061f49a8bcf2fced8ff95e5 /www
parentecab3e163217d15532d54452e28ff882a9649876 (diff)
downloadfreebsd-ports-gnome-10b47f9d058c282b3e2810bf73e136c50418b17b.tar.gz
freebsd-ports-gnome-10b47f9d058c282b3e2810bf73e136c50418b17b.tar.zst
freebsd-ports-gnome-10b47f9d058c282b3e2810bf73e136c50418b17b.zip
http://www.vdr-wiki.de/wiki/index.php/Live-plugin
Live, the "Live Interactive VDR Environment", is a plugin providing the possibility to interactively control the VDR and some of it's plugins by a web interface. Unlike external utility programs that communicate with VDR and it's plugins by SVDRP, Live has direct access to VDR's data structures and is thus very fast. WWW: http://live.vdr-developer.org/
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/vdr-plugin-live/Makefile43
-rw-r--r--www/vdr-plugin-live/distinfo2
-rw-r--r--www/vdr-plugin-live/files/patch-Makefile24
-rw-r--r--www/vdr-plugin-live/files/patch-live.cpp16
-rw-r--r--www/vdr-plugin-live/files/patch-tools.cpp12
-rw-r--r--www/vdr-plugin-live/pkg-descr11
-rw-r--r--www/vdr-plugin-live/pkg-plist194
8 files changed, 303 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e4855e24b55c..2325f8411c28 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1861,6 +1861,7 @@
SUBDIR += uzbl
SUBDIR += validator
SUBDIR += varnish
+ SUBDIR += vdr-plugin-live
SUBDIR += vee
SUBDIR += videocache
SUBDIR += visitors
diff --git a/www/vdr-plugin-live/Makefile b/www/vdr-plugin-live/Makefile
new file mode 100644
index 000000000000..7be109e10c02
--- /dev/null
+++ b/www/vdr-plugin-live/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: vdr-plugin-live
+# Date created: Wed Apr 14 18:11:42 CEST 2010
+# Whom: Juergen Lock <nox@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vdr-plugin-live
+PORTVERSION= 0.2.0s20110303
+PORTREVISION= 2
+CATEGORIES= www multimedia
+MASTER_SITES= http://live.vdr-developer.org/downloads/:release \
+ LOCAL/nox/:snapshot
+DISTNAME= ${PORTNAME:S/-plugin-/-/}-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:snapshot
+
+MAINTAINER= nox@FreeBSD.org
+COMMENT= Video Disk Recorder - live web plugin
+
+LIB_DEPENDS+= tntnet:${PORTSDIR}/www/tntnet \
+ pcre:${PORTSDIR}/devel/pcre
+
+USE_BZIP2= yes
+PATCH_STRIP= -p1
+PORTDOCS= COPYING README
+MAKE_JOBS_SAFE= yes
+WRKSRC= ${WRKDIR}/vdr-plugin-${PLUGIN}
+MAKE_ARGS+= INCLUDES="-I$(LOCALBASE)/include -I${WRKSRC}"
+
+.include "${.CURDIR}/../../multimedia/vdr/Makefile.plugins"
+
+post-patch: post-patch-plugin
+
+post-install: post-install-pluginlocales
+ (cd ${WRKSRC}/${PLUGIN} && \
+ ${COPYTREE_SHARE} \* ${PREFIX}/etc/vdr/plugins/${PLUGIN} )
+ ${CHOWN} -R ${VDR_USER}:${VDR_GROUP} ${PREFIX}/etc/vdr/plugins/${PLUGIN}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/vdr-plugin-live/distinfo b/www/vdr-plugin-live/distinfo
new file mode 100644
index 000000000000..f5053a5271dc
--- /dev/null
+++ b/www/vdr-plugin-live/distinfo
@@ -0,0 +1,2 @@
+SHA256 (vdr/vdr-live-0.2.0s20110303.tar.bz2) = d1a50c8c25f1b8a563c14f8c94cddd61a53764484322d177c506954e6f993462
+SIZE (vdr/vdr-live-0.2.0s20110303.tar.bz2) = 1995550
diff --git a/www/vdr-plugin-live/files/patch-Makefile b/www/vdr-plugin-live/files/patch-Makefile
new file mode 100644
index 000000000000..e65d8489b57e
--- /dev/null
+++ b/www/vdr-plugin-live/files/patch-Makefile
@@ -0,0 +1,24 @@
+--- a/Makefile
++++ b/Makefile
+@@ -151,7 +151,11 @@ $(VERSIONSUFFIX): FORCE
+
+ libvdr-$(PLUGIN).so: $(VERSIONSUFFIX) $(SUBDIRS) $(PLUGINOBJS)
+ $(CXX) $(LDFLAGS) -shared -o $@ $(PLUGINOBJS) -Wl,--whole-archive $(WEBLIBS) -Wl,--no-whole-archive $(LIBS)
++ifdef FREEBSD
++ @cp -f $@ $(LIBDIR)/$@.$(APIVERSION)
++else
+ @cp --remove-destination $@ $(LIBDIR)/$@.$(APIVERSION)
++endif
+
+ ifneq ($(TNTVERS7),yes)
+ @echo ""
+@@ -189,6 +193,9 @@ clean: $(SUBDIRS)
+ @-rm -f $(PLUGINOBJS) $(DEPFILE) *.so *.tgz core* *~
+ @-rm -f $(VERSIONSUFFIX)
+
++install:
++ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) $(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)
++
+ .PRECIOUS: $(I18Npo)
+
+ FORCE:
diff --git a/www/vdr-plugin-live/files/patch-live.cpp b/www/vdr-plugin-live/files/patch-live.cpp
new file mode 100644
index 000000000000..2bd2f0bc0756
--- /dev/null
+++ b/www/vdr-plugin-live/files/patch-live.cpp
@@ -0,0 +1,16 @@
+--- a/live.cpp
++++ b/live.cpp
+@@ -42,7 +42,13 @@ bool Plugin::ProcessArgs(int argc, char
+
+ bool Plugin::Start(void)
+ {
++#ifdef __FreeBSD__
++ char buf[PATH_MAX];
++
++ m_configDirectory = realpath(cPlugin::ConfigDirectory( PLUGIN_NAME_I18N ), buf);
++#else
+ m_configDirectory = canonicalize_file_name(cPlugin::ConfigDirectory( PLUGIN_NAME_I18N ));
++#endif
+
+ #if VDRVERSNUM < 10507
+ RegisterI18n( vdrlive::Phrases );
diff --git a/www/vdr-plugin-live/files/patch-tools.cpp b/www/vdr-plugin-live/files/patch-tools.cpp
new file mode 100644
index 000000000000..c96edad93ba5
--- /dev/null
+++ b/www/vdr-plugin-live/files/patch-tools.cpp
@@ -0,0 +1,12 @@
+--- a/tools.cpp
++++ a/tools.cpp
+@@ -12,6 +12,9 @@
+ #include "tools.h"
+ #include "md5.h"
+
++#ifdef __FreeBSD__
++#define O_LARGEFILE 0
++#endif
+
+ using namespace std;
+ using namespace tnt;
diff --git a/www/vdr-plugin-live/pkg-descr b/www/vdr-plugin-live/pkg-descr
new file mode 100644
index 000000000000..e7ae8578b2d1
--- /dev/null
+++ b/www/vdr-plugin-live/pkg-descr
@@ -0,0 +1,11 @@
+http://www.vdr-wiki.de/wiki/index.php/Live-plugin
+
+Live, the "Live Interactive VDR Environment", is a plugin providing the
+possibility to interactively control the VDR and some of it's plugins by
+a web interface.
+
+Unlike external utility programs that communicate with VDR and it's plugins
+by SVDRP, Live has direct access to VDR's data structures and is thus very
+fast.
+
+WWW: http://live.vdr-developer.org/
diff --git a/www/vdr-plugin-live/pkg-plist b/www/vdr-plugin-live/pkg-plist
new file mode 100644
index 000000000000..8bcd35397a63
--- /dev/null
+++ b/www/vdr-plugin-live/pkg-plist
@@ -0,0 +1,194 @@
+lib/vdr/libvdr-live.so.1.7.17
+etc/vdr/plugins/live/css/DatePicker.css
+etc/vdr/plugins/live/css/siteprefs.css
+etc/vdr/plugins/live/img/active.png
+etc/vdr/plugins/live/img/arrow.png
+etc/vdr/plugins/live/img/arrow_rec.gif
+etc/vdr/plugins/live/img/bg_box_h.png
+etc/vdr/plugins/live/img/bg_box_l.png
+etc/vdr/plugins/live/img/bg_box_r.png
+etc/vdr/plugins/live/img/bg_header_h.png
+etc/vdr/plugins/live/img/bg_header_l.png
+etc/vdr/plugins/live/img/bg_header_r.png
+etc/vdr/plugins/live/img/bg_line.png
+etc/vdr/plugins/live/img/bg_line_top.png
+etc/vdr/plugins/live/img/bg_tools.png
+etc/vdr/plugins/live/img/button_blue.png
+etc/vdr/plugins/live/img/button_green.png
+etc/vdr/plugins/live/img/button_new.png
+etc/vdr/plugins/live/img/button_red.png
+etc/vdr/plugins/live/img/button_yellow.png
+etc/vdr/plugins/live/img/close.png
+etc/vdr/plugins/live/img/close_red.png
+etc/vdr/plugins/live/img/del.png
+etc/vdr/plugins/live/img/edit.png
+etc/vdr/plugins/live/img/english.png
+etc/vdr/plugins/live/img/favicon.ico
+etc/vdr/plugins/live/img/ffw.png
+etc/vdr/plugins/live/img/file.png
+etc/vdr/plugins/live/img/folder_closed.png
+etc/vdr/plugins/live/img/folder_open.png
+etc/vdr/plugins/live/img/german.png
+etc/vdr/plugins/live/img/help.png
+etc/vdr/plugins/live/img/imdb.png
+etc/vdr/plugins/live/img/inactive.png
+etc/vdr/plugins/live/img/info-win-b-l.png
+etc/vdr/plugins/live/img/info-win-b-r.png
+etc/vdr/plugins/live/img/info-win-m-l.png
+etc/vdr/plugins/live/img/info-win-m-r.png
+etc/vdr/plugins/live/img/info-win-t-l.png
+etc/vdr/plugins/live/img/info-win-t-r.png
+etc/vdr/plugins/live/img/logo.png
+etc/vdr/plugins/live/img/logo_login.png
+etc/vdr/plugins/live/img/menu_line_bg.png
+etc/vdr/plugins/live/img/minus.png
+etc/vdr/plugins/live/img/movie.png
+etc/vdr/plugins/live/img/on_dvd.png
+etc/vdr/plugins/live/img/msgbar_line_bg.png
+etc/vdr/plugins/live/img/one_downarrow.png
+etc/vdr/plugins/live/img/one_uparrow.png
+etc/vdr/plugins/live/img/pause.png
+etc/vdr/plugins/live/img/play.png
+etc/vdr/plugins/live/img/plus.png
+etc/vdr/plugins/live/img/record.png
+etc/vdr/plugins/live/img/record_timer.png
+etc/vdr/plugins/live/img/reload.png
+etc/vdr/plugins/live/img/remotecontrol.jpg
+etc/vdr/plugins/live/img/rounded-box-blue-bl.png
+etc/vdr/plugins/live/img/rounded-box-blue-br.png
+etc/vdr/plugins/live/img/rounded-box-blue-ml.png
+etc/vdr/plugins/live/img/rounded-box-blue-mr.png
+etc/vdr/plugins/live/img/rounded-box-blue-tl.png
+etc/vdr/plugins/live/img/rounded-box-blue-tr.png
+etc/vdr/plugins/live/img/rounded-box-green-bl.png
+etc/vdr/plugins/live/img/rounded-box-green-br.png
+etc/vdr/plugins/live/img/rounded-box-green-ml.png
+etc/vdr/plugins/live/img/rounded-box-green-mr.png
+etc/vdr/plugins/live/img/rounded-box-green-tl.png
+etc/vdr/plugins/live/img/rounded-box-green-tr.png
+etc/vdr/plugins/live/img/rounded-box-orange-bl.png
+etc/vdr/plugins/live/img/rounded-box-orange-br.png
+etc/vdr/plugins/live/img/rounded-box-orange-ml.png
+etc/vdr/plugins/live/img/rounded-box-orange-mr.png
+etc/vdr/plugins/live/img/rounded-box-orange-tl.png
+etc/vdr/plugins/live/img/rounded-box-orange-tr.png
+etc/vdr/plugins/live/img/rounded-box-redwine-bl.png
+etc/vdr/plugins/live/img/rounded-box-redwine-br.png
+etc/vdr/plugins/live/img/rounded-box-redwine-ml.png
+etc/vdr/plugins/live/img/rounded-box-redwine-mr.png
+etc/vdr/plugins/live/img/rounded-box-redwine-tl.png
+etc/vdr/plugins/live/img/rounded-box-redwine-tr.png
+etc/vdr/plugins/live/img/rwd.png
+etc/vdr/plugins/live/img/search.png
+etc/vdr/plugins/live/img/stop.png
+etc/vdr/plugins/live/img/stop_update.png
+etc/vdr/plugins/live/img/stream_button.png
+etc/vdr/plugins/live/img/timerconflict.gif
+etc/vdr/plugins/live/img/transparent.png
+etc/vdr/plugins/live/img/tv.jpg
+etc/vdr/plugins/live/img/zap.png
+etc/vdr/plugins/live/js/live/browserwin.js
+etc/vdr/plugins/live/js/live/hinttips.js
+etc/vdr/plugins/live/js/live/infowin.js
+etc/vdr/plugins/live/js/live/liveajax.js
+etc/vdr/plugins/live/js/live/pageenhance.js
+etc/vdr/plugins/live/js/live/vdr_status.js
+etc/vdr/plugins/live/js/live/vlc.js
+etc/vdr/plugins/live/js/mootools/DatePicker.js
+etc/vdr/plugins/live/js/mootools/mootools.v1.11.js
+etc/vdr/plugins/live/js/mootools/readme.mootools.config
+etc/vdr/plugins/live/themes/marine/css/theme.css
+etc/vdr/plugins/live/themes/marine/img/zap.png
+etc/vdr/plugins/live/themes/orange-blue/css/theme.css
+etc/vdr/plugins/live/themes/orange-blue/img/bg_box_h.png
+etc/vdr/plugins/live/themes/orange-blue/img/bg_box_l.png
+etc/vdr/plugins/live/themes/orange-blue/img/bg_box_r.png
+etc/vdr/plugins/live/themes/orange-blue/img/bg_header_h.png
+etc/vdr/plugins/live/themes/orange-blue/img/bg_header_l.png
+etc/vdr/plugins/live/themes/orange-blue/img/bg_header_r.png
+etc/vdr/plugins/live/themes/orange-blue/img/bg_line.png
+etc/vdr/plugins/live/themes/orange-blue/img/bg_line_top.png
+etc/vdr/plugins/live/themes/orange-blue/img/bg_tools.png
+etc/vdr/plugins/live/themes/orange-blue/img/info-win-b-l.png
+etc/vdr/plugins/live/themes/orange-blue/img/info-win-b-r.png
+etc/vdr/plugins/live/themes/orange-blue/img/info-win-m-l.png
+etc/vdr/plugins/live/themes/orange-blue/img/info-win-m-r.png
+etc/vdr/plugins/live/themes/orange-blue/img/info-win-t-l.png
+etc/vdr/plugins/live/themes/orange-blue/img/info-win-t-r.png
+etc/vdr/plugins/live/themes/orange-blue/img/logo.png
+etc/vdr/plugins/live/themes/orange-blue/img/menu_line_bg.png
+etc/vdr/plugins/live/themes/orange-blue/img/remotecontrol.jpg
+etc/vdr/plugins/live/themes/orange-blue/img/tv.jpg
+etc/vdr/plugins/live/themes/orange-blue/img/zap.png
+etc/vdr/plugins/live/themes/redwine/css/theme.css
+etc/vdr/plugins/live/themes/redwine/img/bg_box_h.png
+etc/vdr/plugins/live/themes/redwine/img/bg_box_l.png
+etc/vdr/plugins/live/themes/redwine/img/bg_box_r.png
+etc/vdr/plugins/live/themes/redwine/img/bg_header_h.png
+etc/vdr/plugins/live/themes/redwine/img/bg_header_l.png
+etc/vdr/plugins/live/themes/redwine/img/bg_header_r.png
+etc/vdr/plugins/live/themes/redwine/img/bg_line.png
+etc/vdr/plugins/live/themes/redwine/img/bg_line_top.png
+etc/vdr/plugins/live/themes/redwine/img/bg_tools.png
+etc/vdr/plugins/live/themes/redwine/img/menu_line_bg.png
+etc/vdr/plugins/live/themes/redwine/img/zap.png
+etc/vdr/plugins/live/themes/veltliner/css/theme.css
+etc/vdr/plugins/live/themes/veltliner/img/bg_box_h.png
+etc/vdr/plugins/live/themes/veltliner/img/bg_box_h1.png
+etc/vdr/plugins/live/themes/veltliner/img/bg_box_l.png
+etc/vdr/plugins/live/themes/veltliner/img/bg_box_r.png
+etc/vdr/plugins/live/themes/veltliner/img/bg_header_h.png
+etc/vdr/plugins/live/themes/veltliner/img/bg_header_l.png
+etc/vdr/plugins/live/themes/veltliner/img/bg_header_r.png
+etc/vdr/plugins/live/themes/veltliner/img/bg_line.png
+etc/vdr/plugins/live/themes/veltliner/img/bg_line_top.png
+etc/vdr/plugins/live/themes/veltliner/img/bg_tools.png
+etc/vdr/plugins/live/themes/veltliner/img/button_blue.png
+etc/vdr/plugins/live/themes/veltliner/img/info-win-t-l.png
+etc/vdr/plugins/live/themes/veltliner/img/info-win-t-r.png
+etc/vdr/plugins/live/themes/veltliner/img/logo.png
+etc/vdr/plugins/live/themes/veltliner/img/logo_login.png
+etc/vdr/plugins/live/themes/veltliner/img/menu_line_bg.png
+etc/vdr/plugins/live/themes/veltliner/img/zap.png
+@dirrm etc/vdr/plugins/live/themes/marine/css
+@dirrm etc/vdr/plugins/live/themes/marine/img
+@dirrm etc/vdr/plugins/live/themes/marine
+@dirrm etc/vdr/plugins/live/themes/orange-blue/css
+@dirrm etc/vdr/plugins/live/themes/orange-blue/img
+@dirrm etc/vdr/plugins/live/themes/orange-blue
+@dirrm etc/vdr/plugins/live/themes/redwine/css
+@dirrm etc/vdr/plugins/live/themes/redwine/img
+@dirrm etc/vdr/plugins/live/themes/redwine
+@dirrm etc/vdr/plugins/live/themes/veltliner/css
+@dirrm etc/vdr/plugins/live/themes/veltliner/img
+@dirrm etc/vdr/plugins/live/themes/veltliner
+@dirrm etc/vdr/plugins/live/themes
+@dirrm etc/vdr/plugins/live/js/mootools
+@dirrm etc/vdr/plugins/live/js/live
+@dirrm etc/vdr/plugins/live/js
+@dirrm etc/vdr/plugins/live/img
+@dirrm etc/vdr/plugins/live/css
+@dirrmtry etc/vdr/plugins/live
+%%NLS%%share/locale/ca_ES/LC_MESSAGES/vdr-live.mo
+%%NLS%%share/locale/cs_CZ/LC_MESSAGES/vdr-live.mo
+%%NLS%%share/locale/da_DK/LC_MESSAGES/vdr-live.mo
+%%NLS%%share/locale/de_DE/LC_MESSAGES/vdr-live.mo
+%%NLS%%share/locale/el_GR/LC_MESSAGES/vdr-live.mo
+%%NLS%%share/locale/es_ES/LC_MESSAGES/vdr-live.mo
+%%NLS%%share/locale/et_EE/LC_MESSAGES/vdr-live.mo
+%%NLS%%share/locale/fi_FI/LC_MESSAGES/vdr-live.mo
+%%NLS%%share/locale/fr_FR/LC_MESSAGES/vdr-live.mo
+%%NLS%%share/locale/hr_HR/LC_MESSAGES/vdr-live.mo
+%%NLS%%share/locale/hu_HU/LC_MESSAGES/vdr-live.mo
+%%NLS%%share/locale/it_IT/LC_MESSAGES/vdr-live.mo
+%%NLS%%share/locale/lt_LT/LC_MESSAGES/vdr-live.mo
+%%NLS%%share/locale/nl_NL/LC_MESSAGES/vdr-live.mo
+%%NLS%%share/locale/nn_NO/LC_MESSAGES/vdr-live.mo
+%%NLS%%share/locale/pl_PL/LC_MESSAGES/vdr-live.mo
+%%NLS%%share/locale/pt_PT/LC_MESSAGES/vdr-live.mo
+%%NLS%%share/locale/ro_RO/LC_MESSAGES/vdr-live.mo
+%%NLS%%share/locale/ru_RU/LC_MESSAGES/vdr-live.mo
+%%NLS%%share/locale/sk_SK/LC_MESSAGES/vdr-live.mo
+%%NLS%%share/locale/sl_SI/LC_MESSAGES/vdr-live.mo
+%%NLS%%share/locale/sv_SE/LC_MESSAGES/vdr-live.mo
+%%NLS%%share/locale/tr_TR/LC_MESSAGES/vdr-live.mo