aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2015-02-26 01:42:58 +0800
committeradamw <adamw@FreeBSD.org>2015-02-26 01:42:58 +0800
commit10f4a1c5bd61ec59c2ea0e071ab37e3667e6e127 (patch)
tree253656c397380dd259f2ed9578e01d47b7b189c4 /www
parentba5870b0c8d2b5c12a01e1dbaaf4b82ee67fe9ed (diff)
downloadfreebsd-ports-gnome-10f4a1c5bd61ec59c2ea0e071ab37e3667e6e127.tar.gz
freebsd-ports-gnome-10f4a1c5bd61ec59c2ea0e071ab37e3667e6e127.tar.zst
freebsd-ports-gnome-10f4a1c5bd61ec59c2ea0e071ab37e3667e6e127.zip
Remove a number of unused dependencies.
p5-HTTP-Server-Simple-PSGI support was removed p5-LWP-Protocol-PSGI is for testing p5-Path-Class isn't used p5-URI-Escape-XS isn't used; it wants p5-URI instead While here, add an XS option that depends on optional XS modules: p5-CGI-Deurl-XS p5-URL-Encode-XS p5-JSON-XS p5-YAML-LibYAML (moved from BUILD_DEPENDS to here) PORTREVISION bump for these changes.
Diffstat (limited to 'www')
-rw-r--r--www/p5-Dancer2/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/www/p5-Dancer2/Makefile b/www/p5-Dancer2/Makefile
index 75fd565a3d03..89a6810052f9 100644
--- a/www/p5-Dancer2/Makefile
+++ b/www/p5-Dancer2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Dancer2
PORTVERSION= 0.159001
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -24,13 +25,10 @@ RUN_DEPENDS= p5-App-Cmd>=0:${PORTSDIR}/devel/p5-App-Cmd \
p5-HTTP-Body>=0:${PORTSDIR}/www/p5-HTTP-Body \
p5-HTTP-Date>=0:${PORTSDIR}/www/p5-HTTP-Date \
p5-HTTP-Message>=0:${PORTSDIR}/www/p5-HTTP-Message \
- p5-HTTP-Server-Simple-PSGI>=0:${PORTSDIR}/www/p5-HTTP-Server-Simple-PSGI \
p5-JSON>=0:${PORTSDIR}/converters/p5-JSON \
- p5-LWP-Protocol-PSGI>=0.06:${PORTSDIR}/www/p5-LWP-Protocol-PSGI \
p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64 \
p5-Moo>=0.09014:${PORTSDIR}/devel/p5-Moo \
p5-MooX-Types-MooseLike-Numeric>=0:${PORTSDIR}/devel/p5-MooX-Types-MooseLike-Numeric \
- p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
p5-Plack>=0:${PORTSDIR}/www/p5-Plack \
p5-Plack-Middleware-FixMissingBodyInRedirect>=0:${PORTSDIR}/www/p5-Plack-Middleware-FixMissingBodyInRedirect \
p5-Plack-Middleware-RemoveRedundantBody>=0:${PORTSDIR}/www/p5-Plack-Middleware-RemoveRedundantBody \
@@ -38,16 +36,25 @@ RUN_DEPENDS= p5-App-Cmd>=0:${PORTSDIR}/devel/p5-App-Cmd \
p5-Safe-Isa>=0:${PORTSDIR}/devel/p5-Safe-Isa \
p5-Template-Tiny>=0:${PORTSDIR}/textproc/p5-Template-Tiny \
p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit \
- p5-URI-Escape-XS>=0:${PORTSDIR}/www/p5-URI-Escape-XS \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-YAML>=0.71:${PORTSDIR}/textproc/p5-YAML \
- p5-YAML-LibYAML>=0:${PORTSDIR}/textproc/p5-YAML-LibYAML \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-Memory-Cycle>=0:${PORTSDIR}/devel/p5-Test-Memory-Cycle \
p5-Test-MockTime>=0:${PORTSDIR}/devel/p5-Test-MockTime \
p5-Test-Fatal>0:${PORTSDIR}/devel/p5-Test-Fatal \
p5-Test-TCP>0:${PORTSDIR}/devel/p5-Test-TCP \
- p5-LWP-Protocol-https>0:${PORTSDIR}/www/p5-LWP-Protocol-https
+ p5-LWP-Protocol-https>0:${PORTSDIR}/www/p5-LWP-Protocol-https \
+ p5-LWP-Protocol-PSGI>=0.06:${PORTSDIR}/www/p5-LWP-Protocol-PSGI
+
+OPTIONS_DEFINE= XS
+XS_DESC= Use XS modules for speed boost
+
+XS_BUILD_DEPENDS= p5-CGI-Deurl-XS>=0:${PORTSDIR}/www/p5-CGI-Deurl-XS \
+ p5-JSON-XS>=0:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-URL-Encode-XS>=0:${PORTSDIR}/www/p5-URL-Encode-XS \
+ p5-YAML-LibYAML>=0:${PORTSDIR}/textproc/p5-YAML-LibYAML
+XS_RUN_DEPENDS= ${XS_BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure