aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-12-16 10:41:17 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-12-16 10:41:17 +0800
commit128cd89d09b1a49e8396c4a1b1e46a75f9e10e7c (patch)
tree9441eb291191500434066d17ddb32fc80d01b4f8 /www
parentae921aa3daeb5c0018c2ae101703975065fa52d7 (diff)
downloadfreebsd-ports-gnome-128cd89d09b1a49e8396c4a1b1e46a75f9e10e7c.tar.gz
freebsd-ports-gnome-128cd89d09b1a49e8396c4a1b1e46a75f9e10e7c.tar.zst
freebsd-ports-gnome-128cd89d09b1a49e8396c4a1b1e46a75f9e10e7c.zip
- Fix for amd64
A nasty bug strikes on systems, where size_t and unsigned int are different things -- such as most 64-bit systems. Stuffing the (size_t)-1 into unsigned int results in 0xffff, which is different from string::npos (0xffffffff)... Submitted by: Mikhail T. <mi+thun@aldan.algebra.com> (via e-mail)
Diffstat (limited to 'www')
-rw-r--r--www/wsdlpull/Makefile1
-rw-r--r--www/wsdlpull/files/patch-src__xmlpull__XmlUtils.cpp11
2 files changed, 12 insertions, 0 deletions
diff --git a/www/wsdlpull/Makefile b/www/wsdlpull/Makefile
index c5bd1d7cddff..f109348db845 100644
--- a/www/wsdlpull/Makefile
+++ b/www/wsdlpull/Makefile
@@ -8,6 +8,7 @@
PORTNAME= wsdlpull
PORTVERSION= 1.23
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}%20${PORTVERSION}
diff --git a/www/wsdlpull/files/patch-src__xmlpull__XmlUtils.cpp b/www/wsdlpull/files/patch-src__xmlpull__XmlUtils.cpp
new file mode 100644
index 000000000000..0e7ae3c1354d
--- /dev/null
+++ b/www/wsdlpull/files/patch-src__xmlpull__XmlUtils.cpp
@@ -0,0 +1,11 @@
+--- ./src/xmlpull/XmlUtils.cpp.orig 2009-12-16 02:36:41.855644800 +0000
++++ ./src/xmlpull/XmlUtils.cpp 2009-12-16 02:37:03.225260481 +0000
+@@ -212,7 +212,7 @@
+ // - use-case with a single '/' added (I am not sure this is conform to spec)
+ // #ifdef _WIN32
+ #if !defined(_WIN32)
+- unsigned int p;
++ size_t p;
+ if ((p=uri.find("file:///"))!=std::string::npos)
+ {
+ uri = uri.substr(p+7, uri.length()-p-7);