aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2007-01-26 04:20:34 +0800
committerarved <arved@FreeBSD.org>2007-01-26 04:20:34 +0800
commit17cb8ccde52e51ab3f1f926eb5f92432064a1329 (patch)
tree7f5b21446bf7d0d78ada7412ad7eca2d7901f54d /www
parent72be59aca0d1fc8bf2a58f874cffcb58ddf25556 (diff)
downloadfreebsd-ports-gnome-17cb8ccde52e51ab3f1f926eb5f92432064a1329.tar.gz
freebsd-ports-gnome-17cb8ccde52e51ab3f1f926eb5f92432064a1329.tar.zst
freebsd-ports-gnome-17cb8ccde52e51ab3f1f926eb5f92432064a1329.zip
Add llgal, a commandline image gallery generator
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/llgal/Makefile29
-rw-r--r--www/llgal/distinfo3
-rw-r--r--www/llgal/pkg-descr6
-rw-r--r--www/llgal/pkg-plist17
5 files changed, 56 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 36032510ce37..21551d745d0d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -251,6 +251,7 @@
SUBDIR += ljdeps
SUBDIR += ljpms
SUBDIR += ljsm
+ SUBDIR += llgal
SUBDIR += logtools
SUBDIR += lws
SUBDIR += lynx
diff --git a/www/llgal/Makefile b/www/llgal/Makefile
new file mode 100644
index 000000000000..e8efa11de608
--- /dev/null
+++ b/www/llgal/Makefile
@@ -0,0 +1,29 @@
+# New ports collection Makefile for: llgal
+# Date created: 2007-01-25
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= llgal
+PORTVERSION= 0.13.9
+CATEGORIES= www
+MASTER_SITES= http://download.gna.org/llgal/
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= Command-line online gallery generator
+
+BUILD_DEPENDS= ${SITE_PERL}/Image/Size.pm:${PORTSDIR}/graphics/p5-Image-Size \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext \
+ ${SITE_PERL}/Image/ExifTool.pm:${PORTSDIR}/graphics/p5-Image-ExifTool
+RUN_DEPENDS= ${SITE_PERL}/Image/Size.pm:${PORTSDIR}/graphics/p5-Image-Size \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext \
+ ${SITE_PERL}/Image/ExifTool.pm:${PORTSDIR}/graphics/p5-Image-ExifTool
+
+USE_BZIP2= yes
+USE_PERL5= yes
+USE_GMAKE= yes
+USE_GETTEXT= yes
+
+.include <bsd.port.mk>
diff --git a/www/llgal/distinfo b/www/llgal/distinfo
new file mode 100644
index 000000000000..b7b3c4dbe214
--- /dev/null
+++ b/www/llgal/distinfo
@@ -0,0 +1,3 @@
+MD5 (llgal-0.13.9.tar.bz2) = a76fbb238b132249870d4f5f0b08283a
+SHA256 (llgal-0.13.9.tar.bz2) = 9234e2d984bc28dfa5b12cbf8f5f6a7a554a0f4457f19a9d2bd57b1a988d4875
+SIZE (llgal-0.13.9.tar.bz2) = 76207
diff --git a/www/llgal/pkg-descr b/www/llgal/pkg-descr
new file mode 100644
index 000000000000..919deb68b4d0
--- /dev/null
+++ b/www/llgal/pkg-descr
@@ -0,0 +1,6 @@
+llgal is an easy and fast on-line gallery generator based on iGal.
+Its primary goal is to NOT require any boring useless expensive feature in
+your webserver, such as PHP, JavaScript, SQL, ...
+Thus, llgal generates static web-pages.
+
+WWW: http://home.gna.org/llgal/
diff --git a/www/llgal/pkg-plist b/www/llgal/pkg-plist
new file mode 100644
index 000000000000..6acd7fb12118
--- /dev/null
+++ b/www/llgal/pkg-plist
@@ -0,0 +1,17 @@
+bin/llgal
+etc/llgal/llgalrc
+%%SITE_PERL%%/Llgal/Config.pm
+%%SITE_PERL%%/Llgal/Utils.pm
+%%SITE_PERL%%/Llgal/Templates.pm
+%%SITE_PERL%%/Llgal/Messages.pm
+share/llgal/captions.header
+share/llgal/index.png
+share/llgal/indextemplate.html
+share/llgal/llgal.css
+share/llgal/next.png
+share/llgal/prev.png
+share/llgal/slidetemplate.html
+share/llgal/tile.png
+share/locale/fr/LC_MESSAGES/llgal.mo
+@dirrm %%SITE_PERL%%/Llgal
+@dirrm etc/llgal