aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-09-13 23:54:50 +0800
committersobomax <sobomax@FreeBSD.org>2002-09-13 23:54:50 +0800
commit17cc6ccb0b5ed8eaf231e1b216f4155118c9425c (patch)
tree675a56b89c1843ce24fd85a4faa28b388151ea09 /www
parent30dd1da80dcc9f53aa35bb4369aadc9e83e08a57 (diff)
downloadfreebsd-ports-gnome-17cc6ccb0b5ed8eaf231e1b216f4155118c9425c.tar.gz
freebsd-ports-gnome-17cc6ccb0b5ed8eaf231e1b216f4155118c9425c.tar.zst
freebsd-ports-gnome-17cc6ccb0b5ed8eaf231e1b216f4155118c9425c.zip
Don't assign ${RUN_DEPENDS}=${BUILD_DEPENDS} because it leads to sed_inplace
package leaking into dependency list on FreeBSD versions that don't support sed -i. Revealed by: work on upcoming GNOME tinderbox
Diffstat (limited to 'www')
-rw-r--r--www/p5-libwww/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/www/p5-libwww/Makefile b/www/p5-libwww/Makefile
index 2ff3cf798b5e..9757a8382aaa 100644
--- a/www/p5-libwww/Makefile
+++ b/www/p5-libwww/Makefile
@@ -20,7 +20,11 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/FTP.pm:${PORTSDIR}/net/p5-Net \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/FTP.pm:${PORTSDIR}/net/p5-Net \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser
PERL_CONFIGURE= yes