aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-12-22 13:31:48 +0800
committerkoobs <koobs@FreeBSD.org>2014-12-22 13:31:48 +0800
commit2118f7f2e136c4d0510d87e3cc6ff23892ac0bb4 (patch)
tree19c9395d4146217377032f6a07d0c83b3388f02e /www
parent34200ebbc2499a2ac13bbfa15f0ab8f015beca8f (diff)
downloadfreebsd-ports-gnome-2118f7f2e136c4d0510d87e3cc6ff23892ac0bb4.tar.gz
freebsd-ports-gnome-2118f7f2e136c4d0510d87e3cc6ff23892ac0bb4.tar.zst
freebsd-ports-gnome-2118f7f2e136c4d0510d87e3cc6ff23892ac0bb4.zip
security/py-requests-oauthlib: Update to 0.4.2
- Update to 0.4.2 - Switch distribution files from Github -> PyPi (CHEESESHOP) - Add TESTS option for running the test suite - Update RUN_DEPENDS and TEST_DEPENDS - Use modern Python framework bits - Remove unecessary patch (upstreamed) Changes: * https://github.com/requests/requests-oauthlib/blob/master/HISTORY.rst PR: 193097 Submitted by: Muhammad Moinur Rahman <5u623l20 at gmail com> (with changes)
Diffstat (limited to 'www')
-rw-r--r--www/py-requests-oauthlib/Makefile24
-rw-r--r--www/py-requests-oauthlib/distinfo4
-rw-r--r--www/py-requests-oauthlib/files/patch-setup.py12
3 files changed, 14 insertions, 26 deletions
diff --git a/www/py-requests-oauthlib/Makefile b/www/py-requests-oauthlib/Makefile
index 321aa6df8b16..b6042926fce0 100644
--- a/www/py-requests-oauthlib/Makefile
+++ b/www/py-requests-oauthlib/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= requests-oauthlib
-PORTVERSION= 0.3.2
-PORTREVISION= 2
+PORTVERSION= 0.4.2
CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= koobs@FreeBSD.org
@@ -12,18 +12,18 @@ COMMENT= OAuthlib authentication support for Requests
LICENSE= ISCL
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}oauthlib>=0.4.2:${PORTSDIR}/security/py-oauthlib \
- ${PYTHON_PKGNAMEPREFIX}requests1>0:${PORTSDIR}/www/py-requests1
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}oauthlib>=0.6.2:${PORTSDIR}/security/py-oauthlib \
+ {PYTHON_PKGNAMEPREFIX}requests>=2.0.0:${PORTSDIR}/www/py-requests
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock \
+ ${PYTHON_PKGNAMEPREFIX}pycrypto>0:${PORTSDIR}/security/py-pycrypto
-USE_GITHUB= yes
-GH_ACCOUNT= requests
-GH_TAGNAME= v${PORTVERSION}
-GH_COMMIT= 0b1fe5c
+OPTIONS_DEFINE= TESTS
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+TESTS_DESC= Install test suite dependencies
+TESTS_BUILD_DEPENDS= ${TEST_DEPENDS}
+
+USES= python
+USE_PYTHON= distutils autoplist
regression-test: build
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
diff --git a/www/py-requests-oauthlib/distinfo b/www/py-requests-oauthlib/distinfo
index 29e8f2d1baa4..deced9b8bfec 100644
--- a/www/py-requests-oauthlib/distinfo
+++ b/www/py-requests-oauthlib/distinfo
@@ -1,2 +1,2 @@
-SHA256 (requests-oauthlib-0.3.2.tar.gz) = 93f6252c16537d7d42ca6777e97425a7de801772afc2df5244ae65eaf5b74f51
-SIZE (requests-oauthlib-0.3.2.tar.gz) = 13926
+SHA256 (requests-oauthlib-0.4.2.tar.gz) = 9e0223b89518edac61a97b56ff78f271056ce08c8a17c6b644aef244fac83f23
+SIZE (requests-oauthlib-0.4.2.tar.gz) = 53341
diff --git a/www/py-requests-oauthlib/files/patch-setup.py b/www/py-requests-oauthlib/files/patch-setup.py
deleted file mode 100644
index ded2543b6486..000000000000
--- a/www/py-requests-oauthlib/files/patch-setup.py
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./setup.py.orig 2013-05-04 16:37:49.000000000 +1000
-+++ ./setup.py 2013-05-04 17:04:12.135652732 +1000
-@@ -43,6 +43,9 @@
- 'Programming Language :: Python :: 2.6',
- 'Programming Language :: Python :: 2.7',
- ),
-+ zip_safe=False,
-+ tests_require = ['mock'],
-+ test_suite="tests",
- )
-
-