aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2011-04-11 09:13:14 +0800
committerwen <wen@FreeBSD.org>2011-04-11 09:13:14 +0800
commit23cf794866eccf8adccbbb18c1f082c4ff36eaa7 (patch)
tree753a637289ba2e72ffbe5ff375f5882ffd63e78a /www
parent251dddb6821b92e133d021010f6a72dccbaf503a (diff)
downloadfreebsd-ports-gnome-23cf794866eccf8adccbbb18c1f082c4ff36eaa7.tar.gz
freebsd-ports-gnome-23cf794866eccf8adccbbb18c1f082c4ff36eaa7.tar.zst
freebsd-ports-gnome-23cf794866eccf8adccbbb18c1f082c4ff36eaa7.zip
LWP::Online attempts to answer, as accurately as it can, one of the
nastiest technical questions there is: Am I on the internet? This a problem that had no clean permanent solution, and for which you could just keep writing more and more functionality indefinitely, asymtopically approaching 100% correctness but never reaching it. And so LWP::Online is intended to do as good a job as possible, without having to resort to asking any human questions (who may well get it wrong anyway), and limiting itself to a finite amount of programming work and a reasonable level of memory overhead to load the code. WWW: http://search.cpan.org/dist/LWP-Online/ PR: ports/156260 Submitted by: milki <milki@rescomp.berkeley.edu>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-LWP-Online/Makefile25
-rw-r--r--www/p5-LWP-Online/distinfo2
-rw-r--r--www/p5-LWP-Online/pkg-descr14
-rw-r--r--www/p5-LWP-Online/pkg-plist5
5 files changed, 47 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index bdd31045ac49..f5cb5d4a1b80 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1085,6 +1085,7 @@
SUBDIR += p5-Kwiki
SUBDIR += p5-LWP-Authen-Wsse
SUBDIR += p5-LWP-ConnCache-MaxKeepAliveRequests
+ SUBDIR += p5-LWP-Online
SUBDIR += p5-LWP-UserAgent-Determined
SUBDIR += p5-LWP-UserAgent-POE
SUBDIR += p5-LWP-UserAgent-WithCache
diff --git a/www/p5-LWP-Online/Makefile b/www/p5-LWP-Online/Makefile
new file mode 100644
index 000000000000..bea751724a23
--- /dev/null
+++ b/www/p5-LWP-Online/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-LWP-Online
+# Date created: 2011-04-07
+# Whom: milki <milki@rescomp.berkeley.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= LWP-Online
+PORTVERSION= 1.07
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:ADAMK
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= milki@rescomp.bekreley.edu
+COMMENT= Checks if process has access to the web
+
+RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI
+
+PERL_CONFIGURE= yes
+
+MAN3= LWP::Online.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-LWP-Online/distinfo b/www/p5-LWP-Online/distinfo
new file mode 100644
index 000000000000..3faba495f403
--- /dev/null
+++ b/www/p5-LWP-Online/distinfo
@@ -0,0 +1,2 @@
+SHA256 (LWP-Online-1.07.tar.gz) = 4364db0d456ba28bee6f20acdd5789be838c1fe1d10c83a4b16949c287277f95
+SIZE (LWP-Online-1.07.tar.gz) = 25783
diff --git a/www/p5-LWP-Online/pkg-descr b/www/p5-LWP-Online/pkg-descr
new file mode 100644
index 000000000000..9e7d6b00d7a7
--- /dev/null
+++ b/www/p5-LWP-Online/pkg-descr
@@ -0,0 +1,14 @@
+LWP::Online attempts to answer, as accurately as it can, one of the
+nastiest technical questions there is: Am I on the internet?
+
+This a problem that had no clean permanent solution, and for
+which you could just keep writing more and more functionality
+indefinitely, asymtopically approaching 100% correctness but never
+reaching it.
+
+And so LWP::Online is intended to do as good a job as possible, without
+having to resort to asking any human questions (who may well get it
+wrong anyway), and limiting itself to a finite amount of programming
+work and a reasonable level of memory overhead to load the code.
+
+WWW: http://search.cpan.org/dist/LWP-Online/
diff --git a/www/p5-LWP-Online/pkg-plist b/www/p5-LWP-Online/pkg-plist
new file mode 100644
index 000000000000..51ec07c0d915
--- /dev/null
+++ b/www/p5-LWP-Online/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/LWP/Online.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/LWP/Online/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/LWP/Online
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/mach/auto/LWP
+@dirrmtry %%SITE_PERL%%/LWP