aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-07-27 23:57:30 +0800
committerpat <pat@FreeBSD.org>2002-07-27 23:57:30 +0800
commit25be85c3111c036a94ad776723950df463363c9a (patch)
tree88c1d957a97d26851a10684ab6a626397aafa835 /www
parentc25c9519f92734d67ec5a81ab23ca256de129c79 (diff)
downloadfreebsd-ports-gnome-25be85c3111c036a94ad776723950df463363c9a.tar.gz
freebsd-ports-gnome-25be85c3111c036a94ad776723950df463363c9a.tar.zst
freebsd-ports-gnome-25be85c3111c036a94ad776723950df463363c9a.zip
- Fix dependency paths and plist
- Add missing manpage Reviewed by: Autrijus Tang <autrijus@autrijus.org> (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/p5-Bundle-Slash/Makefile7
-rw-r--r--www/p5-Bundle-Slash/pkg-plist3
2 files changed, 8 insertions, 2 deletions
diff --git a/www/p5-Bundle-Slash/Makefile b/www/p5-Bundle-Slash/Makefile
index a9f70a1b3abf..87adf1128b87 100644
--- a/www/p5-Bundle-Slash/Makefile
+++ b/www/p5-Bundle-Slash/Makefile
@@ -22,7 +22,7 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-D
${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar \
${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
${SITE_PERL}/Net/Cmd.pm:${PORTSDIR}/net/p5-Net \
- ${SITE_PERL}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/HTML/Element.pm:${PORTSDIR}/www/p5-HTML-Tree \
${SITE_PERL}/Font/AFM.pm:${PORTSDIR}/x11-fonts/p5-Font-AFM \
@@ -32,7 +32,7 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-D
${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-Mysql \
${SITE_PERL}/Apache/DBI.pm:${PORTSDIR}/www/p5-Apache-DBI \
${SITE_PERL}/AppConfig.pm:${PORTSDIR}/devel/p5-AppConfig \
- ${SITE_PERL}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
+ ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
${SITE_PERL}/Mail/Sendmail.pm:${PORTSDIR}/mail/p5-Mail-Sendmail \
${SITE_PERL}/Email/Valid.pm:${PORTSDIR}/mail/p5-Email-Valid \
@@ -50,4 +50,7 @@ SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
PERL_CONFIGURE= yes
+MAN3= Bundle::Slash.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
.include <bsd.port.mk>
diff --git a/www/p5-Bundle-Slash/pkg-plist b/www/p5-Bundle-Slash/pkg-plist
index acbdba015851..1bc1903feba3 100644
--- a/www/p5-Bundle-Slash/pkg-plist
+++ b/www/p5-Bundle-Slash/pkg-plist
@@ -1,2 +1,5 @@
lib/perl5/site_perl/%%PERL_VER%%/Bundle/Slash.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Bundle/Slash/.packlist
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Bundle/Slash 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Bundle 2>/dev/null || true
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Bundle 2>/dev/null || true