aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorculot <culot@FreeBSD.org>2011-04-15 20:20:29 +0800
committerculot <culot@FreeBSD.org>2011-04-15 20:20:29 +0800
commit26c596103e6488ea970c71c3019789604875fc35 (patch)
tree79b92296fd3fea7a3905b6052bae0b5a988d1064 /www
parenta3f380d8f99eca48227bdeb3b16fc7a58a5a9c88 (diff)
downloadfreebsd-ports-gnome-26c596103e6488ea970c71c3019789604875fc35.tar.gz
freebsd-ports-gnome-26c596103e6488ea970c71c3019789604875fc35.tar.zst
freebsd-ports-gnome-26c596103e6488ea970c71c3019789604875fc35.zip
HTTP::Message contains classes useful for representing the messages
passed in HTTP style communication. These are classes representing requests, responses and the headers contained within them. WWW: http://search.cpan.org/dist/HTTP-Message/ This new port is needed to update www/p5-libwww.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTTP-Message/Makefile37
-rw-r--r--www/p5-HTTP-Message/distinfo2
-rw-r--r--www/p5-HTTP-Message/pkg-descr5
-rw-r--r--www/p5-HTTP-Message/pkg-plist16
5 files changed, 61 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index f8f2c3c98f3f..642a7344134f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1052,6 +1052,7 @@
SUBDIR += p5-HTTP-Headers-Fast
SUBDIR += p5-HTTP-Lite
SUBDIR += p5-HTTP-MHTTP
+ SUBDIR += p5-HTTP-Message
SUBDIR += p5-HTTP-MobileAgent
SUBDIR += p5-HTTP-MobileAgent-Plugin-Charset
SUBDIR += p5-HTTP-MobileAttribute
diff --git a/www/p5-HTTP-Message/Makefile b/www/p5-HTTP-Message/Makefile
new file mode 100644
index 000000000000..3a0564ea3289
--- /dev/null
+++ b/www/p5-HTTP-Message/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-HTTP-Message
+# Date created: 2011-04-15
+# Whom: Frederic Culot <culot@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Message
+PORTVERSION= 6.02
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Representation of HTTP style messages
+
+RUN_DEPENDS= p5-Compress-Raw-Zlib>=0:${PORTSDIR}/archivers/p5-Compress-Raw-Zlib \
+ p5-Encode-Locale>=1:${PORTSDIR}/converters/p5-Encode-Locale \
+ p5-HTML-Parser>=3.33:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-HTTP-Date>=6:${PORTSDIR}/www/p5-HTTP-Date \
+ p5-IO-Compress>=2.021:${PORTSDIR}/archivers/p5-IO-Compress \
+ p5-LWP-MediaTypes>=6:${PORTSDIR}/www/p5-LWP-MediaTypes \
+ p5-URI>=1.10:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTTP::Config.3 \
+ HTTP::Headers.3 \
+ HTTP::Headers::Util.3 \
+ HTTP::Message.3 \
+ HTTP::Request.3 \
+ HTTP::Request::Common.3 \
+ HTTP::Response.3 \
+ HTTP::Status.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTTP-Message/distinfo b/www/p5-HTTP-Message/distinfo
new file mode 100644
index 000000000000..1823bf97d787
--- /dev/null
+++ b/www/p5-HTTP-Message/distinfo
@@ -0,0 +1,2 @@
+SHA256 (HTTP-Message-6.02.tar.gz) = 2331b3c82e8a9674e596e4583f13a655d24d2e3c7165f3bdc6def4b5d4165181
+SIZE (HTTP-Message-6.02.tar.gz) = 49243
diff --git a/www/p5-HTTP-Message/pkg-descr b/www/p5-HTTP-Message/pkg-descr
new file mode 100644
index 000000000000..b2ca96c9b233
--- /dev/null
+++ b/www/p5-HTTP-Message/pkg-descr
@@ -0,0 +1,5 @@
+This module contains classes useful for representing the messages passed
+in HTTP style communication. These are classes representing requests,
+responses and the headers contained within them.
+
+WWW: http://search.cpan.org/dist/HTTP-Message/
diff --git a/www/p5-HTTP-Message/pkg-plist b/www/p5-HTTP-Message/pkg-plist
new file mode 100644
index 000000000000..0451d2fbd11c
--- /dev/null
+++ b/www/p5-HTTP-Message/pkg-plist
@@ -0,0 +1,16 @@
+%%SITE_PERL%%/HTTP/Config.pm
+%%SITE_PERL%%/HTTP/Headers.pm
+%%SITE_PERL%%/HTTP/Headers/Auth.pm
+%%SITE_PERL%%/HTTP/Headers/ETag.pm
+%%SITE_PERL%%/HTTP/Headers/Util.pm
+%%SITE_PERL%%/HTTP/Message.pm
+%%SITE_PERL%%/HTTP/Request.pm
+%%SITE_PERL%%/HTTP/Request/Common.pm
+%%SITE_PERL%%/HTTP/Response.pm
+%%SITE_PERL%%/HTTP/Status.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Message/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Message
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP
+@dirrm %%SITE_PERL%%/HTTP/Headers
+@dirrm %%SITE_PERL%%/HTTP/Request
+@dirrmtry %%SITE_PERL%%/HTTP