aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2012-11-20 19:31:45 +0800
committerrene <rene@FreeBSD.org>2012-11-20 19:31:45 +0800
commit327c6e11835e4efe1f4e3195f7db2ab698704ec0 (patch)
treeab765c6c8f7743fbe0b11d35da76c3ee1b1a9b6b /www
parentd1ec964a692ba7f44eb1a4dd7d8fa030b61aa601 (diff)
downloadfreebsd-ports-gnome-327c6e11835e4efe1f4e3195f7db2ab698704ec0.tar.gz
freebsd-ports-gnome-327c6e11835e4efe1f4e3195f7db2ab698704ec0.tar.zst
freebsd-ports-gnome-327c6e11835e4efe1f4e3195f7db2ab698704ec0.zip
Fix build when DISABLE_MAKE_JOBS is set.
While here pet portlint. Feature safe: yes
Diffstat (limited to 'www')
-rw-r--r--www/midori/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/www/midori/Makefile b/www/midori/Makefile
index 63d0f1472cf9..179d6115b495 100644
--- a/www/midori/Makefile
+++ b/www/midori/Makefile
@@ -27,8 +27,14 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+=--enable-libnotify \
--enable-addons \
--enable-docs \
- --disable-gtk3 \
- --jobs=${MAKE_JOBS_NUMBER}
+ --disable-gtk3
+
+# if user has set DISABLE_MAKE_JOBS, then MAKE_JOBS_NUMBER is undefined
+.if defined(DISABLE_MAKE_JOBS)
+CONFIGURE_ARGS+=--jobs=1
+.else
+CONFIGURE_ARGS+=--jobs=${MAKE_JOBS_NUMBER}
+.endif
MAKE_JOBS_SAFE= yes
HAS_CONFIGURE= yes
@@ -55,7 +61,7 @@ UNIQUE_DESC= Single instance support
CONFIGURE_ENV+= CC="${CC}"
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls