aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2002-06-18 03:20:04 +0800
committerglewis <glewis@FreeBSD.org>2002-06-18 03:20:04 +0800
commit348d8369e9f8ce01f03f72e6c12948b59f3b2bba (patch)
treece063d41e67d05f2ba34ceec7fe5c6d6e22f5aac /www
parentba1b78d5577410dc1c0b4e574554fa9596eb9c78 (diff)
downloadfreebsd-ports-gnome-348d8369e9f8ce01f03f72e6c12948b59f3b2bba.tar.gz
freebsd-ports-gnome-348d8369e9f8ce01f03f72e6c12948b59f3b2bba.tar.zst
freebsd-ports-gnome-348d8369e9f8ce01f03f72e6c12948b59f3b2bba.zip
Unbreak this port by using the included libneon and expat. The API for
neon has changed incompatibly since the last release of cadaver so it won't compile against our installed version of neon. The included version of neon doesn't appear to like the installed version of expat, so use the included version of that too. The load order of libraries needed changing to ensure that the included version of neon is used. These changes should be reverted if/when a newer release of cadaver catches up with the neon API.
Diffstat (limited to 'www')
-rw-r--r--www/cadaver/Makefile8
-rw-r--r--www/cadaver/files/patch-aa14
2 files changed, 13 insertions, 9 deletions
diff --git a/www/cadaver/Makefile b/www/cadaver/Makefile
index 22e61f422e93..3b17b73eac7b 100644
--- a/www/cadaver/Makefile
+++ b/www/cadaver/Makefile
@@ -12,10 +12,7 @@ MASTER_SITES= http://www.webdav.org/cadaver/
MAINTAINER= ports@FreeBSD.org
-BROKEN= "Does not compile"
-
-LIB_DEPENDS= neon.19:${PORTSDIR}/www/neon \
- intl.2:${PORTSDIR}/devel/gettext
+LIB_DEPENDS= intl.2:${PORTSDIR}/devel/gettext
.ifndef NO_OPENSSL
USE_OPENSSL= yes
@@ -25,7 +22,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib -lintl"
CONFIGURE_ARGS= --with-ssl=${OPENSSLBASE} \
--enable-netrc \
- --with-neon=${LOCALBASE}
+ --with-included-neon \
+ --with-included-expat
ALL_TARGET= cadaver
post-install:
diff --git a/www/cadaver/files/patch-aa b/www/cadaver/files/patch-aa
index 722e6cd9d638..10f3531ebe66 100644
--- a/www/cadaver/files/patch-aa
+++ b/www/cadaver/files/patch-aa
@@ -1,6 +1,8 @@
---- Makefile.in.orig Mon Jan 14 12:01:27 2002
-+++ Makefile.in Sat May 11 02:48:50 2002
-@@ -29,7 +29,7 @@
+$FreeBSD$
+
+--- Makefile.in.orig Mon Jun 17 12:02:32 2002
++++ Makefile.in Mon Jun 17 12:04:36 2002
+@@ -29,10 +29,10 @@
# Toolchain settings.
CC = @CC@
@@ -8,4 +10,8 @@
+CPPFLAGS = @DEFS@ @CPPFLAGS@ -I$(top_srcdir)/src -I${top_srcdir}/libneon
CFLAGS = @CFLAGS@ @SDEFS@
LDFLAGS = @LDFLAGS@
- LIBS = @LIBS@ @NEON_LIBS@
+-LIBS = @LIBS@ @NEON_LIBS@
++LIBS = @NEON_LIBS@ @LIBS@
+
+ TARGET = $(PACKAGE)
+ SUBDIRS = libneon @SUBDIRS@