aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2010-01-01 06:35:03 +0800
committerbrooks <brooks@FreeBSD.org>2010-01-01 06:35:03 +0800
commit3dc97d341b44447359be71c43c0949abc358dc6b (patch)
tree274e4be40da8d9cff8a35c1e5a34df57a5f7333a /www
parente2854c36a3f101b6f9ea90aae9b68e9b5973631f (diff)
downloadfreebsd-ports-gnome-3dc97d341b44447359be71c43c0949abc358dc6b.tar.gz
freebsd-ports-gnome-3dc97d341b44447359be71c43c0949abc358dc6b.tar.zst
freebsd-ports-gnome-3dc97d341b44447359be71c43c0949abc358dc6b.zip
The TracMath plugin allows embedded equations in wiki pages. Basically a
port of mt-math to trac. WWW: http://trac-hacks.org/wiki/TracMathPlugin
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/trac-math/Makefile56
-rw-r--r--www/trac-math/distinfo3
-rw-r--r--www/trac-math/files/pkg-message.in11
-rw-r--r--www/trac-math/pkg-descr4
-rw-r--r--www/trac-math/pkg-plist1
6 files changed, 76 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index c59c6759f67d..1987d25c4077 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1571,6 +1571,7 @@
SUBDIR += trac-ldap
SUBDIR += trac-macropost
SUBDIR += trac-mastertickets
+ SUBDIR += trac-math
SUBDIR += trac-mercurial
SUBDIR += trac-multirepos
SUBDIR += trac-nav
diff --git a/www/trac-math/Makefile b/www/trac-math/Makefile
new file mode 100644
index 000000000000..4244acb7608c
--- /dev/null
+++ b/www/trac-math/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: trac-math
+# Date created: Dec 31, 2009
+# Whom: Brooks Davis <brooks@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${PYDISTUTILS_PKGNAME:S;^Trac;;S;Plugin$;;:L}
+PORTVERSION= 0.1
+CATEGORIES= www math python
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= brooks
+PKGNAMEPREFIX= trac-
+
+MAINTAINER= brooks@freebsd.org
+COMMENT= Support for LaTeX math formulas in wiki pages
+
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac \
+ latex:${PORTSDIR}/print/teTeX-base
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+PYDISTUTILS_PKGNAME= TracMath
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
+
+# Maintainter targets below this point
+
+# Retrieve the latest version from SVN and package in a tarball.
+.if defined(BOOTSTRAP)
+FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
+do-fetch:
+ ${MKDIR} ${WRKDIR}
+ cd ${WRKDIR} && \
+ svn export http://trac-hacks.org/svn/tracmathplugin/ \
+ ${DISTNAME}
+ cd ${WRKDIR} && tar cvf ${DISTDIR}/${DISTNAME}.tar.gz ${DISTNAME}
+.endif
+
+# Create a pkg-plist after the package is installed.
+EGGDIR= ${PYTHON_SITELIBDIR}/${PYEASYINSTALL_EGG}
+PLIST_EGGDIR= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+build-plist:
+ ${FIND} ${EGGDIR} -type f | \
+ ${SED} -e 's|${EGGDIR}|${PLIST_EGGDIR}|' | \
+ ${SORT} > pkg-plist
+ ${FIND} ${EGGDIR} -type d | \
+ ${SED} -e 's|${EGGDIR}|@dirrm ${PLIST_EGGDIR}|' | \
+ ${SORT} -r >> pkg-plist
+
+.include <bsd.port.mk>
diff --git a/www/trac-math/distinfo b/www/trac-math/distinfo
new file mode 100644
index 000000000000..b68139c36312
--- /dev/null
+++ b/www/trac-math/distinfo
@@ -0,0 +1,3 @@
+MD5 (math-0.1.tar.gz) = 8cf9beca984fe8717cb0e554c6994ef1
+SHA256 (math-0.1.tar.gz) = 6690f91e1905b6a3f213edb2a69e9268695a7acc1b3df921e963d453d9b2b2db
+SIZE (math-0.1.tar.gz) = 12800
diff --git a/www/trac-math/files/pkg-message.in b/www/trac-math/files/pkg-message.in
new file mode 100644
index 000000000000..364ae669fac1
--- /dev/null
+++ b/www/trac-math/files/pkg-message.in
@@ -0,0 +1,11 @@
+To use the plugin, you must add at least the following to your trac.ini.
+
+ [tracmath]
+ latex_cmd = %%LOCALBASE%%/bin/latex
+ dvipng_cmd = %%LOCALBASE%%/bin/dvipng
+
+You may also wish to set:
+
+ cache_dir = <cache directory>
+ max_png = <max number of pngs in cache - defaults to 500>
+ use_dollars = enabled
diff --git a/www/trac-math/pkg-descr b/www/trac-math/pkg-descr
new file mode 100644
index 000000000000..7cd03b7abc9d
--- /dev/null
+++ b/www/trac-math/pkg-descr
@@ -0,0 +1,4 @@
+Allow embedded equations in wiki pages. Basically a port of mt-math to
+trac.
+
+WWW: http://trac-hacks.org/wiki/TracMathPlugin
diff --git a/www/trac-math/pkg-plist b/www/trac-math/pkg-plist
new file mode 100644
index 000000000000..ddf68a1c022f
--- /dev/null
+++ b/www/trac-math/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%