aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2002-11-24 04:49:41 +0800
committerdirk <dirk@FreeBSD.org>2002-11-24 04:49:41 +0800
commit4b5a5f5b608366dd0ddc6aeb03f333e34a88bc6b (patch)
tree5044e3d54c094b84deb293bd14a0df21f7cf7d5f /www
parentbb8d2e43bcdc4f62e3eb64ee9edbd1a21ae2e753 (diff)
downloadfreebsd-ports-gnome-4b5a5f5b608366dd0ddc6aeb03f333e34a88bc6b.tar.gz
freebsd-ports-gnome-4b5a5f5b608366dd0ddc6aeb03f333e34a88bc6b.tar.zst
freebsd-ports-gnome-4b5a5f5b608366dd0ddc6aeb03f333e34a88bc6b.zip
Back out last commit (autodetection of apache2) for now.
It's causing too many problems due to inclusion of bsd.port.pre.mk/ bsd.port.post.mk and Makefile.inc. This needs further investigation. Reported by: many
Diffstat (limited to 'www')
-rw-r--r--www/mod_php4/Makefile15
-rw-r--r--www/mod_php5/Makefile15
2 files changed, 4 insertions, 26 deletions
diff --git a/www/mod_php4/Makefile b/www/mod_php4/Makefile
index 4eede4b0f597..27264d970100 100644
--- a/www/mod_php4/Makefile
+++ b/www/mod_php4/Makefile
@@ -37,12 +37,6 @@ SLAVEDIRS= lang/php4
USE_BZIP2= yes
USE_SUBMAKE= yes
USE_AUTOCONF_VER=213
-
-.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/include/apache2/apr.h)
-WITH_APACHE2= yes
-.endif
-
.if defined(WITH_APACHE2)
APACHE_PORT?= ${PORTSDIR}/www/apache2
.else
@@ -91,14 +85,9 @@ SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
pre-fetch:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.php
-.if !defined(STANDALONE)
-.if !defined(WITH_APACHE2)
+.if !defined(STANDALONE) && !defined(WITH_APACHE2)
@${ECHO_CMD} "Define WITH_APACHE2 to build mod_php4 as an apache2 module."
@${ECHO_CMD} ""
-.else
- @${ECHO_CMD} "Building mod_php4 as an apache2 module."
- @${ECHO_CMD} ""
-.endif
.endif
post-install:
@@ -131,4 +120,4 @@ post-clean:
.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/mod_php5/Makefile b/www/mod_php5/Makefile
index 4eede4b0f597..27264d970100 100644
--- a/www/mod_php5/Makefile
+++ b/www/mod_php5/Makefile
@@ -37,12 +37,6 @@ SLAVEDIRS= lang/php4
USE_BZIP2= yes
USE_SUBMAKE= yes
USE_AUTOCONF_VER=213
-
-.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/include/apache2/apr.h)
-WITH_APACHE2= yes
-.endif
-
.if defined(WITH_APACHE2)
APACHE_PORT?= ${PORTSDIR}/www/apache2
.else
@@ -91,14 +85,9 @@ SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
pre-fetch:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.php
-.if !defined(STANDALONE)
-.if !defined(WITH_APACHE2)
+.if !defined(STANDALONE) && !defined(WITH_APACHE2)
@${ECHO_CMD} "Define WITH_APACHE2 to build mod_php4 as an apache2 module."
@${ECHO_CMD} ""
-.else
- @${ECHO_CMD} "Building mod_php4 as an apache2 module."
- @${ECHO_CMD} ""
-.endif
.endif
post-install:
@@ -131,4 +120,4 @@ post-clean:
.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>