aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-10-31 03:46:49 +0800
committerrm <rm@FreeBSD.org>2012-10-31 03:46:49 +0800
commit4baedc03414ceb95cbadd4d141dc7d99d83a724d (patch)
treeec2630c8f23bdce35d9e9f39e5726d194545aac1 /www
parent897043dd161481e896e09b191a992213dd0c65ea (diff)
downloadfreebsd-ports-gnome-4baedc03414ceb95cbadd4d141dc7d99d83a724d.tar.gz
freebsd-ports-gnome-4baedc03414ceb95cbadd4d141dc7d99d83a724d.tar.zst
freebsd-ports-gnome-4baedc03414ceb95cbadd4d141dc7d99d83a724d.zip
- do not directly depend on setuptools, use USE_DISTUTILS instead
- bump PORTREVISION because of dependency change - remove indefinite article in COMMENT - trim Makefile header - limit python version to 2.x only - simplify pkg-plist entries PR: 173171 Submitted by: rm (myself) Approved by: brooks (maintainer, by mail) Feature safe: yes
Diffstat (limited to 'www')
-rw-r--r--www/trac-fullblognotification/Makefile20
-rw-r--r--www/trac-fullblognotification/pkg-plist42
2 files changed, 26 insertions, 36 deletions
diff --git a/www/trac-fullblognotification/Makefile b/www/trac-fullblognotification/Makefile
index a8af4e3f3e86..b0ebfa7958d0 100644
--- a/www/trac-fullblognotification/Makefile
+++ b/www/trac-fullblognotification/Makefile
@@ -1,12 +1,9 @@
-# New ports collection makefile for: trac-fullblog
-# Date created: January 9, 2009
-# Whom: Brooks Davis <brooks@freebsd.org>
-#
+# Created by: Brooks Davis <brooks@freebsd.org>
# $FreeBSD$
-#
PORTNAME= ${PYDISTUTILS_PKGNAME:S;^Trac;;S;Plugin$;;:L}
PORTVERSION= 0.2.1
+PORTREVISION= 1
CATEGORIES= www devel python
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= brooks
@@ -15,20 +12,13 @@ DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
DIST_SUBDIR= trac
MAINTAINER= brooks@FreeBSD.org
-COMMENT= This plugin provides a project Blog
+COMMENT= Plugin that provides a project Blog
RUN_DEPENDS+= trac-fullblog>=0.1.1:${PORTSDIR}/www/trac-fullblog
-BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
-USE_PYTHON= 2.5+
-NO_BUILD= yes
-USE_PYDISTUTILS=yes
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= easy_install
PYDISTUTILS_PKGNAME= TracFullBlogNotificationPlugin
-PYDISTUTILS_NOEGGINFO= yes
-PLIST_SUB= PORTVERSION=${PORTVERSION} \
- PYTHON_VER=${PYTHON_VER}
-
-EGG_PATH= ${PYTHONPREFIX_SITELIBDIR}/${PYDISTUTILS_PKGNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
.if defined(BOOTSTRAP)
do-fetch:
diff --git a/www/trac-fullblognotification/pkg-plist b/www/trac-fullblognotification/pkg-plist
index 8ee4248d0a49..f4df850a2802 100644
--- a/www/trac-fullblognotification/pkg-plist
+++ b/www/trac-fullblognotification/pkg-plist
@@ -1,21 +1,21 @@
-%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/EGG-INFO/PKG-INFO
-%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/EGG-INFO/SOURCES.txt
-%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/EGG-INFO/dependency_links.txt
-%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/EGG-INFO/entry_points.txt
-%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/EGG-INFO/not-zip-safe
-%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/EGG-INFO/requires.txt
-%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/EGG-INFO/top_level.txt
-%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification/__init__.py
-%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification/__init__.pyc
-%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification/__init__.pyo
-%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification/fullblognotification.py
-%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification/fullblognotification.pyc
-%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification/fullblognotification.pyo
-%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification/notification.py
-%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification/notification.pyc
-%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification/notification.pyo
-%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification/templates/fullblognotification_email_template.txt
-@dirrm %%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification/templates
-@dirrm %%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification
-@dirrm %%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/EGG-INFO
-@dirrm %%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/entry_points.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/requires.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/fullblognotification/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/fullblognotification/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/fullblognotification/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/fullblognotification/fullblognotification.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/fullblognotification/fullblognotification.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/fullblognotification/fullblognotification.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/fullblognotification/notification.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/fullblognotification/notification.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/fullblognotification/notification.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/fullblognotification/templates/fullblognotification_email_template.txt
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/fullblognotification/templates
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/fullblognotification
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%