aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authortabthorpe <tabthorpe@FreeBSD.org>2009-01-27 03:32:43 +0800
committertabthorpe <tabthorpe@FreeBSD.org>2009-01-27 03:32:43 +0800
commit4cb4b30cad8f1d2c4fb41874003b5401b678863d (patch)
treec9c3a4268e3dfb999e5b7f4696e8e5e30026fbb2 /www
parentdebd80cbbb3d8a5f7c6f698b96ff993f761b1671 (diff)
downloadfreebsd-ports-gnome-4cb4b30cad8f1d2c4fb41874003b5401b678863d.tar.gz
freebsd-ports-gnome-4cb4b30cad8f1d2c4fb41874003b5401b678863d.tar.zst
freebsd-ports-gnome-4cb4b30cad8f1d2c4fb41874003b5401b678863d.zip
PHP5 rewrite of HTTP_Request package. Provides cleaner API and pluggable
Adapters. Currently available are: * Socket adapter, based on old HTTP_Request code, * Curl adapter, wraps around PHP's cURL extension, * Mock adapter, to use for testing packages dependent on HTTP_Request2. Supports POST requests with data and file uploads, authentication, cookies, proxies, gzip and deflate encodings, monitoring the request progress with Observers. WWW: http://pear.php.net/package/HTTP_Request2/ PR: ports/130293 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/pear-HTTP_Request2/Makefile56
-rw-r--r--www/pear-HTTP_Request2/distinfo3
-rw-r--r--www/pear-HTTP_Request2/pkg-descr11
4 files changed, 71 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 3e491ea8d840..32f5f7fa9072 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1126,6 +1126,7 @@
SUBDIR += pear-HTTP_FloodControl
SUBDIR += pear-HTTP_Header
SUBDIR += pear-HTTP_Request
+ SUBDIR += pear-HTTP_Request2
SUBDIR += pear-HTTP_Server
SUBDIR += pear-HTTP_Session2
SUBDIR += pear-HTTP_Upload
diff --git a/www/pear-HTTP_Request2/Makefile b/www/pear-HTTP_Request2/Makefile
new file mode 100644
index 000000000000..fcef47fb14ae
--- /dev/null
+++ b/www/pear-HTTP_Request2/Makefile
@@ -0,0 +1,56 @@
+# Ports collection makefile for: pear-HTTP_Request2
+# Date created: 08 Jan 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP_Request2
+PORTVERSION= 0.2.0
+CATEGORIES= www pear
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= PEAR classes providing an easy way to perform HTTP requests
+
+BUILD_DEPENDS= ${PEARDIR}/Net/URL2.php:${PORTSDIR}/net/pear-Net_URL2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+OPTIONS= CURL "PHP CURL extension support" off \
+ FILEINFO "PHP FILEINFO extension support" off \
+ ZLIB "PECL ZLIB support" off
+
+CATEGORY= HTTP
+FILES= Request2.php \
+ Request2/Exception.php Request2/Adapter.php \
+ Request2/MultipartBody.php Request2/Response.php \
+ Request2/Adapter/Curl.php \
+ Request2/Adapter/Mock.php \
+ Request2/Adapter/Socket.php \
+ Request2/Observer/Log.php
+TESTS= AllTests.php ObserverTest.php Request2Test.php \
+ Request2/AllTests.php \
+ Request2/MultipartBodyTest.php \
+ Request2/ResponseTest.php \
+ Request2/Adapter/AllTests.php \
+ Request2/Adapter/MockTest.php \
+ _files/bug_15305 _files/response_cookies\
+ _files/response_gzip_broken _files/empty.gif \
+ _files/response_deflate _files/response_headers \
+ _files/plaintext.txt _files/response_gzip
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_CURL)
+USE_PHP+= curl
+.endif
+
+.if defined(WITH_FILEINFO)
+USE_PHP+= fileinfo
+.endif
+
+.if defined(WITH_ZLIB)
+USE_PHP+= zlib
+.endif
+
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/www/pear-HTTP_Request2/distinfo b/www/pear-HTTP_Request2/distinfo
new file mode 100644
index 000000000000..690155e09ea1
--- /dev/null
+++ b/www/pear-HTTP_Request2/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/HTTP_Request2-0.2.0.tgz) = c82e0619b1a19e90a72533972b439a03
+SHA256 (PEAR/HTTP_Request2-0.2.0.tgz) = b063912b08efa71556c925a8d3a9edf8db86b08202cc8300d42a1e871ba5a920
+SIZE (PEAR/HTTP_Request2-0.2.0.tgz) = 49399
diff --git a/www/pear-HTTP_Request2/pkg-descr b/www/pear-HTTP_Request2/pkg-descr
new file mode 100644
index 000000000000..afd6db141ee6
--- /dev/null
+++ b/www/pear-HTTP_Request2/pkg-descr
@@ -0,0 +1,11 @@
+PHP5 rewrite of HTTP_Request package. Provides cleaner API and pluggable
+Adapters. Currently available are:
+* Socket adapter, based on old HTTP_Request code,
+* Curl adapter, wraps around PHP's cURL extension,
+* Mock adapter, to use for testing packages dependent on HTTP_Request2.
+
+Supports POST requests with data and file uploads, authentication,
+cookies, proxies, gzip and deflate encodings, monitoring the request
+progress with Observers.
+
+WWW: http://pear.php.net/package/HTTP_Request2/