aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorshaun <shaun@FreeBSD.org>2006-09-05 05:57:54 +0800
committershaun <shaun@FreeBSD.org>2006-09-05 05:57:54 +0800
commit4e361b265960adbcf3fab06a8fd0b215aee8fb14 (patch)
tree7e2ad52027d5cb4ec77c8444acf6a7bd47b784e5 /www
parent2189253a265934febc98376d042fac3b88e06721 (diff)
downloadfreebsd-ports-gnome-4e361b265960adbcf3fab06a8fd0b215aee8fb14.tar.gz
freebsd-ports-gnome-4e361b265960adbcf3fab06a8fd0b215aee8fb14.tar.zst
freebsd-ports-gnome-4e361b265960adbcf3fab06a8fd0b215aee8fb14.zip
- Fix a bug in horde-passwd.
Submitted by: Danny Carroll
Diffstat (limited to 'www')
-rw-r--r--www/horde-passwd/Makefile5
-rw-r--r--www/horde-passwd/files/patch-lib_Driver.php12
2 files changed, 16 insertions, 1 deletions
diff --git a/www/horde-passwd/Makefile b/www/horde-passwd/Makefile
index 57a260c667fe..7c82b2d37869 100644
--- a/www/horde-passwd/Makefile
+++ b/www/horde-passwd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= horde-passwd
PORTVERSION= 3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www mail
MASTER_SITES= ftp://ftp.horde.org/pub/passwd/ \
ftp://ftp.planetmirror.com/pub/horde/passwd/ \
@@ -60,6 +60,9 @@ pre-configure:
@${SED} -e "s:/home/httpd/html/horde/passwd:${PWDDIR}:g" \
${FILESDIR}/httpd.conf.pwd > ${WRKDIR}/httpd-pwd.conf
+post-patch:
+ @${FIND} ${WRKSRC} -name "*.orig" -delete
+
do-install:
@${MKDIR} ${PWDDIR}
.for REP in ${SUB_DIRS}
diff --git a/www/horde-passwd/files/patch-lib_Driver.php b/www/horde-passwd/files/patch-lib_Driver.php
new file mode 100644
index 000000000000..e5472ef12db1
--- /dev/null
+++ b/www/horde-passwd/files/patch-lib_Driver.php
@@ -0,0 +1,12 @@
+--- lib/Driver.php.orig Wed Aug 23 13:18:54 2006
++++ lib/Driver.php Wed Aug 23 13:19:40 2006
+@@ -107,7 +107,8 @@
+ require_once dirname(__FILE__) . '/Driver/' . $driver . '.php';
+ $class = 'Passwd_Driver_' . $driver;
+ if (class_exists($class)) {
+- return $ret = &new $class($params);
++ $ret = &new $class($params);
++ return $ret;
+ } else {
+ Horde::fatal(PEAR::raiseError(sprintf(_("No such backend \"%s\" found."), $driver)), __FILE__, __LINE__);
+ }