aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2013-10-20 11:59:52 +0800
committerkoobs <koobs@FreeBSD.org>2013-10-20 11:59:52 +0800
commit5385a2caca175d9bb639821d4a8edc73877acad8 (patch)
tree48aee18bad18494cb0ccd2d9f8dea9a5e7b85ddb /www
parentdcb72a5413a86fcd71721929a9213f21787d6028 (diff)
downloadfreebsd-ports-gnome-5385a2caca175d9bb639821d4a8edc73877acad8.tar.gz
freebsd-ports-gnome-5385a2caca175d9bb639821d4a8edc73877acad8.tar.zst
freebsd-ports-gnome-5385a2caca175d9bb639821d4a8edc73877acad8.zip
www/mod_python3: Fix linking when Python is built with libs in LOCALBASE
- Bump port revision - While I'm here, sort Makefile entries - Add regression-test target with comment PR: ports/182185 Reported by: des, pkg-fallout Reviewed by: mva Approved by: maintainer timeout (1 month)
Diffstat (limited to 'www')
-rw-r--r--www/mod_python3/Makefile22
1 files changed, 14 insertions, 8 deletions
diff --git a/www/mod_python3/Makefile b/www/mod_python3/Makefile
index 5af033bae04b..7769e6558c80 100644
--- a/www/mod_python3/Makefile
+++ b/www/mod_python3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mod_python
PORTVERSION= 3.3.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www python
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
MASTER_SITE_SUBDIR= modpython
@@ -13,21 +13,27 @@ EXTRACT_SUFX= .tgz
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache module that embeds the Python interpreter within the server
-
USE_APACHE= 22
USE_PYTHON= yes
-MAKE_ARGS+= APXS=${APXS}
-
INSTALLS_EGGINFO= yes
-LATEST_LINK= mod_python3
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-apxs="${APXS}" --with-python="${PYTHON_CMD}" \
- --without-flex
+LATEST_LINK= mod_python3
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-apxs="${APXS}" \
+ --with-python="${PYTHON_CMD}" \
+ --without-flex
+
+LDFLAGS+= -L${LOCALBASE}/lib
+MAKE_ARGS+= APXS=${APXS}
MAKE_ENV= EXPR_COMPAT=yes
NO_STAGE= yes
post-install:
@${CAT} ${PKGMESSAGE}
+# You need to install apache & mod_python before you run this
+regression-test: build
+ @cd ${WRKSRC} && ${MAKE} check
+
.include <bsd.port.mk>